Beta release stream testing

posted
Total Posts
107
show more
brunn08
Since the new update sometimes when I restart the map the osu! auto-close.
ma3uk
I have delayed the cursor to 240 FPS, as set 60 FPS.
msh1107
Direct X was much better. :(
camas
No noticeable change apart from a few reset video settings. Working nicely.

Felt just like a normal update except I had to do it twice which was slightly confusing before I read this thread.
Smudge
Update process was perfect.

The game feels sort of laggy, input-wise (in Catch The Beat, at least for me), but framerate is much smoother and I no longer have any lag spikes.

I did encounter a bug when switching resolutions though, it made sliders halfway disappear though, as seen below:



There is another issue when switching resolutions that I noticed, and that would be the mod icons disappearing.
Oinari-sama
osu! crashed randomly without producing logs ("program have stopped responding"). Only happened twice on the new beta, don't know how to reproduce. Will switch to CE and see if the crash occurs the same way.



Spec:
Windows 7 64-bit Professional
Intel i7 2600K with 16G RAM
ATI Radeon HD6870 (Catalyst 14.12 with OpenGL 6.14.10.13283)
.Net Framework 4.5.2


EDIT: Don't know if this info has any significance but I'll throw it in:
When the beta became unresponsible, the game screen freezes and windows cursor (busy animation) takes over. But there is this small area of approx 128x128px on screen (centred around frozen osu cursor) where the windows cursor returns to "normal" as opposed to 'busy."
Nabile

Oinari-sama wrote:

osu! crashed randomly without producing logs ("program have stopped responding"). Only happened twice on the new beta, don't know how to reproduce. Will switch to CE and see if the crash occurs the same way.



Spec:
Windows 7 64-bit Professional
Intel i7 2600K with 16G RAM
ATI Radeon HD6870 (Catalyst 14.12 with OpenGL 6.14.10.13283)
.Net Framework 4.5.2
This is related to video backgrounds. It occurs when retrying a map a random number of times when they are enabled. Disable them for now.
Don't worry, it's been a known issue for quite some time :p
gamecrashed
I've been playing on beta due to some problems I've been having with the stable. Strangely my sliders have been disappearing spontaneously until i close and reopen client.
Yauxo
One thing I went to mention here is that my Editor issues seem to be gone now. I didnt have a single crash on the beta client yet (I had one every ~15 minutes on the stable before I switched).
Improv
Frames are fine on beta but overheats computer and causing it to turn off
(this is indeed a problem with my fan, but this has never happened with Directx or on stable for that matter.)
Random Specs I could find.


I run osu! with all detail settings off. 1920x1080 Fullscreen.
anzo-nii
Dunno why osu! OpenGL in windowed mode gets a black screen (or sometimes freezing screen) everytime UAC kicks in. I need to restart the client for it to go back to normal. It doesn't happen on DirectX. (if this is a known issue please do tell me.)

OBSERVATIONS:
(fullscreen/windowed) FPS - same as stable
(windowed) Disabled Desktop Composition: Yep, that osu! logo inside a white box, no input delays (ofc lol)
(windowed) Enabled Desktop Composition: the usual osu! logo, slight input delay but better than stable
(windowed) osu! stops responding as I minimize or hide (via bosskey) the game while in autoplay mod.
(fullscreen) osu! stops responding as I switch to another running application or hide (via bosskey) the game while in autoplay mod.

GFX: Mobile Intel(R) 4 Series Express Chipset Family (yeah my pc sucks T_T)

20150518.7beta
Steffie
Like a lot of people are saying, Better to have DirectX rather than OpenGL, i think it's stupid to remove DX as an renderer.. Me myself cannot play with OGL either.
Yunus
Is it true that OpenGL fixes the Input lag on Windows 8.1? My aim feels kinda weird also I tried starting osu without dwm.exe (Windows 8.1) and I got a blackscreen on the osu window, tried restarting osu, still same blackscreen.

(build 20150518.7)
If the update really fixes the Input lag then this update rocks.
Multtari
Is there anything to do about compability/performance with recording software when using OpenGL?

While the game runs better when playing normally, the performance is significantly lower compared to DirectX while recording. Haven't tried streaming yet but i'm probably going to have more trouble with more demanding preset when the difference is this big with local recording.

Another problem is that there seems to be fixed desync every time trying to record in OpenGL. While it's easily fixed it takes some time and it shouldn't happen.

While these videos wasn't uploaded with intention of posting them here they give good reference. Noticed desync problem after uploading OpenGL recording. Tested it couple of times and the video was desynced every time so i switched to DirectX and reuploaded.


System specs:

OS: Windows 7
GPU: Sapphire HD 6870
CPU: AMD FX-6300. Overclocked at 4.4Ghz
RAM: 8GB
Mobo: Asrock something. Not in home to check and probably not relevant information.
Drive: Some old HDD. Shouldn't be too old to slow things down.


Recording settings used:

Software:OBS
Resolution: 1600x900 downscaled to 1280x720
Mode: CRF 17. No bitrate limit. Buffer size of 1000kbps. Audio bitrate of 160kbs.
Encoding preset: Ultrafast (fastest)
Framerate: 120fps in DirectX and 90fps in OpenGL (Changed because of low performance, can't remember exact numbers)


DirectX
Performance: Averages at ~300fps. Occasional barely noticeable lag spikes where it goes under "red zone" which is 240fps.

OpenGL
Performance: Averages at ~260fps. Constantly dipping below red zone. Audio in desync as told earlier.
Proxy
I wanted to play solo, but the button just wouldn't get me to singleplayer. I can click it multiple times and nothing happens.

https://osu.ppy.sh/ss/3146715

A restart fixed this.
Shadering
How can i have this beta?
Verssesli
Upon updating to the beta the game is no longer playable, as before I would get ~150fps in menu, and ~280-400fps in game with directx, but will only get ~70fps in menu and ~110-140fps in game causing very noticeable stuttering and being completely unplayable with video or storyboard on (Anywhere between 50-70fps).
Running on Intel HD 4000 with dual-channel RAM @ 1680x1050 fullscreen with i5-3210M.

On a side note, running fullscreen on an Intel HD 4400 with dual-channel ram @ 1366x768with an i3-4030U has those issues, but also causes the cursor to disappear, but items are still clickable. The cursor comes back upon switching to borderless.

No other gameplay issues noted, since I can no longer play the game on beta.
gristCollector

Shadering wrote:

How can i have this beta?
Options > Updates > Release stream: Beta

Also, on the current status of the beta 20150518.7:
Laggier than usual. Confirmed that I am using the same settings as I was on the original.
Mateux

peppy wrote:

Mateux wrote:

The second update gave me a white bg with osu! logo.
My game was running at 1fps. I think that is because the game is using OpenGL now.
What graphics card?
Intel GMA 3150 ( D: )
Tom94

Verssesli wrote:

Upon updating to the beta the game is no longer playable, as before I would get ~150fps in menu, and ~280-400fps in game with directx, but will only get ~70fps in menu and ~110-140fps in game causing very noticeable stuttering and being completely unplayable with video or storyboard on (Anywhere between 50-70fps).
Running on Intel HD 4000 with dual-channel RAM @ 1680x1050 fullscreen with i5-3210M.

On a side note, running fullscreen on an Intel HD 4400 with dual-channel ram @ 1366x768with an i3-4030U has those issues, but also causes the cursor to disappear, but items are still clickable. The cursor comes back upon switching to borderless.

No other gameplay issues noted, since I can no longer play the game on beta.
Thr cursor issue should be resolved on the newest cutting edge build. Could you try it there and see if the fix works for you?

We are still working on getting the performance up on par on intel HD chips. For some reason there are performance issues on those currently.
show more
Please sign in to reply.

New reply