[Archived] Issues with Latest Cutting-edge Build (Post Here)

posted
Total Posts
2,521
show more
Trosk-

Anglachel4 wrote:

in stable mode it works fine but when i choose cutting edge that happens again
Hmm, is it happening on Beta? If it is happening on Beta too, could you try to change the release stream to Cutting Edge again and enable the Compatibility mode? If you can't from inside the game (because everything is screwed) try to hold Shift while opening osu! again and enable Compatibility mode from the configuration window.
Anglachel

Trosk- wrote:

Anglachel4 wrote:

in stable mode it works fine but when i choose cutting edge that happens again
Hmm, is it happening on Beta? If it is happening on Beta too, could you try to change the release stream to Cutting Edge again and enable the Compatibility mode? If you can't from inside the game (because everything is screwed) try to hold Shift while opening osu! again and enable Compatibility mode from the configuration window.
Everything is fine in beta too tried changing to cutting edge after beta but it is still like that
Trosk-

Anglachel4 wrote:

Everything is fine in beta too tried changing to cutting edge after beta but it is still like that
Did you try activating the Compatibility mode on Cutting Edge, like I said earlier?
Anglachel

Trosk- wrote:

Did you try activating the Compatibility mode on Cutting Edge, like I said earlier?
Yep but i am afraid that didn't work either
Default
Movement looks stuttery on the editor when playing a song, and I get considerably less fps while on the editor (800) than while playing (3400).




Also noticed that missing/sliderbreaking sprites are still often missing, so I can only hear the combo break sound with no visual clue of what happened but a note with no numbers at all (they just dissapear with no animation). This happens on like a 20-30% of the combo breaks. It happens on beta too, but not on stable.
luka-devnull
Is there a way to use plain ol' OpenGL now? With WINE, the new GLES+ANGLE combination is really putting a damper on everything, probably because of ANGLE. Cutting Edge has the same bad performance as Stable now since both use DirectX :(

Also, why move from just straight GL to having "GLES -> ANGLE-> DirectX"? Could it possible to make it so we can switch between the two, or a switch between ANGLE and the built-in EGL or WGL libraries if you can't switch between GL and GLES? That would really help us WINE users a lot!
abraker
Enabling shaders on an Intel GPU causes draw to plateau upon the start of kiai time

Mofu kun




happens on the 8/16/2015 update
peppy

aus4000 wrote:

Is there a way to use plain ol' OpenGL now? With WINE, the new GLES+ANGLE combination is really putting a damper on everything, probably because of ANGLE. Cutting Edge has the same bad performance as Stable now since both use DirectX :(

Also, why move from just straight GL to having "GLES -> ANGLE-> DirectX"? Could it possible to make it so we can switch between the two, or a switch between ANGLE and the built-in EGL or WGL libraries if you can't switch between GL and GLES? That would really help us WINE users a lot!
I think you're misunderstanding. We moved from OpenGL to OpenGL ES, which guaranteed more compatibility across platforms. Angle is not even activated unless you turn on compatibility mode. If you're getting worse performance, you'll need to fix your wine environment or wait for our official release on linux.
Tom94

Mofu kun wrote:





happens on the 8/16/2015 update
Update your graphics drivers, reboot, and try again, please. Please also tell us what hardware (and operating system) you are using and please upload your gl_info.txt file, found in your osu! directory.
Morbon
When you go to testplay at editor and turn on autoplay, then go back - crash, happens on last cutting edge build, and doesn't happen on stable.
Nobot
I am having an issue, whenever I try and set my osu! to cutting edge, it doesn't download it.

This is my "update_log_lastsuccess.txt"
8/17/2015 8:20:47 AM: Running cleanup..
8/17/2015 8:20:47 AM: Cleanup successful!
8/17/2015 8:20:47 AM: Resetting update process
8/17/2015 8:20:47 AM: CallbackStatus updated to Checking
8/17/2015 8:20:47 AM:
8/17/2015 8:20:47 AM: Beginning update thread
8/17/2015 8:20:47 AM: Stream: CuttingEdge
8/17/2015 8:20:47 AM:
8/17/2015 8:20:47 AM: Serious error occurred in update thread: System.InvalidProgramException: Common Language Runtime detected an invalid program.
at #Fe.#Ee.#nG()
at #Fe.#Ee.#R3b()
8/17/2015 8:20:47 AM: Returning NoUpdate state to caller
8/17/2015 8:20:47 AM: CallbackStatus updated to NoUpdate

Nothing really happens, it just stays on stable and says that osu! is up to date.
Topic Starter
TheVileOne
There is a slight drop in FPS with cutting edge versus beta. It's very small for me but public slack people seem to have larger drops.
Shizuyi
At least im not the only one with this problem
reinaertdevos

Trosk- wrote:

A Mystery wrote:

Is it just me, or is the cursor trail suddenly staying a lot longer since the very last CE update?

CE

Stable
I don't feel that effect on my skins, as well as on Default skin. Probably I'm wrong, but I think it's still the same.
Difference is pretty clear though, not sure why this suddenly happens (is something changed about skin settings). Don't really know how to edit the cursor trail duration, but I disabled it for now.
What even though I'm subscribed to this topic it didn't tell me there was a reply
MillhioreF
Due to huge particle optimizations in a recent patch, the cursor trail's length is no longer capped and can become much longer during fast movements. I see what you mean, though, and a skin.ini setting sounds pretty nice.
reinaertdevos

MillhioreF wrote:

Due to huge particle optimizations in a recent patch, the cursor trail's length is no longer capped and can become much longer during fast movements. I see what you mean, though, and a skin.ini setting sounds pretty nice.
Thanks for clarifying!
Yeah I would love to be able to edit it, it's really destracting to play with it now (at least to me)
peppy
@Nobot: you need to manually download a new build of osu! and replace your existing one.

Here's a link: http://m1.ppy.sh/r/osu!.exe
Nobot

peppy wrote:

@Nobot: you need to manually download a new build of osu! and replace your existing one.

Here's a link: http://m1.ppy.sh/r/osu!.exe
It worked! Thank you.
Spkz
I noticed a little glitch with the hit error on the latest cuttingedge build. Not really noticable, but sometimes the colors won't work they are just white. Screenshot:
show more
Please sign in to reply.

New reply