Solution: Running osu! In Ubuntu or Xubuntu

posted
Total Posts
938
show more
NyaKun

Uber1337 wrote:

Works fine, no lags(Kubuntu) but all fonts are realy sharp =( (Does some1 kno' how to fix Opengl?!)
Also:no background images in beatmap list =(
Очкочановский анальный раб!

On Linux Mint 8 osu! works, but sound is lagging and sometimes osu! crashing. Trying to use OpenGL.

And if you want use you windows osu! songs folder on linux:
sudo mount --bind 'windows songs folder' 'linux songs folder'
rpr13

Eddotan wrote:

Hey, I have this when I'm trying launching osu!
I did all 1st post says



I can't play osu! for this.
Have the same errow msg.
Many people have this msg. Is there anyone who finished installation after seeing this msg?
Haruhiist
Tried to run this on Arch and got this
[alex@HomePC .osu]$ sh winetricks corefonts dotnet20
Executing /usr/bin/cabextract -q --directory=/home/alex/.wine/dosdevices/c:/winetrickstmp /home/alex/.winetrickscache/arial32.exe
/home/alex/.winetrickscache/arial32.exe: library not compiled to support large files.
/home/alex/.wine/dosdevices/c:/winetrickstmp/FONTINST.EXE: Permission denied
/home/alex/.wine/dosdevices/c:/winetrickstmp/fontinst.inf: Permission denied
/home/alex/.wine/dosdevices/c:/winetrickstmp/Ariali.TTF: Permission denied
/home/alex/.wine/dosdevices/c:/winetrickstmp/Arialbd.TTF: Permission denied
/home/alex/.wine/dosdevices/c:/winetrickstmp/Arialbi.TTF: Permission denied
/home/alex/.wine/dosdevices/c:/winetrickstmp/Arial.TTF: Permission denied
------------------------------------------------------
Note: command '/usr/bin/cabextract -q --directory=/home/alex/.wine/dosdevices/c:/winetrickstmp /home/alex/.winetrickscache/arial32.exe' returned status 1. Aborting.
------------------------------------------------------
[alex@HomePC .osu]$
Same goes if i try to install dotnet without corefonts. Any suggestions?
rpr13
-> Haruhiist
Do as root:
chown -R [username]:[usergroup] /home/[username]/.wine/
PS. Arch is da best xD
Haruhiist
Will try to.
P.S. Yea. 3 days ago i switched from Ubuntu to Arch. Looks way better. Wine is working faster.
Haruhiist
Cannot install osu. shows up error. Yes, i have .net framework installed, I'm unable to install game.
Ziggy Zigzagoon

Uber1337 wrote:

Works fine, no lags(Kubuntu) but all fonts are realy sharp =( (Does some1 kno' how to fix Opengl?!)
Also:no background images in beatmap list =(
Excuse me, but how did you get osu! to run under Kubuntu? I tried doing a lot of things in order to get osu! running under Kubuntu, but...
Tasem
I'd like to note that I've tried both the prepare-osu.sh here and the initial setup process in the first post and neither seems to work for me(I'm on Ubuntu Lucid, by the way). The main problem seems to be during install where it cancels out with something about a publishing error. I once tried to move my windows osu! over to ubuntu but all it got me was the ability to open the Osu! updater, not osu itself. I'm about to try again since I just got my new tablet to work, so we'll see how it goes
Crakila
On Lucid (10.04) you have to check a box in order to install osu!

You right-click the exe and click "Properties", Go to the "Permissions" tab and check the "Allow executing file as program", Click "Close" and then right-click the file again and launch with Wine.

That's what I did and it installed perfectly.
Tasem
Really? I wasn't aware of that. Though I just did it and it failed anyway, but I noticed that even after reinstall Wine!, Osu was still in some fashion installed(the version number was 0.0.0.0, which is nothing new but I can't seem to figure out how to uninstall it, since it also crashes when I try to remove it via wine). Is there any way to clear out wine's registration of Osu somehow, so that it can start the install fresh?

--EDIT: I feel a bit closer to success. After reinstalling wine clean and removing osu entirely, I reinstalled it and it still failed when trying to publish it's product information. Now, however, after changing the windows version to 7/Vista, I get this specific error instead of the generic crash:

Application has generated an exception that could not be handled.

Process ID=0x29(41), Thread ID=0x2(42).
If I click cancel to try to debug it, I get:

No registered JIT debugger was specified.

EDIT EDIT: http://pastebin.com/n9ZVwRwx it ocurred to me to try to run the installer through the terminal so I could get the error logs of whatever's wrong. It's pretty much gibberish to me but somebody might be able to make heads or tails out of it?
embolalia
Ubuntu 10.04, amd64

The installer fails at what looks like the end of the process. Instead, I just went to my Windows install directory (I dual-boot) and ran from there. It slows everything waaaaayyyy down, using what looks to be all of one of my two cores. If I wait long enough, it turns the whole screen gray. (I'm guessing that since it was set for full-screen mode in Windows, that's what that is). It doesn't seem to do anything else, and I have to kill it. I've already tried changing to OpenGL in the .cfg file. Any suggestions?
bagnz0r

rpr13 wrote:

-> Haruhiist
Do as root:
chown -R [username]:[usergroup] /home/[username]/.wine/
PS. Arch is da best xD
NOT.
Tasem
http://pastebin.com/n9ZVwRwx

can't anyone tell me what's wrong here? ;w; I'm really missing Osu maan
bagnz0r

Tasem wrote:

http://pastebin.com/n9ZVwRwx

can't anyone tell me what's wrong here? ;w; I'm really missing Osu maan
#
fixme:advapi:RegisterEventSourceW ((null),L".NET Runtime"): stub
#
fixme:advapi:ReportEventW (0xcafe4242,0x0001,0x0000,0x000003ff,(nil),0x0001,0x00000000,0x33eba8,(nil)): stub
#
err:eventlog:ReportEventW L".NET Runtime version 2.0.50727.42 - Fatal Execution Engine Error (79F97075) (80131506)"
#
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
#
err:msi:ITERATE_Actions Execution halted, action L"InstallFinalize" returned 1627
#
err:msi:ITERATE_Actions Execution halted, action L"ExecuteAction" returned 1627
That'd be .NET.
But why don't you try running osu! in VM? Using VirtualBox, that is.
I get avg. 140fps on P4 3GHz, 2GB DDR2 and some nvidia mx.
MapleAwesome12
Hello, Osu! community. After playing in a netgame on another game, and learning of another person playing Osu! I was immediately tempted to see if it would launch on WINE. Nope. I've tried ALL of your info on this. I've tried the first tutorial, I've tried the wget bagznor thing, and there hasn't been any success. The first thing I encountered was the Osu!Install downloading the .NET 2.0 (as the cabextract didn't succeed in downloading a .NET installer) and the .NET installer comes up. I try to install, and it fails. It continues to the Osu! installer. I get it to install up to "Publishing product information" and it gives the Windows Crash Dialog and then the WINE crash dialog. None of this is working. I'd like to play Osu! as soon as possible, as I have songs on my Secondary drive back when I played it on Windows. When exactly will this game work on Linux WITHOUT use of desktop emulators?

BTW, VirtualBox doesn't work. It stops at mid-bootup, so no success there.
Tasem
The main problem seems to be installing dotnet or getting it to run or /someting/ i dunno wut. I'm currently playing it on Virtualbox but JUST TODAY out of nowhere I got the window to run on Wine! The problem is that it died and hasnt opened again. Right now I'm trying to reinstall dotnet2.0 but i dont know what ive done or havent done that will make it work.

You can run it on Virtualbox but even with a whole gig of ram practically given to virutalbox, and all my video memory, I get occasional framerate issues and the sound crackles. They're enough to make the game frustrating to play, to say the least.
bagnz0r

Tasem wrote:

The main problem seems to be installing dotnet or getting it to run or /someting/ i dunno wut. I'm currently playing it on Virtualbox but JUST TODAY out of nowhere I got the window to run on Wine! The problem is that it died and hasnt opened again. Right now I'm trying to reinstall dotnet2.0 but i dont know what ive done or havent done that will make it work.

You can run it on Virtualbox but even with a whole gig of ram practically given to virutalbox, and all my video memory, I get occasional framerate issues and the sound crackles. They're enough to make the game frustrating to play, to say the least.
Change sound driver in vm settings.
Tasem
?_? To what, exactly? I'm currently using OSS, but I don't know what's considered to be the optimal one, and OSS /seemed/ to work the best.
joaowojcikiewicz
I can't run osu! on linux here.
I have installed dotnetfx 20 and 30, all required fonts and osu crash.
Sometimes, when I click a lot of times in Restart osu, it start, but everytime when I choose a song, the audio automatically mute and the music won't load.
What I have to do to make it work?

Tasem
Okay, so yesterday I reinstalled Linux Mint, in preparation for my new RAM. I'm now running Isadora Gnome x64bit, and I installed Wine rc6 from the wine ppa. I got winetricks, installed gecko, and then installed the following:
corefonts
some corefonts smoothing files(normal smoothing and grayscale, I believe)
dotnet20

Then I tried for Osu again. the installer ran and failed at publishing like always, and I pretty much gave up right then and there, but to my surprise, Osu is opening consistently in direct3d mode when I run it on wine!

If I switch it to opengl mode, it breaks and will not open.

However, all is not well; on occasion the sound just dies out of nowhere, even after I configured wine to actually use an audio driver, which I hadn't done yet. Even if it doesn't, when I start a beatmap(so far tested with Full Metal Alchemist Rewrite), the game/beatmap freezes. I can hit escape and go back to the osu! menu but the sound will invariably be dead. Additionally, there are a few things that aren't rendered, like the boxes that cover the resolution settings in options and the text inside the little bubbles that show up for updates.

Also, I was able to sign into my account, that wasn't an issue surprisingly.

Could the problem be because I installed Directx10 and not...nine, or something? I'm scared to tamper with this too much more in case I do something stupid and break it all over again. I hope someone can help me here, thanks
show more
Please sign in to reply.

New reply