1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
show more
posted

peppy wrote:

anyone tried this? http://support.microsoft.com/kb/2908279
I install that update. Not solved :(
posted

peppy wrote:

anyone tried this? http://support.microsoft.com/kb/2908279
Yes, this fixes the 200hz cap/input lag issue

It doesn't fix the sensitivity != 1.0x issue though
posted
that's a good start.
posted
Well, apparently we can fix osu! by manually extending the update part. The question is should i attempt to manually change it as the instructions say or should i wait until they have a fix fix? Also, does manually adding osu! solve the mouse sensitivity problem?
posted

BlitzBattalion wrote:

Well, apparently we can fix osu! by manually extending the update part. The question is should i attempt to manually change it as the instructions say or should i wait until they have a fix fix? Also, does manually adding osu! solve the mouse sensitivity problem?
That's what I did, the update does nothing otherwise
posted

Espionage724 wrote:

http://support.microsoft.com/kb/2908279

Not sure if it fixes the exact issue with osu! or not though.

Edit: Doesn't seem to help. If you want to test it, you have to flag osu!.exe to be affected by the update (instructions under "How to extend the update to other games").
Added osu!.exe manually, works like a charm now.
posted
That fix completely solved the issue for me. I can select sensitivities well above 1.0x without getting jumpy cursors like I was before I applied the update. I applied the registry fix, did the ShimFlushCache step, then rebooted and that fixed the problem. Mouse also seems slightly more responsive as well.

I notice that osu! seems to be taking longer to load with the fix, but that's a really minor issue compared to jumpy mouse.
posted

esibun wrote:

That fix completely solved the issue for me. I can select sensitivities well above 1.0x without getting jumpy cursors like I was before I applied the update. I applied the registry fix, did the ShimFlushCache step, then rebooted and that fixed the problem. Mouse also seems slightly more responsive as well.

I notice that osu! seems to be taking longer to load with the fix, but that's a really minor issue compared to jumpy mouse.
This doesn't seem to be the case for me. I applied the fix and extended the update to osu and the problem is still there for me when I raise the mouse sensitivity in osu's settings. I made sure the path to the file is correct and the value data is correct too. So, this fix didn't work for me and it appears it didn't fix the sensitivity issue for other users here as well. I guess I'll stick to 1.0x for now.
posted
News:
http://techreport.com/news/25599/window ... x-incoming

Official Microsoft Response:
http://answers.microsoft.com/en-us/wind ... 528c42e400

It hasn't been pushed but is available now for download.
http://support.microsoft.com/kb/2908279


Updated (11/8)

We want to thank our gaming community for the detailed feedback many of you have provided on these issues. We have released some fixes and workarounds that will allow you to get back to your gaming.

The “mouse lag” issue is actually several different issues that could vary based on the game, input methods used, etc.

The three following issues are addressed by a fix we have provided in KB 2908279:

Mouse jitters (jumps forward and back) as you move it through a game
– This occurs in some games because Windows 8.1 introduced changes to mouse input processing for low latency interaction scenarios and this causes some games to respond differently to mouse input than in previous releases of Windows.

Mouse movement is not to scale even after acceleration is turned off
– If you have turned off acceleration to make the distance on the screen match the distance you move the mouse, that may not work correctly anymore.

Measured mouse Polling Rate has a lower reporting frequency than expected
– If you have a gaming mouse that has a high frequency, when you test it, you may find it is reporting a lower frequency than you expect. Note: if you previously encountered issues with measuring the polling rate you will need to follow the instructions in KB 2908279 to ensure that, not only the patch is installed, but also the app used to measure the polling rate has an appropriate registry entry to enable the fix for that specific executable.
posted
Can someone make a .reg for this?
posted
It seems that I can safely update to win8.1 now..
owo

Let's see what will happen.
posted

peppy wrote:

Can someone make a .reg for this?
http://puu.sh/5hc1N.zip

1. Download KB2908279 Update (KB2908279.url)
2. Install it and reboot
3. Run osu! 8.1 Mouse Fix.reg
4. Run ShimFlushCache.bat (as Administrator)
5. Reboot
6. Win

osu! 8.1 Mouse Fix.reg contains:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files (x86)\\osu!\\osu!.exe"="NoDTToDITMouseBatch"
ShimFlushCache.bat contains:
Rundll32 apphelp.dll,ShimFlushCache
posted
Thanks much. I will look at automating this process in the next release.
posted

Espionage724 wrote:

peppy wrote:

Can someone make a .reg for this?
http://puu.sh/5g9P1.zip

- Run osu! 8.1 Mouse Fix.reg to import the registry entry
- Run ShimFlushCache.bat
- Reboot

osu! 8.1 Mouse Fix.reg contains:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files (x86)\\osu!\\osu!.exe"="NoDTToDITMouseBatch"
ShimFlushCache.bat contains:
Rundll32 apphelp.dll,ShimFlushCache
I did all the steps and it's still not fixed for me.
posted

Gabb1995 wrote:

I did all the steps and it's still not fixed for me.
Are you on Windows 8.1 (with GA updates), and have you installed the hotfix from http://support.microsoft.com/kb/2908279?
posted

Espionage724 wrote:

Are you on Windows 8.1 (with GA updates), and have you installed the hotfix from http://support.microsoft.com/kb/2908279?
I am on Windows 8.1, do I need to install some Windows update manually? If yes then from where? Also no I havent done the hotfix I thought it was in the fix you sent let me try it with the hotfix first. Thanks for help.

EDIT: It worked after I installed the hotfix, thanks for help I can finally play Osu! at uni.
posted

Espionage724 wrote:

peppy wrote:

Can someone make a .reg for this?
http://puu.sh/5g9P1.zip

- Run osu! 8.1 Mouse Fix.reg to import the registry entry
- Run ShimFlushCache.bat
- Reboot

osu! 8.1 Mouse Fix.reg contains:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
"C:\\Program Files (x86)\\osu!\\osu!.exe"="NoDTToDITMouseBatch"
ShimFlushCache.bat contains:
Rundll32 apphelp.dll,ShimFlushCache
Thanks for the .reg mate. Everything is working perfectly now :) Hooray
posted

Gabb1995 wrote:

Espionage724 wrote:

Are you on Windows 8.1 (with GA updates), and have you installed the hotfix from http://support.microsoft.com/kb/2908279?
I am on Windows 8.1, do I need to install some Windows update manually? If yes then from where? Also no I havent done the hotfix I thought it was in the fix you sent let me try it with the hotfix first. Thanks for help.

EDIT: It worked after I installed the hotfix, thanks for help I can finally play Osu! at uni.
Ah; if you ran Windows Update, you probably have the GA update; at some point before launch though you had to manually download the update.

Updated the fix link and added clearer instructions :)
posted
Windows 8.1 Mouse Lag Fix :)

posted
Has this update been released on windows update yet?
show more
Please sign in to reply.