forum

Unoffical Updated OSX osu! Wineskin Package

posted
Total Posts
456
show more
Stingy

peppy wrote:

You need to use non-fallback builds to submit scores.
I used to be able to submit everything just fine, but we'll see!
The client forced a restart, so after it's finished I'll get back with an update.

Edit: Everything is fine!
TestTesty
god this forum exists. if it didn't i wouldn't able to play the latest version of osu in mac.
Sam_Bunny
can't download it from mega, can you add a download mirror on mediafire?
PandaQueeen
I have been playing on mac for a while and it is sad to see that I cannot play on it anymore. :( I just wish through lazer you could play with friends or something.
- Marco -
https://www.codeweavers.com/about/blogs/jwhite/2019/10/31/announcing-a-first-alpha-build-of-crossover-19-for-macos-catalina

CodeWeavers wrote:

We plan to start our beta process shortly and we hope to have a production quality version of CrossOver 19 before the end of the year. We strongly recommend that everyone that can wait for that version.
Soo...theoretically wine on mac should be ready to use before the end of the year. At the current status it's just a hacky build that kind of works but nothing is assured to go well.
Ufish_shina
I want to ask, does osu! worked on os X Catalina now?
I have played for a long time and I accidentally upgrade my macbook. QQQQQ
Hbdsll
I did everything in this guide. does it applies to Multi Osu! as well or do i need to do something else?
SevenChords
a solution for all macos catalina users for the time being would be to install windows via the bootcamp utility and boot into that windows installation to play osu, otherwise wait for either lazer release or a compatible wrapper like wine or even wine itself
CakeOWO
Before I redownload osu, the old osu has a drive c file.But the new osu doesn't have. I cant move my songs and datas to the new osu. What should I do
Topic Starter
Technocoder

CakeOWO wrote:

Before I redownload osu, the old osu has a drive c file.But the new osu doesn't have. I cant move my songs and datas to the new osu. What should I do
If the drive_c shortcut does not exist you can find the folder manually through: Contents > Resources > drive_c. If that folder does not exist you may need to start osu! at least once for the folder to show up (though it should appear anyway).
Va1iant212
I downloaded osu but once I updated my computer to the Catalina update I couldn't open it. I tried redownloading it but it still doesn't work
Toebrain
I have catalina and i downloaded it from https://github.com/ppy/osu/releases works for me
SosPesos

Toebrain wrote:

I have catalina and i downloaded it from https://github.com/ppy/osu/releases works for me
It's osu!lazer. I also tried downloading this version rather than original but I didn't understand how to import songs and skins into it. How did you do it?
jjini

SosPesos wrote:

Toebrain wrote:

I have catalina and i downloaded it from https://github.com/ppy/osu/releases works for me
It's osu!lazer. I also tried downloading this version rather than original but I didn't understand how to import songs and skins into it. How did you do it?
you can just drag and drop the skin/beatmap files (skin support is currently very limited though)
kyoo

SosPesos wrote:

Toebrain wrote:

I have catalina and i downloaded it from https://github.com/ppy/osu/releases works for me
It's osu!lazer. I also tried downloading this version rather than original but I didn't understand how to import songs and skins into it. How did you do it?
Can you write how to download this on macOS? I've already download this XQuartz but I can't figure out how to install this. I bought MacBook 3 days ago and I can't do it yet.
RichardMupp
so for the discord rich presence i didn't seem to have the discord rpc dll file in there yet and when i put in a new one and launch osu it just deletes the file. Any solution?

Still doesn't work
The Tiffanys
How long will it take for this to be imported to macOS Catalina?
DegenerateBeing
Hi, I'm on a 2017 Macbook Air 8 Gb ram. Recently I've had a crap ton of lag spikes out of nowhere mid-song. This happens about even 40-60 seconds, and its only started ever since I've upgraded to Mac Mojave and has gotten progressively worse. Is there any fix to make this stable more compatible with mojave to reduce the lag spikes?
thaiboy digital
any updates on osu! for catalina?
SaintePayette

RichardMupp wrote:

so for the discord rich presence i didn't seem to have the discord rpc dll file in there yet and when i put in a new one and launch osu it just deletes the file. Any solution?
Same problem
Topic Starter
Technocoder
This is an experimental build for osu! on macOS Catalina.
Download link: https://mega.nz/#!1wUhSK5b!UOh3p73XnupbZktFgsljieoIdf_L1PkxDFwjBvflNGM
After extraction follow the steps under osu! or Wineskin will not open! from my guide. Ignore any "Operation not permitted" errors.

If you are on a version of macOS older than 10.15.4 System Integrity Protection must also be disabled. You can check if it is enabled:
  1. Open Terminal
  2. Type csrutil status and press enter
  3. Check if it says it is enabled
If it is enabled, you can follow these steps from official Apple documentation to disable it: https://developer.apple.com/library/archive/documentation/Security/Conceptual/System_Integrity_Protection_Guide/ConfiguringSystemIntegrityProtection/ConfiguringSystemIntegrityProtection.html#//apple_ref/doc/uid/TP40016462-CH5-SW1

One person has confirmed that the Wineskin does work on Catalina with no apparent issues as long System Integrity Protection is disabled.

Technical Build Information:
This build augments Peppy's (@peppy) July 2019 build with the newer Crossover 19.0.1 build designed to run on macOS Catalina from the Unofficial Wineskin releases: https://github.com/Gcenx/WineskinServer/releases/tag/V1.8.4
The (extracted) application size has increased to 2.56 gigabytes which suggests that it may be more space efficient to rebuild the Wineskin from scratch.
osulover_old_1
after installing osu by the way you mentioned I am getting an error
System.ComponentModel.Win32Exception (0x80004005): Błąd wewnętrzny
at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
at #=zfx4YmktRjFRJMjRCIw==.#=z21atl_k=(Boolean #=zz37TCDhPZt7T, Exception #=zd$QcV_I=)
at #=zECDBzTWwbaPTpTsrQb0uALU=.#=zzgK5Nt5FWiHc(Object #=zyyMutHw=, EventArgs #=zd$QcV_I=)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
Do you know what shall I do? I know it is still alpha, but you know...
Topic Starter
Technocoder

osulover wrote:

after installing osu by the way you mentioned I am getting an error
System.ComponentModel.Win32Exception (0x80004005): Błąd wewnętrzny
at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
at #=zfx4YmktRjFRJMjRCIw==.#=z21atl_k=(Boolean #=zz37TCDhPZt7T, Exception #=zd$QcV_I=)
at #=zECDBzTWwbaPTpTsrQb0uALU=.#=zzgK5Nt5FWiHc(Object #=zyyMutHw=, EventArgs #=zd$QcV_I=)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
Do you know what shall I do? I know it is still alpha, but you know...

Can you clarify where you are getting this error? Does this happen when you launch the game or when you play a beatmap or something else?

(It would also be helpful to know if you have System Integrity Protection enabled. Type csrutil status in Terminal and press enter to check.)
vistafan12
I also tried Catalina build and my osu! crashed automatically when I started it up.



Error:
System.ComponentModel.Win32Exception (0x80004005): Niepowodzenie DDE
at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
Paydru
I was ready to update to catalina but theres still people with errors :( guess ill wait until it is resolved
Topic Starter
Technocoder
Going by this comment on the Unofficial Wineskin page (and my tester):
these have not been signed or notarized so to make use of these you need to disable SIP in order for wine32on64 to set the kernal flag to allow 32Bit code execution.
it looks like for the Catalina build to work correctly System Integrity Protection needs to be disabled.
I'm not sure whether this is something that can be fixed in the future (it seems that there is a method to sign the engine). I'll link an article on disabling SIP in the original Catalina post.
vistafan12

Technocoder wrote:

Going by this comment on the Unofficial Wineskin page (and my tester):
these have not been signed or notarized so to make use of these you need to disable SIP in order for wine32on64 to set the kernal flag to allow 32Bit code execution.
it looks like for the Catalina build to work correctly System Integrity Protection needs to be disabled.
I'm not sure whether this is something that can be fixed in the future (it seems that there is a method to sign the engine). I'll link an article on disabling SIP in the original Catalina post.
osu! looks and works just fine now without any problems. thanks!

---
after restart I got another crash with this type of error:

System.BadImageFormatException: Zły format. (Exception from HRESULT: 0x8007000B)
at #=zZQxv518qVKROUiQPwbWgTZ0=.#=z3yZu7DN4B2BRBgmayg==(Int32 #=zPUugZWQ=, #=zRZWZnGM3MIXD7ReruX9T_H6a_0hIEKA6xUsLpGIgFN8k& #=zi_qKPgk=)
at #=zZQxv518qVKROUiQPwbWgTZ0=.#=zhUMWxy48qeAhNKlcsQ==(Int32 #=zPUugZWQ=, #=za1OJjy3FLdUZnYkbSEi409aObgByGORR5olBu_A= #=zi_qKPgk=)
at #=zZQxv518qVKROUiQPwbWgTZ0=.#=z1UVvLa3xfwH0bXf_XQ==()
at #=zA3hSbco8uK0sKiIQ4Q==.#=z$NzUus8FUH3H(String #=z_qtqZfQM0CQK, Boolean #=zCxwmJWU=)
at #=zawrZjcDFGFN3WxT5WQ==.#=zDHXf2aC0PWn8()
at #=zawrZjcDFGFN3WxT5WQ==..ctor(String #=zNPNE6w0=)
at #=zsxC23dam3M26SVlPAA==.#=zBFA$LxQqV3VR(String #=zKT0vJ19XlKiR, Boolean #=zFal$SqUTp_kaIDi5zqOJw_8=, Boolean #=zn74D38aoz386Xfo46A==)

---

Nevermind, got it to work after clicking "restart osu!" on crash screen.
- Ephemeral -
I'm having an issue opening the application, even after disabling the System Integrity Protection on my laptop. It keeps bringing up this issue about the .NET framework.

"This application could not be started. You must enable the .NET Framework from the Windows Features dialog box (from Control Panel, choose Programs, Turn Windows features on or off). Do you want to view information about this issue?"
Topic Starter
Technocoder

- Ephemeral - wrote:

I'm having an issue opening the application, even after disabling the System Integrity Protection on my laptop. It keeps bringing up this issue about the .NET framework.

"This application could not be started. You must enable the .NET Framework from the Windows Features dialog box (from Control Panel, choose Programs, Turn Windows features on or off). Do you want to view information about this issue?"

That's certainly a strange error to be getting. I know this sounds rather dumb but it might be worth downloading the file again just in case it was a one off error. If that doesn't work check if there are any files in Show Package Contents > drive_c > osu! > Songs > Logs. If there are, paste the contents of those files here (preferably in a pastebin).

It seems that there's an option to view information about the issue as well. Paste that information here as well if you can. Otherwise, you can try installing the .NET Framework manually (although I don't know if that will help):
  1. Open Wineskin from Show Package Contents
  2. Click on Advanced > Tools > Winetricks
  3. Click on dlls and check the box next to dotnet40 (theoretically, there should be a mark in the Installed column as well)
  4. Click on Run
- Ephemeral -
I redownloaded the osu! Catalina build, but this time, it told me that '"osu!" is damaged and can't be opened. You should move it to the Trash." So I deleted this new version and tried to reopen the first version that I downloaded.

Using this first version, I tried manually installing the .NET Framework using your steps, but it gave me another error. The following pastebin link has the error messages and information you requested in your reply.

https://pastebin.com/GMbyJETa
Topic Starter
Technocoder

- Ephemeral - wrote:

I redownloaded the osu! Catalina build, but this time, it told me that '"osu!" is damaged and can't be opened. You should move it to the Trash." So I deleted this new version and tried to reopen the first version that I downloaded.

Using this first version, I tried manually installing the .NET Framework using your steps, but it gave me another error. The following pastebin link has the error messages and information you requested in your reply.

https://pastebin.com/GMbyJETa

You have ran this command right? sudo xattr -dr com.apple.quarantine 'osu!.app'
This needs to run on the osu! application each time it is downloaded. If you get the message xattr: No such file it means you have not set the working directory in Terminal correctly (the steps in my guide go into more detail). This is most likely the reason why you get "osu! is damaged and can't be opened". I suggest you try downloading it again.

I found this interesting error in the logs: wine: Bad CPU type in executable which seems to suggest that you're not using the Catalina build for some reason? It might just be an issue with winetricks.

There is a failure when osu! tries to update: _pending\osu!.exe => osu!.exe: FAIL. You can try updating osu! manually (there is a set of steps in my guide for this). There's also the error: No available GL context found.. Have you managed to get osu! on Wineskin working before? It might be that your graphics card is too old (I don't know what model of computer you have) but that seems unlikely.
elliotttate
Works perfectly for me! (sudo xattr -dr com.apple.quarantine 'osu!.app' isn't necessary if you enable "install from anywhere" in Catalina)
- Ephemeral -
Okay, got it on my laptop. Is there a way to transfer skins? I tried to move my skins and songs to the new osu! folder, but the crossover application said there "is no windows application configured to open this file" when I tried to open the game with the new skin.
Topic Starter
Technocoder

- Ephemeral - wrote:

Okay, got it on my laptop. Is there a way to transfer skins? I tried to move my skins and songs to the new osu! folder, but the crossover application said there "is no windows application configured to open this file" when I tried to open the game with the new skin.

Drag your skins into the skins folder (Show Package Contents > drive_c > osu! > Skins). Alternatively, perform the sections How to do a data backup on the old Wineskin and How to restore a data backup on the new Wineskin from my guide.
BlasterLizard
The app doesn't open.
AstroThePony
OK GUYS I NEED HELP SO MUCH.
My osu runs fine on my macbook pro screen but on my secondary monitor i got 14 ms.How can i fix that?
PinkBunny19

Technocoder wrote:

This is an experimental build for osu! on macOS Catalina.
Download link: https://mega.nz/#!1wUhSK5b!UOh3p73XnupbZktFgsljieoIdf_L1PkxDFwjBvflNGM
After extraction, you must run the following command on the application:
sudo xattr -dr com.apple.quarantine 'osu!.app'
(or otherwise apply the steps from the section: osu! or Wineskin will not open! from my guide. Ignore any "Operation not permitted" or "No such file" errors.)

For the moment, System Integrity Protection must also be disabled. You can check if it is enabled:
  1. Open Terminal
  2. Type csrutil status and press enter
  3. Check if it says it is enabled

If it is enabled, you can follow these steps from official Apple documentation to disable it: https://developer.apple.com/library/archive/documentation/Security/Conceptual/System_Integrity_Protection_Guide/ConfiguringSystemIntegrityProtection/ConfiguringSystemIntegrityProtection.html#//apple_ref/doc/uid/TP40016462-CH5-SW1

One person has confirmed that the Wineskin does work on Catalina with no apparent issues as long System Integrity Protection is disabled.

Technical Build Information:
This build augments Peppy's (@peppy) July 2019 build with the newer Crossover 19.0.1 build designed to run on macOS Catalina from the Unofficial Wineskin releases: https://github.com/Gcenx/WineskinServer/releases/tag/V1.8.4
The (extracted) application size has increased to 2.56 gigabytes which suggests that it may be more space efficient to rebuild the Wineskin from scratch.
I don´t understand the part "you must run the following command", I download the app but I don´t know how to follow the steps :c
Topic Starter
Technocoder

BlasterLizard wrote:

The app doesn't open.
Provide more information.

AstroThePony wrote:

OK GUYS I NEED HELP SO MUCH.
My osu runs fine on my macbook pro screen but on my secondary monitor i got 14 ms.How can i fix that?
14 ms is about as high as you can get with a 60 or 70 refresh rate monitor. Have you disabled VSync or chosen a higher frame rate in the graphics options?

PinkBunny19 wrote:

I don´t understand the part "you must run the following command", I download the app but I don´t know how to follow the steps :c
What part of the steps in my guide are you having trouble with?
Jyxle
I downloaded the zip file, but it says it's damaged and cannot be opened. When you say copy and paste the command, do you mean in Terminal? I have no idea what you mean when you said to paste it onto the osu! application. When I typed the command into Terminal, it just asked for a 'Password: " with a key symbol. How do I fix this?


Update: I disabled system integrity and I've run the command, it said no such file. (where can I find your osu! or Wineskin will not open! guide?) osu! still says its damaged, can't be opened, and that I should move it to the bin.

I don't see how the Wineskin thing plays into the installment. I have the unofficial one you provided downloaded.
Topic Starter
Technocoder

Jyxle wrote:

I downloaded the zip file, but it says it's damaged and cannot be opened. When you say copy and paste the command, do you mean in Terminal? I have no idea what you mean when you said to paste it onto the osu! application. When I typed the command into Terminal, it just asked for a 'Password: " with a key symbol. How do I fix this?


Update: I disabled system integrity and I've run the command, it said no such file. (where can I find your osu! or Wineskin will not open! guide?) osu! still says its damaged, can't be opened, and that I should move it to the bin.

I don't see how the Wineskin thing plays into the installment. I have the unofficial one you provided downloaded.

I've included the guide in my signature. You can also find the guide in the first post of this thread. The password won't show up when you type it in but it will still be registered. Press enter after you've typed it in. The command will also fix the damaged error.

The working directory of your Terminal is likely not in the same place as your osu! file. There are more detailed steps on this in my guide.
show more
Please sign in to reply.

New reply