[Archived] Stable40 / Stable (Latest) Performance Issues

posted
Total Posts
280
show more
Arii
Currently running f.lux, but I've disabled it and tested it and sudden FPS drops and some lag still persists.

Problem: Sudden freezing, or FPS drops to 0-2 for about half a second every now and then, which often results in a combo break or a series of 100s and 50s, in about 10-25 second intervals. Main menu is also very slow compared to fallback version, e.g. freezing for a few seconds when switching songs, and generally low frame rate.

-Compatibility Mode is disabled, but enabling it doesn't seem to fix problems. Enabling "Reduce dropped frames" seems to help slightly, but doesn't solve the problem either.
-Processor is an AMD A6-6310 APU, @ 1.80Ghz, with AMD Radeon R4 Graphics (On a laptop)
-Fullscreen
-I couldn't find a gl_info.txt, nor can I accurately record a video.
Smilyt1
Update 21/11/15

So out of curiosity, I tried using my laptop's second integrated graphics driver, the Intel(R) HD Graphics 3000.
And just like that, all the lags vanished.
Somehow I wasn't surprised with this discovery, I always knew that my Nvidia driver was a little balloon-headed..
Mitch
Looks like all my issues are fixed as of yesterday, no more micro stutters or fps drops.

I can even watch streams again on my second monitor without experiencing additional input delay or frame stutters, good job peppy!
reinaertdevos
I'm still getting minor stuttering at random moments, sometimes a lot (like every 20 seconds), sometimes not at all for 1 or more hours.
Nothing demanding is running in the background, no updates or whatever, so this shouldn't be the problem.

These stutters are purely graphical, they don't influence my gameplay at all except that it can be a little distracting. The screen basically stutters a few times quickly and then it continues with smooth gameplay, before it gets interrupted again. The frame times do show something (as 2-4 little squares appear when this happens)

Info: Running osu! with a GTX 980, i7 4790k and 8 gigs of RAM (I suppose hardware isn't the problem). No shadowplay, no compatibility mode (this only increases input lag)

[url=Performance.log]http://puu.sh/luDEQ/8c3b93d623.log[/url]
TheBlaiZe
So osu! told me to update and apparently the latest stable build is just that. Stable. No fps drops whatsoever. Thanks fam :3
I have been baited, It still stutters ಠ_ಠ
LCSS
I already try Beta and Cutting Edge and the problem persists. Using integrated graphics card works fine, but when switch to Nvidia, my fps goes to the ground (20-35) and the mouse latency too (30-35). When i switch back to Stable (fallback) everything back to normal.

My performance log: https://ghostbin.com/paste/va7uv
-C o c o a
Iam using a HP windows laptop. Windows 10
Razer blackwidow 2016
Wacom intuos pro pen and touch tablet

After the last update, and key binding i set standard to will become unresponsive during a map and only when playing a map. I tried changing the bindings to diffrent keys of the keyboard and it still has the same problem. I uninstalled osu and then reinstalled it and it still had the same problem. I know its not the keyboard because i tried my old one and it had the same problem. These started occuring after the last osu! update. I also restart and also tried every version of osu! and still the problem persists.
Topic Starter
peppy
Could nvidia users with issues please try disabling "Threaded Optimizations" from your nvidia control panel?

Smilyt1


in my case, all stutters and frame jumps disappeared.
The only problem now is the slightly high latency (average 5.2ms; compared to 1.8ms when I use the integrated Intel graphics card).
moki
- What kind of performance problems are you seeing? Low framerate throughout the game? Lag spikes? How often? How long do the spikes last?
I'm getting insane lag - while and while not recording.

- Is compatibility mode turned on in options? Can you turn it off?
It's turned off.

- What GPU are you running on? Do you have two GPUs in your PC? Have you tried both?
R9 380

- Are you running fullscreen? If not, please try this before posting.
I play osu! in fullscreen mode.

- Provide gl_info.txt from your osu! folder.
I'm unable to locate the file.

- Video showing exactly what you are experiencing.


Before the last osu! update the game would run flawlessly, now it is unplayable.
FieryLight
I always lag at the same part in the same songs but not on Stable (fall back version).


Song: https://osu.ppy.sh/b/804164 [Forever]


Song: https://osu.ppy.sh/b/108021 [Let's Jump!!]

Performance log: http://puu.sh/lHnh1/3e26e9cf24.log

No video because if I were to record, the video would be so inconsistent you wouldn't be able to see the specific laggy point anyway

Integrated GPU I think
hello there21

hello there21 wrote:

My computer got upgraded to Windows 10 and now during a song it will have a freeze for about one second every 15 seconds making it kind of unplayable. It worked perfectly fine on Windows 8.something. Help? :( I got the latest update, is there anyway that this could be fixed or do I have some sort of problem?........

Ok, so here is the frame graph, but i'm not quite sure what a performance log is.
I can not get it to appear using the img thing.

http://imgur.com/3huOp3i
Ok... I figured it out, it was a problem with my computer, but its fixed now so im all good. :)
Smilyt1

hello there21 wrote:

My computer got upgraded to Windows 10 and now during a song it will have a freeze for about one second every 15 seconds making it kind of unplayable. It worked perfectly fine on Windows 8.something. Help? :( I got the latest update, is there anyway that this could be fixed or do I have some sort of problem?........

Ok, so here is the frame graph, but i'm not quite sure what a performance log is.
file:///C:/Users/Chuck/Desktop/Daniel's/screenshot006.jpg
[url]file:///C:/Users/Chuck/Desktop/Daniel's/screenshot006.jpg[/url]
[img]file:///C:/Users/Chuck/Desktop/Daniel's/screenshot006.jpg[/img]

IDK how to make the picture appear, but above is the link.
....give me few minutes.

ok

To thumbnail/link the screenshots you desire on a forum like this, you have to upload it somewhere on the internet first (ideally imgur or puush).
After uploading you should be able to obtain its link, then you copy and paste the link [img]here[/img].
Nevik
I've been experiencing teleporting issues on my cursor on Stable (Latest). When I use fallback, it is completely fine. I updated my tablet driver but it never really helped. Anyone else having this issue too?
reinaertdevos
I'm experiencing less stutters than before (at least the last 2 days) Not sure if it was the threaded optimizations or an update, but thanks anyway!
wiken
Disabling "Threaded Optimizations" works fine, unfortunately there's still some stutters even at 200FPS.
Compability mode: Off
GPU: I can use GeForce 610M and HD Graphics 3000 with the latter has far more stutters at every FPS limit.
Running Fullscreen with 1366x768 as a native resolution, reducing it to 1280x720 does not seem to make any difference.

Should i switch to Cutting Edge to post my performance.logs here?
Mancis
- What kind of performance problems are you seeing? Low framerate throughout the game? Lag spikes? How often? How long do the spikes last?
I get stutters which started ever since the open-gl only thingy was launched. They happen at very random times, sometimes a bunch of them in the span of 5-10 mins while sometimes the same amounts in the span of 1-2 hours. I noticed that after the game comes back from freezing up the input delay has suddenly jumped to +1000ms and rapidly goes down to what it normally is (2-4ms). I get them on all builds of the game except Stable (Fallback) and Stable (Latest) with Compatibility mode turned on. I still get stutters on Stable (Latest) if my compatibility mode is off.
- What GPU are you running on? Do you have two GPUs in your PC? Have you tried both?
I only have one GPU which is a super ancient one. It's Nividia GeForce 8600 GT. I never used to have problems with osu! before though so I don't think this is the reason.
- Are you running fullscreen? If not, please try this before posting.
I am running full screen, I've never played without full screen.

Some other PC specs:
Processor is AMD Athlon 64 X2 Dual Core Processor 4200+ 2.20GHz
1GB of DDR2 RAM
Windows 7 32-bit OS

What I've tried so far:
- Turning it on and off
- Restarting computer
- Reinstalling osu!
- Updating drivers
- Trying out different builds
- Disabling "Threaded Optimizations" from nvidia control panel as mentioned earlier in the thread.

The only thing that has somewhat worked so far is turning on compatibility mode on Stable (Latest) , which completely removes stutters, but it adds an additional 3-5ms input delay to my already decently high average of 2-4ms

Below is my performance.log of some gameplay posted on pastebin, because for w/e reasons either my browser lags out or the website's anti DDOS triggers when I paste it here. I deleted some slow frame stuff at the beginning so the .txt meets the size requirement for paste bin. It was mostly slow frames in menu, which happen to me all the time and are 100% cause of my super low-end PC (for e.x. spamming F2 button or when stuff is still loading).

http://pastebin.com/Uth83dVh
Kert
Have you removed snaking slider rendering at higher fps? (i.e. = monitor refresh rate)
It's my eyes or see it is like that on all versions now including stable.
tbh looks like everything in-game became less fluid for me

Will be fixed later (ppy blog)
XPridNet94X
- What kind of performance problems are you seeing? Low framerate throughout the game? Lag spikes? How often? How long do the spikes last?

Stutters on my. Updated to the latest version of the game. Tried compatibility mode. Still seeing the stutters on it. FPS still stays at 120FPS but still can see stutters

- What GPU are you running on? Do you have two GPUs in your PC? Have you tried both?

Currently running on Nvidia Geforce GTX 750 TI 2GB. Not an very old card. Had no issues with it running OSU! before the update. No. I don't Run 2 GPUS on my system

- Are you running fullscreen? If not, please try this before posting

Yes. Never played without full screen. Only Bring more input lags.

My other PC Specs

Intel Core i5 4460 3.2GHZ
Asus Z97 Pro gamer MB
16GB DDR3 1600MHZ RAM
Windows 10 Pro 64Bit

What I've tried so far:
-Running in compatibility mode
-Updating all drivers
-Disable "Threaded Optimizations

When I Turn on Compatibility mode, It fixed most of the issues but still bring some stutters. Didn't see any ms drops at all.
Araett
This issue was reported some time ago, but it wasn't resolved, so I might get a chance if I write the issue myself.

As I've began to look towards osu in a bit of serious perspective, I've started off from the fallback version. Been playing on fullscreen 1920x1080 resolution on 180~ FPS with unlimited framerate on my laptop. Afterwards I've updated to the latest stable version and then I've started experiencing issues. Running fullscreen on stable version 1920x1080 on unlimited makes the game run on constant 30 with lagspikes. The game actually looks clunky, and comparing it to the experience on the fallback version - almost unplayable. The only way to play it normally on Stable is on windowed borderless which brings in a new issue - input lag. And... Well... Input lag is fixed by playing on fullscreen.

The compatibility mode has no effect on the issue, just creates more input lag for me. Thus I keep it off.

I am running it on Acer Aspire V 15 Nitro Laptop, which has Integrated Intel GPU and Nvidia GTX 950M. I have tried both. The issue is mainly with the Nvidia, but integrated has ridiculous amounts of lag spikes. One thing I've noticed when running on fullscreen, that GPU-Z showed that GPU is fully loaded while Osu is running.

Drivers are up to date, Threaded optimization is off.

Did switch to Cuttingedge and here's the log for the first 15-25 seconds in menu
http://pastebin.com/Zq5P31wm

I would be really thankful if somebody would help me out about this. Till then I will be still using Fallback version.
show more
Please sign in to reply.

New reply