1. osu! forums
  2. osu!
  3. Development
posted
YOU MUST BE A SUPPORTER TO USE THIS

Hi there folks, I come again with a new application which creates menu backgrounds that match your dekstop background, giving off a transparent window effect! Like the picture here.
Original idea was by Pannari, sadly I managed to code my GUI version of the application way faster than he managed to do. He'll be posting the console application version soon.
Heres some screenshots of how it looks like.

Theres preview mode where you can view how it will look like on your osu! with your desktop background behind it.


Instructions on how to use: >:(
1. Unzip it anywhere and open it.
2. Select your main osu! folder.
3. Select the skin you want the background to be set on (the one you're using or another).
4. Click the button and then restart your osu! client for the changes to take effect.

Download latest version here!

posted
Looks cool. I'll try it.
---------------------------------
EDIT: When I test it, there was something that is not right. This is my main background:

And o!verlay use this one:

Also, I use Windows 8.1. The OS may cause this problem?
posted
Nice job LeliFlen~
posted

Who me??? i'm not doing anything, i'm just following the instruction and.........
posted

[cocoa] wrote:


Who me??? i'm not doing anything, i'm just following the instruction and.........
Try these
1. Close osu! and try again.
2. Run as administrator.
posted

LoliFlan wrote:

2. Run as administrator.
Working now but why my BG not change???
posted

[cocoa] wrote:

LoliFlan wrote:

2. Run as administrator.
Working now but why my BG not change???
You are not a supporter.
posted

LoliFlan wrote:

You are not a supporter.
oh that's makes sense now, why not tell it from first time???
posted

[cocoa] wrote:

LoliFlan wrote:

You are not a supporter.
oh that's makes sense now, why not tell it from first time???
You should know that its a supporter only feature like everyone else..
posted
hi!
after i tried a few things (changing desktop bg, running as admin, restarting pc, updating .net) im still getting this:

See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentException: The path is not of a legal form.
at System.IO.Path.NormalizePath(String path, Boolean fullCheck, Int32 maxPathLength, Boolean expandShortPaths)
at System.IO.Path.GetFullPathInternal(String path)
at System.IO.Path.GetFullPath(String path)
at System.Drawing.IntSecurity.UnsafeGetFullPath(String fileName)
at System.Drawing.IntSecurity.DemandReadFileIO(String fileName)
at System.Drawing.Image.FromFile(String filename, Boolean useEmbeddedColorManagement)
at System.Drawing.Image.FromFile(String filename)
at osuoverlaygui.Core.SetBG_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
o!verlay_gui
Assembly Version: 0.0.0.0
Win32 Version: 0.0.0.0
CodeBase: file:///C:/Users/Bertalan/Desktop/Neuer%20Ordner%20(5)/o!verlay_gui.exe
----------------------------------------
Microsoft.VisualBasic
Assembly Version: 10.0.0.0
Win32 Version: 12.0.51209.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------
System
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Runtime.Remoting
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.34209 built by: FX452RTMGDR
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


Screen resolution: 1280 x 1024
Osu! resolution: 1024 x 600
posted
Odd, let me try to figure out whats causing it.
posted

LoliFlan wrote:

You should know that its a supporter only feature like everyone else..
wow i feel like a dummy now, well this a great app will tell it to everyone (of course who have osu supporter ;) ).
posted

Muv Acid wrote:

CodeBase: file:///C:/Users/Bertalan/Desktop/Neuer%20Ordner%20(5)/o!verlay_gui.exe
-
Can you try to put the application directly on your desktop or somewhere else like C: or D: drive and give it a go.
posted

LoliFlan wrote:

Muv Acid wrote:

CodeBase: file:///C:/Users/Bertalan/Desktop/Neuer%20Ordner%20(5)/o!verlay_gui.exe
-
Can you try to put the application directly on your desktop or somewhere else like C: or D: drive and give it a go.
i guess we are getting somewhere. now it asks for Bertalan.cfg? (bertalan is my name)
http://puu.sh/9oN42/c054eb1f4e.png

And preview background gives this
http://puu.sh/9oN8j/4878734cc9.png
posted
The path is wrong. It shouldn't be C:\Program Files\osu!\Skins, what path did you set?
posted

sheela901 wrote:

Looks cool. I'll try it.
---------------------------------
EDIT: When I test it, there was something that is not right. This is my main background:

And o!verlay use this one:

Also, I use Windows 8.1. The OS may cause this problem?
Are you using more than 1 monitor? If so, it works with the Primary Screen background.
posted

LoliFlan wrote:

The path is wrong. It shouldn't be C:\Program Files\osu!\Skins, what path did you set?
i guess, my pc is beeing an idiot or something...
http://puu.sh/9oO2R/acd408a47b.png
posted

Muv Acid wrote:

LoliFlan wrote:

The path is wrong. It shouldn't be C:\Program Files\osu!\Skins, what path did you set?
i guess, my pc is beeing an idiot or something...
http://puu.sh/9oO2R/acd408a47b.png
Its you actually. Set it to C:\Program Files\osu!

Added a filter to make sure osu! subfolders will not be accepted as the game path.
posted
im running it as admin. http://puu.sh/9oPQR/e053c5c853.png

when running without admin privilaget http://puu.sh/9oPP8/eb02405299.png
posted

Muv Acid wrote:

im running it as admin. http://puu.sh/9oPQR/e053c5c853.png

when running without admin privilaget http://puu.sh/9oPP8/eb02405299.png
Delete the o!verlay cfg file and try again. Your PC IS an idiot. Do you have multiple osu! clients installed or something.
show more
Please sign in to reply.