forum

[Archived] Can't find the Intel graphics

posted
Total Posts
36
Topic Starter
gxrl

OpenGL ES Error



Hello, so two days ago, I've tried to open osu! but it gave me an error saying "OpenGL ES Error; Can't find the Intel graphics" screeshot below and i can't find a solution.
I saw a couple of posts talking about a similar problem, which said "Can't find the name of Intel ICD OpenGL driver", I've looked at both threads ( 1 and 2 ) and tried different solutions.

I've tried downgrading my Intel drivers, running it in compatibility mode, trying to update my drivers again, running the repair osu! and going into my osu!settings and changing "Fullscreen = 1" to "Fullscreen = 0" and this fixed it, yeah, but i have a lot of input lag and can't play like that, so I switched it back and it stopped working again, so I changed it to 0 once again and it didn't work anymore.

My Main Specs are
  1. Zotac GTX 1070
  2. Intel I7 7700
  3. 16 gb RAM DDR4


My Error


This is what it says when my osu! crashes, at the back of the crying Pippi
OpenTK.Graphics.GraphicsContextException: [EGL] Failed to create window surface, error BAD_NATIVE_WINDOW.
en OpenTK.Platform.Egl.EglWindowInfo.CreateWindowSurface(IntPtr config)
en OpenTK.Platform.Egl.EglContext..ctor(GraphicsMode mode, EglWindowInfo window, IGraphicsContext sharedContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
en OpenTK.Platform.Egl.EglAnglePlatformFactory.CreateGLContext(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Boolean directRendering, Int32 major, Int32 minor, GraphicsContextFlags flags)
en OpenTK.Graphics.GraphicsContext..ctor(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
en #=zHahDXDClfUfycfCJl1XPBhBYywD4.#=zDWflqfs=(Int32 #=ziQDgFRo=, Int32 #=zOFGR9vM=, GraphicsContextFlags #=zGrlDMPc=)
en #=z$INYgJGBg3KIDRtF5ZI5ihA=.OnHandleCreated(EventArgs #=zFH8hruE=)
en #=z6EXxIUeHYYzldCaN5MrxaKYlYMnW.OnHandleCreated(EventArgs #=zFH8hruE=)
en System.Windows.Forms.Control.WmCreate(Message& m)
en System.Windows.Forms.Control.WndProc(Message& m)
en System.Windows.Forms.ScrollableControl.WndProc(Message& m)
en System.Windows.Forms.Form.WmCreate(Message& m)
en System.Windows.Forms.Form.WndProc(Message& m)
en #=zdniuNIWPOiiIC3IMIbRc0Vk=.WndProc(Message& #=zzQd1Ah4=)
en System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
en System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
en System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


My osu! version: Stable 20190620.4 (latest)

I hope this was enough information, I haven't tried all the solutions from the threads but, it seems like the ones I didn't try, didn't work either.

And I think thats all.

also sorry for bad english xd
Tobias Leander
The posts you were looking at were pretty old, try this.

Death wrote:

Please make sure your Intel graphics drivers are up to date. Intel released a fix for this specific issue in all of their driver versions 15.46 and higher. If you get your graphics drivers through a computer manufacturer, they may use a different versioning scheme and their most recent drivers may still have this issue. It is good idea to download them directly from Intel's website.

Temporary solutions include: Running osu! with integrated graphics and disabling compatibility mode if applicable. It is highly recommended you fix this issue permanently by downloading up to date drivers.

If you believe you have enabled compatibility mode, navigate to your osu! folder and edit the file "osu!.pcname.cfg". Verify that the line "CompatibilityContext" is set to 0. If it is not, change it and save the file. Otherwise, this was not the cause.
Topic Starter
gxrl

Tobias Leander wrote:

The posts you were looking at were pretty old, try this.

Death wrote:

Please make sure your Intel graphics drivers are up to date. Intel released a fix for this specific issue in all of their driver versions 15.46 and higher. If you get your graphics drivers through a computer manufacturer, they may use a different versioning scheme and their most recent drivers may still have this issue. It is good idea to download them directly from Intel's website.

Temporary solutions include: Running osu! with integrated graphics and disabling compatibility mode if applicable. It is highly recommended you fix this issue permanently by downloading up to date drivers.

If you believe you have enabled compatibility mode, navigate to your osu! folder and edit the file "osu!.pcname.cfg". Verify that the line "CompatibilityContext" is set to 0. If it is not, change it and save the file. Otherwise, this was not the cause.
Thanks for replying.

Regarding the drivers, I already have my intel drivers up to date Pic Below
"CompatibilityContext" was set to 0 and I'm not really sure what you mean by running osu! with integrated graphics and yes, I did disable compatibility mode and it still doesn't work.
Tobias Leander
Could you try uninstalling your current Intel graphics drivers with DDU and then getting the latest drivers from Intel's website?
Topic Starter
gxrl

Tobias Leander wrote:

Could you try uninstalling your current Intel graphics drivers with DDU and then getting the latest drivers from Intel's website?
Ok I tried that, I uninstalled my drivers and reinstalled them from Intel's website but still the same error.
Tobias Leander
Do you have an external monitor plugged in? if so try unplugging it and see if that does anything.
Topic Starter
gxrl
Yes I do have an external monitor. This one is connected to my I7 while my other monitor, is connected with DP to my GTX 1070, and that's the one I play all my games. I unplugged it from the computer and it still gives me this error.
Tobias Leander
You could you try running osu! trough Integrated graphics instead of your gtx 1070, to do this right-click your desktop and open your Nvidia control panel and go to manage 3d settings, then go to program settings and select osu! from there you should be able to change the preferred rendering device.

Another thing you could do is to go to your osu folder and edit the osu!.pcname.cfg file and find the line Fullscreen = 1 and change the number from 1 to 0 and then save the file and launch osu!
Topic Starter
gxrl

Tobias Leander wrote:

You could you try running osu! trough Integrated graphics instead of your gtx 1070, to do this right-click your desktop and open your Nvidia control panel and go to manage 3d settings, then go to program settings and select osu! from there you should be able to change the preferred rendering device.

Another thing you could do is to go to your osu folder and edit the osu!.pcname.cfg file and find the line Fullscreen = 1 and change the number from 1 to 0 and then save the file and launch osu!
So, I know you're going to get mad but I don't know how change the preferred rendering device, could you please help me with that? I've looked but i don't find what i want, or atleast I can't find it on my spanish settings.
Also, I re-installed osu! two times and, FullScreen doesnt appear on my osu!.cfg file.
Hydropisch
So I got this problem too
DolphinTaco
What I did was right-click on the desktop screen to go on to my Nvidia Control panel. Then I went to "Manage 3D settings" and went to the "Program Settings" tab. Find Osu.exe in the "Select a program to customize" dropdown menu or add it if you can't find it. Then I set the preferred graphics processor to "Integrated graphics" and saved it.

This worked for me I hope it works for you!
AXEL777_old_1

DolphinTaco wrote:

What I did was right-click on the desktop screen to go on to my Nvidia Control panel. Then I went to "Manage 3D settings" and went to the "Program Settings" tab. Find Osu.exe in the "Select a program to customize" dropdown menu or add it if you can't find it. Then I set the preferred graphics processor to "Integrated graphics" and saved it.

This worked for me I hope it works for you!
top tier solution
thankyou
jakebirdo
It doesnt work for me because the "preferred graphics processor" doesn't show up for me. Osu still doesn't work :/
Dntm8kmeeatu

jakebirdo wrote:

It doesnt work for me because the "preferred graphics processor" doesn't show up for me. Osu still doesn't work :/
This post is old and outdated.

Please follow these instructions instead.

While osu is closed. Open your Start Menu or a File Explorer window and type %localappdata% in the address bar.
From there, find your osu! folder and open the osu!.pcname.cfg file with Notepad.
Set the following lines as such;

CompatibilityContext = 0
CanForceOptimusCompatibility = 0

Once you are done, save the file, and then launch osu!

Also please make sure your Graphics drivers are installed for your Integrated and Dedicated/Discrete GPU
shadoworbit

Dntm8kmeeatu wrote:

jakebirdo wrote:

It doesnt work for me because the "preferred graphics processor" doesn't show up for me. Osu still doesn't work :/
This post is old and outdated.

Please follow these instructions instead.

While osu is closed. Open your Start Menu or a File Explorer window and type %localappdata% in the address bar.
From there, find your osu! folder and open the osu!.pcname.cfg file with Notepad.
Set the following lines as such;

CompatibilityContext = 0
CanForceOptimusCompatibility = 0

Once you are done, save the file, and then launch osu!

Also please make sure your Graphics drivers are installed for your Integrated and Dedicated/Discrete GPU
I still don't understand
I was playing osu fine earlier and then i went into the setting to change my sensitivity but then t came up with graphics and i accidentally clicked something and when i try to open osu it says cant find intel graphics. I dont know how to find it and/or change it to work as i dont know where to put the %localappdata% as i put it in the search for quick access and my pc but it just said nothing found.
Zelzatter Zero

shadoworbit wrote:

Dntm8kmeeatu wrote:

jakebirdo wrote:

It doesnt work for me because the "preferred graphics processor" doesn't show up for me. Osu still doesn't work :/
This post is old and outdated.

Please follow these instructions instead.

While osu is closed. Open your Start Menu or a File Explorer window and type %localappdata% in the address bar.
From there, find your osu! folder and open the osu!.pcname.cfg file with Notepad.
Set the following lines as such;

CompatibilityContext = 0
CanForceOptimusCompatibility = 0

Once you are done, save the file, and then launch osu!

Also please make sure your Graphics drivers are installed for your Integrated and Dedicated/Discrete GPU
I still don't understand
I was playing osu fine earlier and then i went into the setting to change my sensitivity but then t came up with graphics and i accidentally clicked something and when i try to open osu it says cant find intel graphics. I dont know how to find it and/or change it to work as i dont know where to put the %localappdata% as i put it in the search for quick access and my pc but it just said nothing found.
Did you try to find it though Windows+R? Also how can't you find it in quick access?
shadoworbit

Zelzatter Zero wrote:

shadoworbit wrote:

Dntm8kmeeatu wrote:

jakebirdo wrote:

It doesnt work for me because the "preferred graphics processor" doesn't show up for me. Osu still doesn't work :/
This post is old and outdated.

Please follow these instructions instead.

While osu is closed. Open your Start Menu or a File Explorer window and type %localappdata% in the address bar.
From there, find your osu! folder and open the osu!.pcname.cfg file with Notepad.
Set the following lines as such;

CompatibilityContext = 0
CanForceOptimusCompatibility = 0

Once you are done, save the file, and then launch osu!

Also please make sure your Graphics drivers are installed for your Integrated and Dedicated/Discrete GPU
I still don't understand
I was playing osu fine earlier and then i went into the setting to change my sensitivity but then t came up with graphics and i accidentally clicked something and when i try to open osu it says cant find intel graphics. I dont know how to find it and/or change it to work as i dont know where to put the %localappdata% as i put it in the search for quick access and my pc but it just said nothing found.
Did you try to find it though Windows+R? Also how can't you find it in quick access?
I found through Windows+R but when i typed it in quick access it wouldnt find anything

I have done it and it now works, thanks for the help
bb1YT

Dntm8kmeeatu wrote:

jakebirdo wrote:

It doesnt work for me because the "preferred graphics processor" doesn't show up for me. Osu still doesn't work :/
This post is old and outdated.

Please follow these instructions instead.

While osu is closed. Open your Start Menu or a File Explorer window and type %localappdata% in the address bar.
From there, find your osu! folder and open the osu!.pcname.cfg file with Notepad.
Set the following lines as such;

CompatibilityContext = 0
CanForceOptimusCompatibility = 0

Once you are done, save the file, and then launch osu!

Also please make sure your Graphics drivers are installed for your Integrated and Dedicated/Discrete GPU
thank you
CheeryFlame4611

Dntm8kmeeatu wrote:

jakebirdo wrote:

It doesnt work for me because the "preferred graphics processor" doesn't show up for me. Osu still doesn't work :/
This post is old and outdated.

Please follow these instructions instead.

While osu is closed. Open your Start Menu or a File Explorer window and type %localappdata% in the address bar.
From there, find your osu! folder and open the osu!.pcname.cfg file with Notepad.
Set the following lines as such;

CompatibilityContext = 0
CanForceOptimusCompatibility = 0

Once you are done, save the file, and then launch osu!

Also please make sure your Graphics drivers are installed for your Integrated and Dedicated/Discrete GPU
You are an absolute lifesaver, I thought I was going to have to reinstall the game and all the maps.
Thanks you!
Nashe

Tobias Leander wrote:

You could you try running osu! trough Integrated graphics instead of your gtx 1070, to do this right-click your desktop and open your Nvidia control panel and go to manage 3d settings, then go to program settings and select osu! from there you should be able to change the preferred rendering device.

Another thing you could do is to go to your osu folder and edit the osu!.pcname.cfg file and find the line Fullscreen = 1 and change the number from 1 to 0 and then save the file and launch osu!
thanks bro
show more
Please sign in to reply.

New reply