1. osu!community
  2. osu!
  3. Help
  4. Resolved Issues
posted

KnightlyAurora wrote:

For the past 3-4 months after updating my GPU drivers and being forced into another Win10 update, I used to get a 0.9-1ms response before all of this, but now my game fluctuates in frames, and I only get a response rate of 4-5ms in game. I've tried almost every solution, Disable Fullscreen Optimizations, Run the game windowed, Uninstall and fresh install, run it borderless windowed, and try to run it on a lower resolution. This has been driving me up the wall for the longest time now as I suffer Osu withdrawl!

My specs are an Asus ROG Gl752 with;
OS: Win10 64bit
GPU: Nvidia GTX960M
RAM: 16GB
CPU: Intel i7-6700HQ
Though we may not be exactly experiencing one's symptoms, it does seem that there's some kind of correlation between NVIDIA GPUs, laptops (from what I've seen so far), and increased frame times. I truly wonder what causes this, if we'll ever get to the bottom of it...

Thank you for attempting all of the suggestions, and I am truly sorry to hear that none of them were effective in your case. All I can say is that you'll have to adapt to the change somehow, unless we can figure out something else.

Best of luck to you, my friend.
posted
Nvidia 930m Intel core I3 5010U same problem. I also have a desktop where I play with my RX 480 and Ryzen 5 1400, so my laptop is useless for Osu!
posted

zodyak wrote:

Nvidia 930m Intel core I3 5010U same problem. I also have a desktop where I play with my RX 480 and Ryzen 5 1400, so my laptop is useless for Osu!
Thanks for sharing your similar issue with us; makes the issue ever more so persistent!

Quick question, does the problem also occur on your desktop, with the AMD GPU? Perhaps that can even further specify the problem to only NVIDIA GPUs.

If you have not already, attempt the number of suggested fixes on the thread, and see if they work for your laptop.

Best of luck to you :)
posted
Nothing helped and found nothing :?
posted

-Raijin wrote:

Nothing helped and found nothing :?
You have my dearest condolences... That's really unfortunate.

For the time being, we can only wait. Nevertheless, thanks again for contributing to the post.

TR4NQU1L1TY
posted

TR4NQU1L1TY wrote:

-Raijin wrote:

Nothing helped and found nothing :?
You have my dearest condolences... That's really unfortunate.

For the time being, we can only wait. Nevertheless, thanks again for contributing to the post.

TR4NQU1L1TY
Yeah we just have to wait and see. :(:D
posted
hi i just wanted to say i have the same problem right now, osu! is capped at 60fps in fullscreen but gets all the fps in windows (like 400) i have gtx 850M
posted
Who knows if our issue is related to this https://www.reddit.com/r/pcgaming/comme ... ced_vsync/

I'm super tired of this already, I give up on looking for solutions zzz
posted

smau5 wrote:

hi i just wanted to say i have the same problem right now, osu! is capped at 60fps in fullscreen but gets all the fps in windows (like 400) i have gtx 850M
Thanks for sharing your issue with us; it's good to know that this problem affects many out there. Now, if only we could get some help!

Fortunately, it seems that playing windowed is a fine workaround for you. If it helps even more, try running the game fullscreen with integrated graphics; worked better for me!

Thanks again :D

ezek wrote:

Who knows if our issue is related to this https://www.reddit.com/r/pcgaming/comme ... ced_vsync/

I'm super tired of this already, I give up on looking for solutions zzz
Heyo, ezek. Welcome back to the ongoing mess, XD.

I looked into your provided link, and actually it has occurred to me that Windows 10 might be a possible culprit. It disrupted my Counter-Strike: Global Offensive, locking it to the mentioned 60 FPS. Impossible to play as I used to.

However, I did manage to fix it! I messed around with Window's "Game Mode" feature, toggling it on or off... The problem is gone, and I can happily achieve my 120 FPS while playing.

If only that'd work for osu! :? Maybe I'll experiment a bit when I have time, later...

I too am annoyed at the persisting problem at hand, and the lack of help we've been receiving (still, kudos to Death at the beginning)... Weird, you'd think they would check out a thread that's hit over 50 posts, with 1,325+ views since the beginning.

Let's see how it goes. Yet again, thanks for your contribution, ezek. Best of luck to you :)
posted
Hi,

I have the same problem. I've tried everything but still stays at 60 FPS with 17ms.
Every other game works fine, except osu! :(

(Dell XPS 15 9560) Specs:
OS: Windows 10 Home
CPU: Intel i7-7700HQ
GPU: Nvidia GTX 1050 (4GB)
RAM: 16 GB

However, I have no problems on my computer which has almost the same specs as my laptop.

Pretty weird =/
posted

Eren024 wrote:

Hi,

I have the same problem. I've tried everything but still stays at 60 FPS with 17ms.
Every other game works fine, except osu! :(

(Dell XPS 15 9560) Specs:
OS: Windows 10 Home
CPU: Intel i7-7700HQ
GPU: Nvidia GTX 1050 (4GB)
RAM: 16 GB

However, I have no problems on my computer which has almost the same specs as my laptop.

Pretty weird =/
Greetings, fellow osu! player. Those specs look practically identical to my brother's HP OMEN laptop - also mentioned by ezek in previous posts! - could it perhaps be another model with 16GB of RAM? If you can confirm on this, please do so.

You say you have tried everything, yet to no avail. That sounds quite unfortunate... I don't mean to be disbelieving, but have you attempted to run osu! on

1) Your integrated graphics (if possible, that is)
2) On fullscreen borderless, utilizing your GTX 1050

For my brother's laptop (and ezek's!) the above workarounds did remove the cap. My brother manages less than 1ms (meaning more than 1000 FPS) ingame, while on borderless (with his 8GB of RAM, mind you) windowed. Integrated graphics (in fullscreen) also worked to remove the 60 FPS cap, but it was significantly weaker at performance (fluctuating around the 200 FPS range) when compared to his NVIDIA GPU + borderless windowed.

If you have already attempted such things, I apologize in advance for being useless ;-;

On a final note, you say you have no such problems on a desktop - with nearly the same specs, too. How could this be, that the problem is only prominent in laptops? That's quite the curiosity... I cannot think of any reason for this occurrence, but it nevertheless confirms my suspicions.

From what I've observed so far... The 60 FPS and 17ms lock applies to laptops with NVIDIA GPUs, when running osu! with a NVIDIA GPU in fullscreen.

More or less.

Thank you Eren024 for contributing to the thread. Don't hesitate if you have any ideas, questions, or comments to be made with this persisting issue.

I wish you the best of luck :D
TR4NQU1L1TY
posted
peppy peppy doo where are you 🎵
posted
It may seem counter intuitive, but can you guys try reinstalling/updating your Intel Graphics Drivers with this slightly old version. Before you download and install it, verify that it's actually valid for your computer, I believe it should be for most people.
posted
Death contacted me in-game thank god he didn't come for my soul and he told me to do what he just said above. My laptop didn't want to install the drivers and showed a message saying the driver wasn't for my laptop, but we were sure it was. Well, I did the manual installation since it didn't work with the .exe and it installed correctly.

And guess what! it got fixed! NO MORE 60FPS/17MS LOCK

Who could've guessed the issue had to do with intel drivers when our problem was when running with nvidia~

Let's see if it works with you too, guys~

Thanks Death, you're the best!

Edit: After that got fixed I got another issue. Osu! froze every time I did alt+tab or used the windows key, but that got fixed by disabling discord's in-game overlay. Just saying in case someone else gets this problem~
posted
Well idk what to do then, the driver you linked isn't compatible with my cpu, so i searched for the ones that were compatible and there are 3, one from 2018, one from 2017 and one from 2016. I tried installing the 2018 one but it didn't fix the problem, and when i tried the other two the installation gives me an error saying it couldn't install the driver.
posted
If you've tried everything else in this thread and that driver is not valid for your CPU, try to roll back a version instead.

I'm unable to test whether or not this issue is even caused by drivers on CPUs that aren't covered in that driver version I linked. It's possible it's still something else.

If you try to install the drivers I linked and you get an error message along the lines of, "The driver being installed is not validated for this computer" then give this page from Intel a read. If you are receiving a different error message then I would wait and try different solutions.
posted

Death wrote:

If you've tried everything else in this thread and that driver is not valid for your CPU, try to roll back a version instead.

I'm unable to test whether or not this issue is even caused by drivers on CPUs that aren't covered in that driver version I linked. It's possible it's still something else.

If you try to install the drivers I linked and you get an error message along the lines of, "The driver being installed is not validated for this computer" then give this page from Intel a read. If you are receiving a different error message then I would wait and try different solutions.
Could it be because I installed it with the .exe instead of using the .zip? I doubt it could be that, but i'll try it anyway.

Edit: managed to install an older driver with the zip file, rebooted the pc, got a blue screen, game still running at 60 fps, currently installing the latest driver again...
posted

Death wrote:

It may seem counter intuitive, but can you guys try reinstalling/updating your Intel Graphics Drivers with this slightly old version. Before you download and install it, verify that it's actually valid for your computer, I believe it should be for most people.
I shall attempt to do so as soon as I have time, perhaps by the weekend :D

Let's see how this goes! I'll update this post accordingly. Thanks again, Death :)

ezek wrote:

Death contacted me in-game thank god he didn't come for my soul and he told me to do what he just said above. My laptop didn't want to install the drivers and showed a message saying the driver wasn't for my laptop, but we were sure it was. Well, I did the manual installation since it didn't work with the .exe and it installed correctly.

And guess what! it got fixed! NO MORE 60FPS/17MS LOCK

Who could've guessed the issue had to do with intel drivers when our problem was when running with nvidia~

Let's see if it works with you too, guys~

Thanks Death, you're the best!

Edit: After that got fixed I got another issue. Osu! froze every time I did alt+tab or used the windows key, but that got fixed by disabling discord's in-game overlay. Just saying in case someone else gets this problem~
Wonderful that it worked for you! I hope it helps me too, XD

Nevertheless, please report back if you do experience certain issues ;)

Intel drivers conflicting with NVIDIA, huh. I would never have imagined... :thinking: Only Death knows o_O

Thank you for all you have contributed to the thread, ezek. :D

Ari0n wrote:

Death wrote:

If you've tried everything else in this thread and that driver is not valid for your CPU, try to roll back a version instead.



I'm unable to test whether or not this issue is even caused by drivers on CPUs that aren't covered in that driver version I linked. It's possible it's still something else.



If you try to install the drivers I linked and you get an error message along the lines of, "The driver being installed is not validated for this computer" then give this page from Intel a read. If you are receiving a different error message then I would wait and try different solutions.
Could it be because I installed it with the .exe instead of using the .zip? I doubt it could be that, but i'll try it anyway.



Edit: managed to install an older driver with the zip file, rebooted the pc, got a blue screen, game still running at 60 fps, currently installing the latest driver again...
Hm... You have my sympathy in the current predicament you are in. Keep us updated, and tell us if you figure things out; it could help many others.

Best of luck, Ari0n. May your year of waiting be over ;-;

Thank you again, everyone! I'll update my status soon! Until then... TR4NQU1L1TY

UPDATE! Doesn't seem that the provided driver is supported by my laptop's CPU... In attempting to install, I receive the following message after reading and extracting the files: "This computer does not meet the minimum requirements for installing the software." Looking further into it, the download does not seem to be valid for my Intel Core i5-5200U, nor my Intel HD Graphics 5500. That sucks.

Any ideas on how/what I am to "roll back," regarding my Intel components? All help is appreciated!
posted
I apologize for this double post, but I thought it was necessary for my following report. I am sorry for any inconvenience in doing so.

Ever since we pinpointed the issue to be somehow connected to Intel graphics, I started to play around with possible things.

First, I tried to download and install the provided graphics from Death, but they did not seem to be compatible with my laptop.

Then, I located some drivers for my own Intel components (Intel HD Graphics 5500, to be specific). In doing so, I tried to install some of those drivers, but to no avail: "...not validated for this computer..."

I proceeded to attempt to manually install the drivers, again, suggested by Death. However, in observing the instructions provided by Intel, I noticed how you could update your Intel drivers utilizing your Device Manager in Windows. So, I opened that up, found my Intel HD Graphics 5500 under "Display adapters," right-clicked it, and saw "Update driver."

Now, when you click that, you'll be presented with two options. One letting your computer automatically search for possible updated drivers, or two, manually locating your downloaded driver. Of course, you would choose the second option if you were installing the drivers manually. Nonetheless, I gave the former a try...

I guess the program did find something to update, and it began to install some new drivers... Again, manually downloading a ZIP file for your drivers isn't necessary for this; your computer does the work for you.

It finished its install, and I opened up osu! using my NVIDIA GPU in fullscreen.

No more 60 FPS cap, no more 17ms of frame time.

Man, am I relieved. I sincerely hope this isn't something temporary :P I'll report in if anything does happen.

Please attempt this fix! Perhaps it'll work for you, and you'll finally be able use your NVIDIA GPU in fullscreen without a problem :D

Before I conclude, I'd like to state a funny observation I made. I tested the following four combinations in running osu!:

1. osu! with integrated graphics, fullscreen.
2. osu! with integrated graphics, windowed fullscreen borderless.
3. osu! with NVIDIA GPU, fullscreen, with fix.
4. osu! with NVIDIA GPU, windowed fullscreen borderless.

And the results, when playing a beatmap...

1. Less than 1ms - 1.5ms = 667 FPS - 1000+ FPS
2. 4ms - 5ms = 200 FPS - 250 FPS
3. ~3ms = 333 FPS
4. 2.5ms - 3ms = 333 FPS - 400 FPS

In the end, I decided to stick with playing osu! on fullscreen, using my integrated Intel HD Graphics 5500.

I guess my 820M isn't as great as I had thought it to be ;-;

Though it may have ultimately been a pointless effort for me, I hope that others with significantly more powerful NVIDIA GPUs who have been suffering with this issue will find happiness with the aforementioned solution!

I wish you the best of luck, and I thank everyone for all the help and feedback! :)Special thanks to Death and ezek! :)

~ TR4NQU1L1TY ~
posted
Ok i tried disabling Gsync and it worked, i got 2ms and 240 fps.
But sadly deactivating Gsync just for osu is not really the way to go because then there is a bug that sometimes you need to restart your pc to enable Gsync again after playing Osu.
So the problem for many people was that Osu is not compatible with Gsync all along.
Shouldn't we let peppy now?
Please sign in to reply.