1. osu!community
  2. osu!
  3. Help
  4. Resolved Issues
posted
Hey guys, I've came across an issue I'd like to discuss. When running osu! on my dedicated NVIDIA 820M GPU (not the best, but it's my laptop), it always caps to 60 FPS (though it fluctuates from 60 - 61). This lock is accompanied by a severe 17ms of input lag.



I am quite sure that vSync (vertical sync) is disabled, as I play on the "unlimited" fps setting.



In the NVIDIA Control Panel, it is also disabled.



Interestingly enough, this only occurs on the fullscreen setting. When toggled off - into windowed mode - I receive maximum fps, with around 4ms of input lag. Nonetheless, I continue to play on my integrated graphics, Intel(R) HD Graphics 5500. Here, I also achieve maximum fps, but the latency bounces from time to time, in addition to the occasional second of freezing when playing a map. I want to try using the NVIDIA GPU, to see if it's possible for improvement.

If need be, I can fetch additional information that may be relevant to this problem.

Have a good one, TR4NQU1L1TY.

collapsed text
EDIT! It seems that I have come across the misconception that the "ms" indicated in osu!'s FPS counter is NOT input lag! Rather, it is one's "frame times."

I quote Death here:

Death wrote:

If you are using the ms values at the bottom right of your screen while playing, this is not input lag. These are your frame times, which is just the inverse of FPS. You can calculate your FPS using these values by doing 1000/ms = fps. 3ms would be 333.333fps and 2ms would be 500fps.


Disregard my mistakes throughout the post! I apologize for any inconveniences. :?
posted
Inside your osu! folder, right click on the osu!.exe, select Properties, and then Compatibility. Once there, check "Disable fullscreen optimizations."

If that does not work, restart you computer, close any programs you have running in the background and disable any overlays you have enabled.

You can also try updating or reinstalling your graphics drivers.
posted

Death wrote:

Inside your osu! folder, right click on the osu!.exe, select Properties, and then Compatibility. Once there, check "Disable fullscreen optimizations."

If that does not work, restart you computer, close any programs you have running in the background and disable any overlays you have enabled.

You can also try updating or reinstalling your graphics drivers.


Thanks for the speedy response!

I took a shot at disabling fullscreen optimizations. Following all your directions, I navigated the files to adjust the settings as you indicated. However, it seems that the issue continues to persist: I am still locked at 60-61 FPS, with 17ms of input lag.

Restarting my computer did not do the trick, and I analyze this issue with osu! as the only open program, without any overlays.

I just updated the graphics card via NVIDIA GeForce Experience, hoping that it would work...

Unfortunately, it didn't D:

Please continue to attempt to find a solution. All help is appreciated. If you require any other information, simply ask.
posted
Do you have any programs like EVGA Precision X or MSI Afterburner installed on your computer at all? Programs such as these have been found in the past to be the culprit of this capped FPS issue, and sometimes people forget about disabling them.
posted

Death wrote:

Do you have any programs like EVGA Precision X or MSI Afterburner installed on your computer at all? Programs such as these have been found in the past to be the culprit of this capped FPS issue, and sometimes people forget about disabling them.


Sorry for a late response, I got busy over the past couple of days.

I do not believe I have such programs installed. The only item that may fall under the same category is NVIDIA GeForce Experience. Yet, I do not believe that it applies to osu! at all, as it does not recognize it as an official game... I simply use GeForce Experience to update my NVIDIA drivers, which are indeed of the latest build.

Interestingly enough, this seems to be a widespread issue. I have realized that osu! is set to run on integrated graphics by default, as seen on both of my brothers' laptops. In terms of specifications, their computers are of greater quality than mine.

On both computers, I have attempted to run osu! via their NVIDIA GPUs - NVIDIA GTX 1050 and 960mx. Being in fullscreen, the same issue occurs! A fluctuating 60 FPS cap, with 17ms of input lag. This is not the case when you run it in integrated graphics, nor in windowed w/ a NVIDIA GPU.

Could this be some kind of issue regarding NVIDIA GPUs + fullscreen in osu!...?

Any feedback would be appreciated. I apologize for any inconvenience in the delayed reply!
posted
Try disabling the In-game overlay through GeForce Experience.
posted

Death wrote:

Try disabling the In-game overlay through GeForce Experience.


NVIDIA GeForce Experience's In-Game Overlay does not seem to be compatible with my older GPU...



Any other thoughts?
posted
Do you have any power saving settings enabled on your laptop? If so disable them, also plug your laptop in if it is not.

Check to make sure your graphics card also has maximum performance selected for anything power related.
posted

Death wrote:

Do you have any power saving settings enabled on your laptop? If so disable them, also plug your laptop in if it is not.

Check to make sure your graphics card also has maximum performance selected for anything power related.


Observing the NVIDIA Control Panel, the option of "Power Management Mode" has been set to "Prefer maximum performance," in addition "Texture filtering - Quality" to being set to "High performance." "Threaded optimization" is also enabled, to allow the usage of multiple CPUs...

Within the power settings of my computer, it is set to "High Performance." Items regarding graphics and CPU usage has been set to maximum performance.

And yes, I do play with my laptop plugged in :)

Nonetheless, the issue continues to persist. Please mention if I may have missed something relevant.
posted
try turning down the resolution (of osu)
posted

Kondou-Shinichi wrote:

try turning down the resolution (of osu)


Ah, still no luck. I attempted all available resolutions with fullscreen. The issue persists, with the NVIDIA GPU - a 60 FPS lock and 17ms of input lag.

Thanks for the suggestion, though :D
posted
idk if this is related, but try turning game DVR and game bar off

goto settings (control panel), then gaming, then turn both game dvr and game bar off.

researched a bit online and i saw some people having same problem with fullscreen capping at 60fps when this helped them, so give it a try
posted
Well I've been having the exact same problem for almost a year now and funny enough I was looking for solutions again today because I got so annoyed by the variations in fps i get from playing with the integrated graphics, and found your post. Not sure if this is a problem with laptops, because I play on one too, though my gpu is a 740m.
I have tried all the possible fixes already, so i'm just leaving a comment to see if someone comes up with a solution and to show that you're not alone with this mind breaking problem, my friend. :cry:
posted

Kondou-Shinichi wrote:

idk if this is related, but try turning game DVR and game bar off

goto settings (control panel), then gaming, then turn both game dvr and game bar off.

researched a bit online and i saw some people having same problem with fullscreen capping at 60fps when this helped them, so give it a try


Thanks for another suggestion! I've actually tried this before, but to no avail. Interestingly enough, I discovered this fix when my Counter-Strike: Global Offensive was locked at 60 FPS with irregular input lag! It worked for that game... if only it did for osu! :)

Ari0n wrote:

Well I've been having the exact same problem for almost a year now and funny enough I was looking for solutions again today because I got so annoyed by the variations in fps i get from playing with the integrated graphics, and found your post. Not sure if this is a problem with laptops, because I play on one too, though my gpu is a 740m.
I have tried all the possible fixes already, so i'm just leaving a comment to see if someone comes up with a solution and to show that you're not alone with this mind breaking problem, my friend. :cry:


Yikes, nearly a year? Yes, I've also researched this online, and it seems to be a reoccurring issue among a number of NVIDIA GPUs - from what I've seen, of course. Developers, hear us out! (at your convenience, of course :D)

Thanks for the words of empathy! I truly hope that we are able to find a fix sometime in the future... Until then, my friend ;)
posted
I also have this problem (GTX 1050, i5-7300HQ laptop)
I've been playing with integrated graphics until i can find a solution, but the lag spikes are really annoying
With the NVIDIA GPU, if i restart my laptop, the issue gets removed strangely, but i have to do that every time i plan to play the game

Disabling fullscreen optimizations on the osu.exe properties + Compability mode in osu settings removed the cap but increased the input lag a bit, having average 2.0ms (but no lag spikes) vs 1.3ms on integrated

idk what's limiting exactly the fps, happens only when I'm with NVIDIA GPU + fullscreen
posted

KrisyYy wrote:

I also have this problem (GTX 1050, i5-7300HQ laptop)
I've been playing with integrated graphics until i can find a solution, but the lag spikes are really annoying
With the NVIDIA GPU, if i restart my laptop, the issue gets removed strangely, but i have to do that every time i plan to play the game

Disabling fullscreen optimizations on the osu.exe properties + Compability mode in osu settings removed the cap but increased the input lag a bit, having average 2.0ms (but no lag spikes) vs 1.3ms on integrated

idk what's limiting exactly the fps, happens only when I'm with NVIDIA GPU + fullscreen


Interesting suggestion, and it did seem to have some success! The 60 FPS lock was indeed lifted, and the input lag was no longer at 17ms.

Using "Disable fullscreen optimizations" and running the game with osu!'s "Compatibility Mode," I achieve my maximum FPS (set to 240) and around 3.0ms of input lag (which I am currently used to, I do not believe I have ever played with anything lower XD is that a bad thing).

These results are similar to operating osu! on fullscreen windowed (borderless) at my maximum resolution of 1366x768, which I have been doing since the beginning of this post.

I'll see if there's an actual difference, playing between the two options:

(NVIDIA + fullscreen + "Disable fullscreen optimizations" + osu!'s Compatibility Mode) vs (NVIDIA + fullscreen windowed borderless)

Again, both result in a constant 240 FPS and approximately 3.0ms of input lag when playing a beatmap.

Thanks for your contribution! Anything else (from anyone!) would be appreciated :)
posted
lmao you just posted right before me

do you use unlimited fps as your fps limiter? or is it 240fps?
posted

Kondou-Shinichi wrote:

lmao you just posted right before me

do you use unlimited fps as your fps limiter? or is it 240fps?


LOL I DIDN'T NOTICE

I set it to the "Unlimited" FPS option, but it shows FPS/240FPS on the FPS counter, at the bottom right of the screen.

Also, I was experimenting with my integrated Intel graphics... I get overall less FPS (ranging from 150 to 180FPS, not usually going over 200), but also less input lag, at 2.0ms to even less than 1.0ms.

Regarding my previous post, both of those "fixes" result in a greater total of FPS (for me, the aforementioned 240FPS) but around 3.0ms of input lag. This is probably due to the fact of "Compatibility Mode" or "fullscreen windowed borderless," depending on what "solution" you are utilizing.

~150FPS and less than 2.0ms (integrated) ... vs 240FPS and around 3.0ms (NVIDIA) ...

I'm curious if this makes a significant difference! Please provide feedback on what is to be prioritized, if anything :D
posted
Where are you getting these numbers for "input lag"?

If you are using the ms values at the bottom right of your screen while playing, this is not input lag. These are your frame times, which is just the inverse of FPS. You can calculate your FPS using these values by doing 1000/ms = fps. 3ms would be 333.333fps and 2ms would be 500fps.

The difference should not be too significant unless you are getting spikes. But, you are able to play on both, you should try to see if you feel a difference yourself.
posted

Death wrote:

Where are you getting these numbers for "input lag"?



If you are using the ms values at the bottom right of your screen while playing, this is not input lag. These are your frame times, which is just the inverse of FPS. You can calculate your FPS using these values by doing 1000/ms = fps. 3ms would be 333.333fps and 2ms would be 500fps.



The difference should not be too significant unless you are getting spikes. But, you are able to play on both, you should try to see if you feel a difference yourself.


Oh, jeez. I had no idea...

I've always assumed that was an indication of input lag. The reason for this was due to the fact that the 60 FPS lock also included "17ms," and cursor movement was severely slowed down, "lagging" behind when compared to 240 FPS and a lower "ms" value (ranging from "4.0ms" and below).

I feel so foolish right now :?

As you have uncovered an incorrect interpretation of mine, is there any valid way (instead of relatively "feeling" it) to observe "input lag" within osu!...?

Such things aside, my FPS continues to be locked at 60 with my NVIDIA GPU and fullscreen, while including a constant "frame time" of 17ms.

This 60 FPS cap and the frame time of 17ms results in a sluggish, delayed cursor movement, which makes osu! basically unplayable from what I am used to. I avoid this issue by running osu! using the aforementioned settings, spoken throughout this post.

I shall perform further testing on both settings when I have time.

Please forgive my error! If need be, I can clarify on anything else... Additionally, whatever help is appreciated.
Please sign in to reply.