Solution: Running osu! In Ubuntu or Xubuntu

posted
Total Posts
938
show more
[deleted user]
I'm running Ubuntu 9.04 and can't get the game to run using the instructions provided. When I try to install the game the files begin to copy, then the installation crashes. The files that do transfer are below.

Any advice?

anonymous_old

prosive wrote:

Also is there any way to bottle up a fresh working install of osu! on wine and distribute it? Like for example, later when I get time I am going to try to run osu! on my ubuntu machine, if I get it working, could I potentially just port the bottle over to my os x machine and try it out?
There's nothing special about osu! installs. You can copy an installation anywhere and run it from any computer (assuming the configuration is compatible across the systems).
GolemdX
tinkyxiii, try installing on Windows and copy it over.

For me...
Application has generated an exception that could not be handled.

Process ID=0x19 (25), Thread ID=0x1a (26).

Click OK to terminate the application.
Click CANCEL to debug the application.
Click OK and...
The program osu!.exe has encountered a serious problem
and needs to close. We are sorry for the inconvenience.

Blah blah blah http://appdb.winehq.org blah blah blah

Blah blah blah blah blah blah http://bugs.winehq.org.

...and nothing else.
Topic Starter
KcLKcL
This map has been deleted on the request of its creator. It is no longer available.
GolemdX
I did.

Also, insufficient priveleges for the app.
Somebody should make a linux installer. I could once I get it to work...
Intermezzo
Did you try to open up osu!.yourLocalAccountHere.cfg and change Renderer = d3d to Renderer = opengl ?
GolemdX
Just tried that... same error.

If I go to "Uninstall Wine Software", Microsoft .NET Framework 2.0 is listed twice. Once with the version 2.0.50727 and the Visual Studio logo as the icon, and the other one has no version and has the Wine logo as the icon.
[deleted user]
Well I'm trying to run this through wine again (I must be a masochist). Instead of using the GUI, I used the command line to get wine and winetricks working on OS X, and installed the corefonts and dotnet20 winetricks. Then I copied my game folder over and ran it. The crash / bug reporter screen shows up for me. I'm not sure if I'm missing anything, but any help would be much appreciated. Basically it crashes then submits the bug and restarts and the same thing happens. I also tried deleting my user configuration. I have attached a screen shot.





CoGetContextToken apartment not initialised
fixme:shell:URL_ParseUrl failed to parse L"System"
fixme:shell:URL_ParseUrl failed to parse L"System.Windows.Forms"
fixme:shell:URL_ParseUrl failed to parse L"System.Drawing"
fixme:shell:URL_ParseUrl failed to parse L"osu"
fixme:shell:URL_ParseUrl failed to parse L"Microsoft.Xna.Framework"
fixme:shell:URL_ParseUrl failed to parse L"System.Runtime.Remoting"
fixme:process:SetProcessPriorityBoost (0x170,0): stub
fixme:shell:URL_ParseUrl failed to parse L"msvcm80"
fixme:win:EnumDisplayDevicesW ((null),0,0x33dba0,0x00000000), stub!
fixme:wave:wodDsCreate DirectSound not implemented
fixme:wave:wodDsCreate The (slower) DirectSound HEL mode will be used instead.
fixme:wave:wodDsCreate DirectSound not implemented
fixme:wave:wodDsCreate The (slower) DirectSound HEL mode will be used instead.
err:ole:CoGetClassObject class {bcde0395-e52f-467c-8e3d-c4579291692e} not registered
err:ole:CoGetClassObject no class object {bcde0395-e52f-467c-8e3d-c4579291692e} could be created for context 0x1
err:wgl:opengl_error No OpenGL support compiled in.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
err:d3d:WineDirect3DCreate Direct3D9 is not available without opengl
fixme:shell:URL_ParseUrl failed to parse L"mscorlib.resources"
fixme:shell:URL_ParseUrl failed to parse L"osu!.resources"
fixme:shell:URL_ParseUrl failed to parse L"{ef5dc3ce-33e8-49bf-a83b-f70d0ebf15b8}"
fixme:shell:URL_ParseUrl failed to parse L"osu!.resources"
fixme:advapi:CheckTokenMembership (0x440 0x21bb40 0x11dbdb48) stub!
fixme:imm:ImmDisableIME (-1): stub
fixme:thread:NtQueryInformationThread Cannot get kerneltime or usertime of other threads
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:advapi:RegisterEventSourceW ((null),L".NET Runtime 2.0 Error Reporting"): stub
fixme:advapi:ReportEventW (0xcafe4242,0x0001,0x0000,0x000003e8,0x0,0x0008,0x000000d0,0x3009a1b4,0x6cd260): stub
err:eventlog:ReportEventW L"osu!.exe"
err:eventlog:ReportEventW L"1.3.3.7"
err:eventlog:ReportEventW L"4ae3fa5f"
err:eventlog:ReportEventW L"unknown"
err:eventlog:ReportEventW L"0.0.0.0"
err:eventlog:ReportEventW L"00000000"
err:eventlog:ReportEventW L"0"
err:eventlog:ReportEventW L"8000000a"
fixme:advapi:DeregisterEventSource (0xcafe4242) stub
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet
fixme:thread:NtQueryInformationThread info class 9 not supported yet

gorghurt
well
i also have the problem, that i can't use the openGL mode.
does anybody made it work already.




sorry for my bad english

edit:
for all those who dont get dot20 installed, i could try upload my .wine folder.
CoCoMW
I've just installed ubuntu. i did everything what was written here and as you might guess, osu doesn't work properly. It turns on but instead of menu i've got some random textures. And after few second of this screen, report window pops up and it turns off.

http://img177.imageshack.us/i/zrzutekranug.png/ (screen)

I was able to change rendering to opengl, but it didn't work :D please help me ;]
Sakako
Can we get a link to winetricks .deb? It's been removed from the Karmic repositories.

Also, a zip of the install would be nice - the .msi doesn't seem to work properly, even with msiexec.
BOSSU
I updated wine today for the first time in a number of months, and decided I would try osu.
Surprisingly, it works almost flawlessly (I didn't measure fps or anything, but it is beyond being merely "playable").
Strangely, though, it tends to crash when I try to reposition the window.

Not sure if this helps, but I also installed the d3dx9, vcrun2005 (sp1) and dotnet20 packages from winetricks beforehand.

Sakako wrote:

Can we get a link to winetricks .deb? It's been removed from the Karmic repositories.

Also, a zip of the install would be nice - the .msi doesn't seem to work properly, even with msiexec.
wget http://www.kegel.com/wine/winetricks
There is no binary, it's just a giant shell script.

Edit: Forgot to mention that the updater works.
HarZens
This map has been deleted on the request of its creator. It is no longer available.
Esupanitix
This version of osu! will be a drunk copy.
HarryHy
When I try to install, I get:
404
zenadoreg
awp
This map has been deleted on the request of its creator. It is no longer available.
bagnz0r
For all those who are lazy/don't understand simple tutorial.
Start your terminal and execute this:
wget http://bagnzor.org.pl/prepare-osu

And then execute this:
sh prepare-osu

OR

Download that: http://bagnzor.org.pl/prepare-osu and execute it in terminal.
Subaru
mine crashes after how many seconds. i don't know why (it rarely happens though)

using Ubuntu 9.04 Jaunty Jackalope

Edit1: Sound is not sync properly, or is it just me?
Edit2: Crashes upon exiting in Universal Offset.
Kaya-
Works fine, no lags(Kubuntu) but all fonts are realy sharp =( (Does some1 kno' how to fix Opengl?!)
Also:no background images in beatmap list =(
show more
Please sign in to reply.

New reply