User avatar
Tempo Trainee
8 posts
Offline
When I try to open osu the "Can't find the name of Intel ICD openGL driver" window appears and sometimes osu won't open at all.
I'm not able to back to previous of my Intel's graphics driver and i tried to download other versions of intel drivers but it seems my computerr isn't compatible with them. I also have uninstalled and reinstalled the official Intel driver from the manufacturer's (Lenovo) site.
Image
https://imgur.com/a/a5Z2K
I have Fullscreen = 0
Image
https://imgur.com/a/nTf9y
It started after I updated my windows to version 1709. (I did some smaller updates after that one but I don't know if they matter.)
Image
https://imgur.com/a/FGmGr
I have turned turned Windows DVR off.
Image
https://imgur.com/a/sKTAH
Here is my computer's information.
Image
https://imgur.com/a/Hv8Kh
And here is the error message I got from osu crash window. (Behind crying Pippi)

OpenTK.Graphics.GraphicsContextException: [EGL] Failed to create window surface, error BAD_NATIVE_WINDOW.
kohteessa OpenTK.Platform.Egl.EglWindowInfo.CreateWindowSurface(IntPtr config)
kohteessa OpenTK.Platform.Egl.EglContext..ctor(GraphicsMode mode, EglWindowInfo window, IGraphicsContext sharedContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
kohteessa OpenTK.Platform.Egl.EglAnglePlatformFactory.CreateGLContext(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Boolean directRendering, Int32 major, Int32 minor, GraphicsContextFlags flags)
kohteessa OpenTK.Graphics.GraphicsContext..ctor(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
kohteessa #=zZjYKHpuRzWjvEgHNFxLVfZJfC2u5.#=zqtqcJFA=(Int32 #=zblFwaHQ=, Int32 #=zncvlaVU=, GraphicsContextFlags #=zQzjV$Ck=)
kohteessa #=zjtbDwLqK14NGAiLA3Y3SGUc=.OnHandleCreated(EventArgs #=zOR6kMCg=)
kohteessa #=zze2uL$ZDyfLAxFO$Y0dErTYWdkWS.OnHandleCreated(EventArgs #=zOR6kMCg=)
kohteessa System.Windows.Forms.Control.WmCreate(Message& m)

I can't play osu

I'm at my wits end, please help

osu! version: 20171106.5 (latest)
User avatar
Support Team
997 posts
Offline
Inside the file osu!.pcname.cfg, set the line CompatibilityContext to 0. This is a temporary solution, enabling compatibility mode will cause this issue to reappear.

For a permanent solution, update your Intel graphics drivers. Intel released a fix for this specific issue a while ago.
User avatar
Tempo Trainee
8 posts
Offline
thanks for the quick reply :)

Setting CompatibilityContext to 0 worked, (lag increased from 1ms to 3,5ms but i'm ok with that)

I tried to install the Intel driver that was linked in an Intel forum post about this issue. (I think it's the latest version)
https://communities.intel.com/thread/110921
but when I was installing it I got this error message
https://imgur.com/a/d6Ve6
it roughly translates to:

Driver's compatibility with this computer hasn't been confirmed. Get the proper driver from the manifacturer of this computer.
Installation will be ended.
User avatar
Support Team
997 posts
Offline
Hope this video can help for that:
User avatar
Tempo Trainee
8 posts
Offline
thank you, that worked worked for updating my intel integrated driver and osu doesnt crash anymore but the lag is 3,5ms but there aren't any lag spikes so its playable
User avatar
Support Team
3,418 posts
Offline
hintsala wrote:
thank you, that worked worked for updating my intel integrated driver and osu doesnt crash anymore but the lag is 3,5ms but there aren't any lag spikes so its playable


Try enabling Compatibility mode again. If your drivers are fixed, it shouldn't cause a crash and may return to the ~1ms performance it used to yield.
User avatar
Tempo Trainee
8 posts
Offline
Setting compability context back to 1 caused the openGL problem to reappear, it seems that updating drivers only stopped lag spikes. : (

On a side note osu lazer doesn't crash but it is buggy as hell for me.
Reply 7 posts

Users browsing this forum: None


Jump to: