User avatar
Rhythm Incarnate
1,254 posts
Offline
Image

Have you problem like this? This simple guide should help you.


This problem is very easy to fix, so follow these steps quickly:
  1. As first open Device Manager. Do it by going to Control Panel and then to Device Magager.
  2. When you do this expand list called "Display Adapters".
  3. Now click two times on your Intel device and go to "Driver" tab.
  4. It's the most important part of this guide - click "Roll Back Driver" and restore driver to older one.
  5. Enjoy the game!

If you can't roll back your driver you should change your Intel Driver to this one.

Hope this small guide helped! If you see any typo or something like this don't hesitate to tell me this in post below!
Last edited by Venix on , edited 1 time in total.
User avatar
Support Team
2,992 posts
Offline
Been meaning to write up a more comprehensive guide for a while now, just been too busy. This works well enough for now though I guess.
User avatar
Rhythm Rookie
2 posts
Offline
Venix i cant roll it back it says some things wont work anymore so you cant roll it back what do i gotta do now?
User avatar
Rhythm Incarnate
1,680 posts
Offline
This is not a completed guide since it sometimes doesn't let you roll back your driver version.

Mouad073 wrote:
Venix i cant roll it back it says some things wont work anymore so you cant roll it back what do i gotta do now?


Try installing this Intel driver version.
User avatar
Rhythm Incarnate
1,254 posts
Offline
Nikosbks wrote:
This is not a completed guide since it sometimes doesn't let you roll back your driver version.

Mouad073 wrote:
Venix i cant roll it back it says some things wont work anymore so you cant roll it back what do i gotta do now?


Try installing this Intel driver version.

Sorry for this. Added to guide.
User avatar
Rhythm Rookie
1 posts
Offline
I've had this issue for the past month or so.

Rolling back the driver fixes the problem for the launch straight after installing, but when I run compatibility mode it will return to the same error or not even open properly. I can't run osu properly without compatibility mode in the first place, so having it off isn't much of an option.

The other option of downloading the other intel driver doesn't work for me either, because that driver is apparently incompatible with my laptop.
User avatar
Rhythm Incarnate
1,790 posts
Offline
These have been tackled in these threads:

Otherwise, going to osu!.%username%.cfg and changing Fullscreen to "0" will fix it
Image
User avatar
Rhythm Rookie
2 posts
Offline
Guys I'm using 7th Generation Intel Processor what I need to do?
User avatar
Tempo Trainee
7 posts
Offline
Alright, I did all the steps and rolled-back my driver but it still comes up with "Can't find name of the Intel ICD OpenGL Driver" everytime I startup Osu! Is it because I rolled it back on another account on my PC, or what?
User avatar
Tempo Trainee
8 posts
Offline
Alright, while rolling back the driver makes it possible for me to at least open the game again, its running at less than 1 fps which is beyond unplayable. When I try to go back the first driver I had the ICD OpenGL problem comes back. What do I do? :/

EDIT: 5 minutes later, for some reason, I went ahead and did all the steps again and after a weird crash my game works again. Ok then!

EDIT 2: and now my game crashes every time I try to exit it, nice...
Rhythm Rookie
2 posts
Offline
If none of the things brought up there for me how dfq do I play. Cuz my laptop does not accept that intel version neither let me roll back to an older one. Should I wait another update?
User avatar
Rhythm Rookie
1 posts
Offline
I have the same problem as some other people here. Brand new laptop, can't install any older drivers as my laptop is not compatible with them. Changing the fullscreen option as Kao wrote did sadly not help.
Any help would be appreciated.
User avatar
Rhythm Rookie
3 posts
Offline
I have exactly the same problem
running with intelhd works but the fps are shit
Reply 13 posts

Users browsing this forum: None


Jump to: