1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
Heya, ever since I rebuilt my computer and got this new keyboard I've been having this really odd issue with input "lag". I've done a fair bit of troubleshooting but still haven't quite solved the problem. Bear in mind this is on Mania, I assume the issue also occurs in the other modes but I don't often play them.

This screencap was taken mid gameplay of me playing Evening's Backbeat Maniac. You'll notice that with very little deviation my keypresses "snap" to certain points in time. It doesn't matter if I press my keys late or early, it just snaps forwards to the nearest location. I ruled out in-game settings as well as my graphics card and monitor settings. This includes refresh rates, V and G-Sync, resolutions, frame limiting, and so on.

Figuring it was my new keyboard (Tesoro's Gram XS), I loaded up Spy's BroGamer, plugged in my old keyboard (Gigabyte's Force K7) and low and behold it played fine with negligible snapping. When I plugged back in my new keyboard and tried the same map, I was surprised to find out that the input lag was like with my old keyboard, hardly noticeable.

I went to check to see if the first map would work now because maybe plugging in my old keyboard for a second somehow fixed the problem but nope. Backbeat Maniac still had that weird input lag. After trying to use either of my keyboards in different combinations I came to the conclusion that this problem exists on all of my maps with varying degrees of severity. Some maps are worse than others and for whatever reason, my new keyboard seems to amplify the issue more than my old keyboard.

Putting aside the issue with my keyboard, I decided to see if I could figure out what was causing the problem to be worse on some maps and not others. My immediate thought was that Backbeat Maniac incorporates heavy red and green-tick SV, so I thought maybe that was the issue. I played one of my own un-uploaded beatmaps that has heavy red and green-tick SV, but it played fine.


Maybe my map wasn't dense enough and didn't cause enough stress on the system or maybe the osu! gods happen to hate Evening today so I went to see if the issue would be significant on Evening's Singularity, which by all means is much more intense than Backbeat Maniac.

If the screenshot doesn't speak for itself then allow me to say that the input stagger/lag/snapping was once again, negligible.

Even MAAAAS' hardest difficulty of Two-Torial had no issue.


Now so far in this post, it looks like this issue only happens on Backbeat Maniac but I do know I have this ridiculous note-staggering on other maps as well. I didn't keep track of them as that was yesterday but I'll update if I notice it on any other maps while I play.

----------------------------------------------

This happens when I play certain maps like Evening's Backbeat Maniac:

But doesn't happen on other maps that are of equal, greater, or lesser intensity like Evening's Singularity, MAAAAS' hardest difficulty of TWO-TORIAL, or Spy's BroGamer.






I'm not sure what causes this staggering/snapping of keypresses and why it's only severe on some maps.

----------------------------------------------


I'm at a bit of a loss and would appreciate any help you guys may have. Below I have a list of things I've done to try and fix the problem.

----------------------------------------------

Pay special attention to the hit window at the bottom of the videos. Both of which are recorded at 60 FPS without any dropped frames.

Backbeat Maniac. Showing the excessive input snapping.
Singularity. Showing how most other maps even of a similar caliber play mostly normal.
  1. CPU: i7-6700k
  2. GPU: Asus GTX 1070
  3. Mobo: Gigabyte GA-Z170mx
  4. RAM: Corsair 16gb DDR4-3200
  5. Monitor: Asus ROG PG348Q
  6. Keyboard: Tesoro Gram XS
It's worth noting that when running the game's frame limiter at unlimited, as I normally do, I never dip below 1000 FPS. My monitors refresh rate is overclocked to 100hz, up from the standard 60hz.
This list is growing very long. Just know I've attempted most of the basic stuff, but for the sake of getting rid of this, I'll re-try any and all possible solutions.
  1. Switching keyboards. Had some success here but the problem was still very noticeable.
  2. Switching my keyboard to all the different USB ports. Including USB 2s, 3s, 3.1 with a type c converter, and even the USB hub on my monitor.
  3. Changing the V-Sync and G-Sync options in-game and in Nvidia's Control panel.
  4. Changing my monitors refresh rates from 60-100hz in intervals of 5 both with the control panel and the built-in overclock functionality my monitor has.
  5. Re-downloading and re-installing the beatmaps I had trouble with.
  6. Switching client version to Beta and Cutting Edge.
  7. Running the osu! updater. Also using the repair tool and repairing folder permissions.
  8. Using all the available options of the frame limiter.
  9. Changing resolutions.
  10. Changing to windowed, borderless, letterboxed fullscreen, etc
  11. Using compatibility mode.
  12. Tried the reduce dropped frames option.
  13. Detect performance issues is on.
  14. Disabling F.lux.
  15. Turning on and off the Shaders and softening filter.
  16. Tweaking universal (and map specific) offset and scroll speed.
  17. Using the default skin.
  18. Creating a "new" difficulty of the same map. Notes and SV preserved.
  19. Restarting my game.
  20. Closing all programs but osu!.
  21. Restarting my computer.
  22. Ignoring Beatmap skins and hitsounds
  23. Trying both N-Key and 6-Key Rollover.
  24. Removing the maps audio file.
  25. Changing audio output device.
  1. Evening's Backbeat Maniac
  2. Evening's Fox4-Raize- (All difficulties)
  3. Protastic101's Sonder
  4. Couil's Fuego (All difficulties)
  5. CircusGallops' Piano Beatmap Set (Probably all difficulties, but I can't be bothered to check all of them)
  6. Wonki's Trigger (Probably all difficulties)
See "EDIT"

----------------------------------------------

EDIT:

After searching through my beatmaps trying to find ones that this issue occurs on it seems to be a common trend that this issue only happens on maps with custom hitsounds (and my guess is that it happens on all maps with heavy custom hitsounding). I've tried ticking "Ignore beatmap hitsounds" but with no change. It's also odd to me that my keyboard of all things amplifies an issue that looks to be rooted in custom hitsounds. Any ideas on how to fix this?

EDIT 2:

It seems likely that certain BPMs really disagree with something (my keyboard perhaps?) and causes this issue. For me, 150 BPM has the worst input "snapping". Any ideas on what I can do?
posted
Make sure that the response rate of the keyboard is 1000HZ
posted
Well, I wasn't able to find anywhere or anyway to test my poll and response rates but the manufacturers do advertise the keyboard to be at 1000hz. If you happen to know how I can test my response rate let me know and I'll be glad to do it.

I also still need to figure out why custom hitsounded maps are causing issues though.
posted
If the song files has an archive named "something".osb, try to delete this file and play the map again, otherwise i'll be looking around if i can find some solution

Edit: try this too
https://osu.ppy.sh/community/forums/topics/728163
posted

Jik wrote:

If the song files has an archive named "something".osb, try to delete this file and play the map again, otherwise i'll be looking around if i can find some solution

Edit: try this too
https://osu.ppy.sh/community/forums/topics/728163
I don't see how either of these are related to this issue at all. Your first post was much closer.

If I'm not mistaken this is an issue caused by the BPM of the map being a multiple of your keyboard's report rate, or something similar. I'm also not sure why custom hitsounds would make a difference.
posted

Death wrote:

Jik wrote:

If the song files has an archive named "something".osb, try to delete this file and play the map again, otherwise i'll be looking around if i can find some solution

Edit: try this too
https://osu.ppy.sh/community/forums/topics/728163
I don't see how either of these are related to this issue at all. Your first post was much closer.

If I'm not mistaken this is an issue caused by the BPM of the map being a multiple of your keyboard's refresh rate, or something similar. I'm also not sure why custom hitsounds would make a difference.
Just telling by experience, once it happened to me about the custom hitsounds and deleting .osb file in folder fixed? (idk how osu works tbh)
posted

Death wrote:

If I'm not mistaken this is an issue caused by the BPM of the map being a multiple of your keyboard's report rate, or something similar. I'm also not sure why custom hitsounds would make a difference.
After a fair amount of testing, it seems like the BPM is a likely issue. I was really confused why hitsounds would mean anything. Figured maybe it had to do with how it was loading into memory. Funny coincidence though that all the hitsound maps I tested happened to be problematic at BPMs.

As for what you suggested Jik, .osb files are storyboard files, they don't exist on the majority of problematic beatmaps I have and are unrelated it seems. About the repeat rate of my keyboard, all of that is set up properly.

Back to the point, BPM, specifically 150 BPM seems to cause the issue. Is there a fix?
posted
Sorry for bumping but I've done some searching and I couldn't dig anything up, does anyone know how I can fix this? I may not play for rank but it is still annoying to not have control over my accuracy.
posted
What fps are you playing at?

The snapping is visible when either the fps or your keyboard's poll rate align with the map's bpm.

If you get error bars like that in maps with 150, 160 and 200BPM, your fps seems to be divisible by 2 (with a more pronounced effect if it also is divisible by 160 and if your fps is low; since 160 is not very low, the effect wouldn't ever be be very pronounced for all those BPMs). Overall, it's strange that the effect is very pronounced for all of those BPMs.

From your screenshot, you seem to be playing at 60fps (vsync?). The youtube video you posted of you playing Backbeat Maniac seems more extreme, with like 20fps. If that is the case, increase your fps to make your keypresses be detected more accurately.

Another possible cause (though uncommon) is a very inaccurate audio device's clock timing. See if it still happens if you remove the mp3 file from the beatmap.
posted
The videos were recorded at 60 FPS with no dropped frames. Visually, the game plays exactly as it's meant to. The "stuttering" of the notes is SV, a chaotic visual effect available in osu!Mania.

This picture shows my in-game FPS counter and Geforce experience overlay, taken roughly the same time while playing Backbeat Maniac.


My monitors refresh rate is 100hz so I assume that's why the in-game FPS counter locks to 100 FPS. I don't have any settings on otherwise that would lock the games FPS.

Edit: Here's the FPS graph as well.
posted
Try removing the map's mp3 file so the game doesn't try to sync with your audio device.
posted
Unfortunately no change. I also tried to change my audio output device, both my local default and with the in-game settings.
posted
I waited a bit, tried some more fixes on my own, but I'm still out of luck. I'm hoping someone knows more about this.
posted
Try disabling Windows Defender.
posted
It's already off. I tried turning it on just for the sake of it. No changes.
Please sign in to reply.