1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
Hey guys, I've came across an issue I'd like to discuss. When running osu! on my dedicated NVIDIA 820M GPU (not the best, but it's my laptop), it always caps to 60 FPS (though it fluctuates from 60 - 61). This lock is accompanied by a severe 17ms of input lag.



I am quite sure that vSync (vertical sync) is disabled, as I play on the "unlimited" fps setting.



In the NVIDIA Control Panel, it is also disabled.



Interestingly enough, this only occurs on the fullscreen setting. When toggled off - into windowed mode - I receive maximum fps, with around 4ms of input lag. Nonetheless, I continue to play on my integrated graphics, Intel(R) HD Graphics 5500. Here, I also achieve maximum fps, but the latency bounces from time to time, in addition to the occasional second of freezing when playing a map. I want to try using the NVIDIA GPU, to see if it's possible for improvement.

If need be, I can fetch additional information that may be relevant to this problem.

Have a good one, TR4NQU1L1TY.

EDIT! It seems that I have come across the misconception that the "ms" indicated in osu!'s FPS counter is NOT input lag! Rather, it is one's "frame times."

I quote Death here:

Death wrote:

If you are using the ms values at the bottom right of your screen while playing, this is not input lag. These are your frame times, which is just the inverse of FPS. You can calculate your FPS using these values by doing 1000/ms = fps. 3ms would be 333.333fps and 2ms would be 500fps.
Disregard my mistakes throughout the post! I apologize for any inconveniences. :?
posted
Inside your osu! folder, right click on the osu!.exe, select Properties, and then Compatibility. Once there, check "Disable fullscreen optimizations."

If that does not work, restart you computer, close any programs you have running in the background and disable any overlays you have enabled.

You can also try updating or reinstalling your graphics drivers.
show more
Please sign in to reply.