1. osu!community
  2. osu!
  3. Help
  4. Resolved Issues
Problem Details:

Two days ago I've played osu with no problems, then added some beatmaps as usual. Next day, when I started game, Osu can't find any beatmap with status=r. All beatmaps are still there, but every one of them has "?" mark. When I select global ranking scores, then Osu download it's status and beatmap can be find by status=r. It seems like osu can't access status files, but folder Data exists and has its contents. Local scores and replays are still accessible and can be watched.

I've tried to repair file permissions (osu option, took 7 minutes), I've tried to recheck all beatmaps (F5) before and after doing this, still not work.
I've tried to run as administrator, recheck all beatmaps, does not work too.

Is there a way to repair this? I don't want to go every beatmap to recheck its status, because I have 11771 maps.

osu! version: 20170404.2 (latest)
Windows 10 Creators Update version 1703 build 15063.138
I don't think there's any other option than pressing f5 or moving out your osu!.Db
Alternatively, you could try waiting for a while and see if it fixes itself
Well, refreshing by F5 not works. It refresh only new beatmaps without checking its status.
Moving osu.db out forced game to rebuild all beatmaps list from zero, still without status.

Good that game created some backups. I moved out original osu.db and renamed latest backup. Game warned me about corrupted database (from about one month ago, osu warned me everytime when I start the game about this) and rebuild it from scratch. Osu never crashed and game process was never killed by force, so I don't know why.

After this, about 8000 beatmaps has ranking statuses, needed to do F5, and still need to check about 4000 one by one.

I think that we can't do nothing better.
Please sign in to reply.