[resolved] Windows 10 Mouse Lag

posted
Total Posts
8
Topic Starter
Killerbyte
Problem Details: So I decided to upgrade from windows 7 to windows 10 and I've noticed a huge hinderance appearing while playing Osu!, mouse lag, i tried everything including using the MarkC mouse acceleration fixes and turning on and off raw input and playing full screen although i want to play on windowed and it still lags.
I am using a Logitech M100 mouse (I am a mouse + keyboard player and yes i know it's a bad mouse.) and Windows 10 Pro.


Video or screenshot showing the problem: None.


osu! version: 20150812.11 (latest)

Help would be really appreciated!
-Chitose-
Hi K1ll3rbyt3!

Did you tried to update your VGA driver? maybe the problem is in your graphic card who didn't support windows 10.

I have the same problem to when I try to upgrade to win 10 but after updating my graphic card it's feel normal again :D
Topic Starter
Killerbyte
Hey Chitose!

Thanks for the reply, but I've got a question: How do i do that? Because all of the beta drivers on the AMD website are at maximum for Windows 8.1 as I'm seeing it right now.

edit: I'm using a AMD R9 295x2 as my graphic card, I've disabled CrossfireX for Osu! to make sure it doesen't lag on input, but it still does.
-Chitose-
I'm using AMD to and now it's support windows 10

You can go here and get the installer
Topic Starter
Killerbyte
Awesome! This works, thanks! But one more thing, how do i reduce the input lag in windowed mode? On fullscreen it's perfect but what if i want to play on windowed mode because my resolution is too big for me?
Arcane
Thats one monster of a GPU you got there !!! <33 You can do this.

Follow these steps in windows:


  • - System
    - advanced system settings ( left side of the window )
    - Settings (Tab: Performance)
    -''adjust settings to increase performance''


i'd recommend you to turn one thing on there and that is something called : use templates instead of icons. or something XDD this will enable that when you go to : for example, your pictures that it will show a mini version of your picture and not the windows picture icon ^^

This should fix the input lag ALOT!
Topic Starter
Killerbyte
I noticed a slight improvement but not a dramatic one, but whatever, I'll get used to it :D

Thanks!
VeilStar
You'll always have more input lag on windowed mode on windows 10, due to dwm. Play on fullscreen or check out the Letterboxing option in the beta & cutting edge release streams.

Marking as resolved.
Please sign in to reply.

New reply