forum

Full guide of how to get the lowest input lag/ms and extra help

posted
Total Posts
5
Topic Starter
sebasthefast
So, i am a laptop player, and my average ms ingame were 5ms, now they are 0.3 - 0.5 ms (with apps opened) while recording i get 0.6 - 0.7, im making this post, because i looked everywhere and i found other posts, but they werent really helpful, because they would say the same thing, or either it wouldnt work.
Just reminding, i speak spanish so my grammar wont be perfect


Lets start with something very important, LAPTOP players gotta pay attention to this:
So as a laptop player, ive experienced tons of problems, most of them being: Not being able to use my nvidia graphic card to run osu, also when i got to use my nvidia graphic card in the game, the ms would be extremely high, Couldnt find intelICD OpenGL driver (something like that) and even more, today i am gonna help you with this, if you are getting the same problems in a pc it will also help you

(you can skip this if you dont have any of the problems i listed above)

First: I cant open osu! with my nvidia graphic card, this can be fixed in multiple ways, first way is by right clicking in your desktop, and going into nvidia control panel

then after that, if you check the left, you will see something called control 3D setting or something like that, click on it, go to program settings, you will see something like this

click where it says "add" (sorry if mine is in spanish) and look for your osu! folder, then click in osu.exe, then you will click on "select the graphic processor for this program, and choose "integrated graphics"
after that, you should be able to run osu with your nvidia graphic card, how?, you can right click in osu and where it says "run with graphics processor", choose High perfomance NVIDIA processor.

If this didnt work, there is another solve for it; right click into osu, then go to "properties", then go to compatibility, and mark "disable fullscreen optimizations" ON


If this didnt solve it, please let me know it


Second problem: High ms in-game while using nvidia graphic card, but when using integrated graphics the ms are low

There is a way to fix this, go back to NVIDIA CONTROL PANEL, then go to Control 3D Settings, then Program Setting, click "add" then find and select osu!, (if you are having troubles, or you dont know how, check up in the images i sent, maybe like that its easier for you), after you selected osu scroll down in "specify value of program setting" or something like that, then scroll down and look for the option "Low latency mode", turn that on ULTRA (REMEMBER TO DO IT IN THE GRAPHIC PROCESSOR UR GONNA USE, IF YOU ARE GONNA RUN IT WITH NVIDIA GRAPHICS, THEN CHANGE THE DEFAULT TO NVIDIA, PUT ON ULTA LOW LATENCY MODE, SAVE AND THEN GO BACK TO DEFAULT INTEL GRAPHICS (so you can run osu with nvidia graphics without it crashing + low input lag)



Now what you have been waiting for, and probably the reason of why you are here, how to low my ms?



Lets start by doing the basic things, (in-game settings) to make your ms go lower, if you have already searched online for how to low your ms, you probably saw most of the things here before, check it again still, maybe theres something i mention that you havent did, if you already did everything here, just go to the next part, because thats where i add new solutions

First: Go into your osu! settings, go into graphics, and in FPS LIMIT, change it to UNLIMITED, this will help alot, also DONT TURN ON REDUCE DROPPED FRAMES, it will lead to stuttering, and in screen resolution, use fullscreen, it is the MOST IMPORTANT PART, because its the most helpful one, fullscreen to windowed mode is alot difference


in detail settings, turn everything off but the animated sliders


THIS ONE IS ALSO VERY HELPFUL, THE BACKGROUND, when i used to play with the background at 0%, it would give me more input lag, so put it on 100%, make it totally dark, this will help


Another tip is to turn off background video, that lags alot and close all the other apps in use, you can go to the bottom right of your screen and click an arrow to show the apps in use, right click on them and exit all of them (unless you need to keep one opened)


After we are done with the basics, lets skip straight to extra settings to low your input lag

FIRST: (skip if you dont use a laptop) LOWING MS FROM 3 TO 1.1, if nothing above in the laptop part helped you, this will help you alot and it wont at the same time, so most of the laptops have this problem, i think its called optimus (made to save battery) in my case its useless because i always have my laptop connected, but maybe its helpful for other people, anyways, this makes your osu be limited, i dont really know how to explain it because i havent searched about it alot, only a bit, enough to explain what happens and a solution, this is sad to say but you will need an external monitor, when i got an external monitor, my ms boosted to 1.1 (alot less input lag) no matter what monitor, even if its 60hz just get an external monitor, connect it trought hdmi, and remember to set it as ONLY USE THE MONITOR SCREEN, if you do duplicate or other option, it wont help, and will only lag even more, but if you do it, it will help alot, also using a monitor with let you run osu with nvidia graphics, or well, thats how it was for me, without needing to change the setting to default integrated graphics (read the first part of the topic if you dont know what i mean) if you cant afford a monitor, or you dont have one, sorry, and i wish the first part of this topic helped you.

SECOND: (for pc people, or just peolpe with monitor)

Go into your desktop, right click and get into NVIDIA CONTROL PANEL, go into control 3D SETTTINGS, then go to PROGRAM CONFIGURATION, click where it says "ADD" and find your osu!
then go to " 3. especify the value of the program settings" or something like that (mine is in spanish lol) then SCROLL DOWN until you see the options: Low latency mode, Control energy mode, Linked optimization (or something like that, and Vertical sync, starting with low latency mode, change it to "ULTRA", in control energy mode, choose "Prefeer max pefomance", in linked optimization ACTIVATE IT, and in vertical sync, make it DISABLED



NEXT STEP AND A VERY IMPORTANT ONE

If you scroll up A BIT, you will see 2 settings, saying "MAX FPS FREQUENCY", DISABLE BOTH OF THEM, (DO NOT CAP TO 1000)


If you click on it, you can see it shows it automatically limits it to 58 FPS, IT DOESNT, it actually just makes it UNLIMITED, so dont put it on 1000, because if you do, it will cap to 1000, if you disable it, it will go over 1000, (2000+ fps 3000+ fps)





Thats it, i really wish it helped you!

jkzu123
this is cool but mention that its mostly for nvidia gpu users
[LS]PositoniX
my linux distro has been giving me some pretty big latency issues so ill definitely give this a try later today, thanks for the guide!
Jundullah
This is cool and all but it would be more understandable if you explain it in English tho
ICanNotDoSlider

Jundullah wrote:

This is cool and all but it would be more understandable if you explain it in English tho
Everything is explained in English, just not images. Most, if not all of the steps are pretty straightforward.
Please sign in to reply.

New reply