User avatar
Whistle Blower
27 posts
Offline
Problem Details:
(1) osu keeps dropping frames no matter what settings or GPU I use. every single build including lazer. If a dropped frame occurs at the same time as a hit object it will be a miss.
(2) my fps has been steadily dropping over the almost 2 years I've owned this laptop. it was easily in the 900-1500 fps range at first. over time it has dropped to 500, then 300 and now it can't even reach 300. this isn't really a big deal but its really difficult to attempt livestreaming due to the low framerates.

specs:
CPU: Intel i7-6700HQ
GPU: Intel HD graphics 530(integrated), Nvidia GTX 960M(discrete)

Video or screenshot showing the problem:
(1) https://youtu.be/3_KXjcpI_Z8
(2) when I first got the laptop: http://imgur.com/a/Crdz0
nowadays: http://imgur.com/a/L7Ygh

osu! version: stable(latest)b20170503.4, stable(fallback)b20160403.6, beta b20170503.3beta, CuttingEdge b20170521cuttingedge, osu!lazer 2017.524.0
User avatar
Rhythm Incarnate
1,902 posts
Offline
Are you on Windows 10? If so, try removing the Xbox app completely from your PC. Here's a guide on how to do it.
User avatar
Whistle Blower
27 posts
Offline
Windows 8.1 pro
User avatar
Rhythm Incarnate
1,902 posts
Offline
If I'm correct, windows 8.1 have also the Xbox application installed. The way to uninstall it should be the same as windows 10.
User avatar
Whistle Blower
27 posts
Offline
Hmm this problem only started recently so I don't see how it would help but I'll try tomorrow morning.
User avatar
Rhythm Incarnate
1,902 posts
Offline
Disabling/uninstalling completely this app usually increases frame rate and improves the performance. You could give it a try for the heck of it.
User avatar
Rhythm Rookie
1 posts
Offline
Do you have this problem with any other games? It would help a lot to know.
User avatar
Whistle Blower
27 posts
Offline
Only osu has this horrible stuttering
User avatar
Whistle Blower
27 posts
Offline
nope can't find the xbox app. Might have already uninstalled it long ago
User avatar
Rhythm Incarnate
1,902 posts
Offline
Alright, read the following.

Help Center wrote:

I'm experiencing lag spikes or stuttering during play!


Lag can be caused by a variety of things. Here are some common causes that may help if you're experiencing lag:
  • Background processes, anti-virus software, etc.. Try turning them off while you are playing osu!.
  • Viruses, spyware, trojans. If you don't have any anti-virus software at all, and your operating system and osu!'s performance seem choppy, you should try scanning your system with an anti-virus scanner.
  • Your computer may be in need an upgrade - some really old computers utilizing old Intel Integrated graphics (such as GMA) may not cut it for osu!.
  • Your drivers may not be up-to-date. One of the easiest ways of getting somewhat better performance is bringing your drivers up-to-date, especially your graphics drivers.
  • Try turning off some visual settings from the options menu. If your problem is not fixed by any of these, try the advanced troubleshooting methods below:

The game's performance is choppy or stutters frequently.
This might simply be caused by using a system with very outdated hardware. Aside from getting a more powerful system and checking the other sections in this article there is not much you can do in this case.

Occasional momentary freezeups.
Check if another background process is monopolizing your system for brief moments. This could be caused by other games, web browsers, or server apps (including file sharing/torrents). Close all other background programs and tray icons and see if the problem persists.

FPS drops sharply after an update.
This is known to happen to some users after some updates. Restart your PC to fix it in 99% of cases.
User avatar
Whistle Blower
27 posts
Offline
Restarted laptop today. Stuttering is now a less impossible once every 30sec or so. Osu is actually playable. Managed to fc an almost no weight pp play.
I tried uninstalling graphics drivers and playing on the compatibility vga driver. Stuttering present. DDU and latest drivers. Still there. Restart, nothing running but osu and task man. Still there
User avatar
Rhythm Incarnate
616 posts
Offline
Are you sure Windows isn't installing an additional video driver for your GeForce card?

You can try disabling on-board graphic in the BIOS/UEFI but I doubt that's the problem.

You may want to download HWMonitor and check the temperatures listed.
User avatar
Whistle Blower
27 posts
Offline
With Nvidia Optimus the gpu must pipe every frame through the integrated graphics on a hardware level. No BIOS trickery to do there. I recently repasted my laptop so thermals aren't the issue
User avatar
Whistle Blower
27 posts
Offline
R8nD0m wrote:
I recently repasted my laptop so thermals aren't the issue

In fact until yesterday I had to play overwatch at low preset 50% resolution scale or I'd get 20fps. That problem went away with new paste. Osu stuttering didn't
User avatar
Whistle Blower
27 posts
Offline
http://imgur.com/a/5XPR0
disabled avg. turned off qbittorrent. turned off shadowplay
stuttering once every few minutes. almost as if the problem isn't there. of course almost isn't good enough for me when I'm using a high spec laptop
problem is those used to be active and I had no issues with osu.
if its the update then I hope they release a new stable build soon
Locked 35 posts jump | 1, 2, 3  next

Users browsing this forum: None


Jump to: