User avatar
Rhythm Rookie
4 posts
Offline
Problem Details:Game Lags massively when moving the mouse.

System Specs:
  • CPU - AMD Ryzen 5 1600 @ 3.9Ghz
  • GPU - nVidia GTX 1060 6GB
  • OS - Windows 10 Pro
  • RAM - 16GB DDR4-2933Mhz

During the lag I show no high CPU usage, I've closed out all other background programs, memory usage is low, temps all look great. I've uninstalled and reinstalled osu! entirely and the problem persists regardless of the build I use (even the Fallback build exhibits the issue). This did not happen at all until either a day or two ago when osu! popped a message up saying "osu! has encountered an error" and ever since then there has been a huge issue. No other games on my machine are exhibiting this issue.

The steps I have already taken:
  • Reinstalling osu!
  • Trying the fallback build
  • Rebooting the machine
  • Checking temperatures, cpu usage, etc.

I'm really at a loss here, can someone make any other suggestions? I am currently working on ensuring my Video Card drivers are up to date, will post if that solves the issue.

Video or screenshot showing the problem: https://youtu.be/Ol5M0LqUeC0

osu! version: 20171106.5 (latest)
User avatar
Rhythm Rookie
4 posts
Offline
Okay, I seem to have jumped the gun on posting this. I solved the issue, I have a CORSAIR M65 Pro gaming mouse and the default polling rate for that mouse is 1000Hz; if I lower that to 125Hz the lag disappears, but I didn't have to do this before. Is there anyone who has found a workaround? I don't mind having to change it when I'm in osu! but it physically hurts everywhere else in Windows (basically anywhere that doesn't use raw input of the mouse). Having to flip a switch every time I launch and close the game is quite the annoyance.
User avatar
Rhythm Incarnate
616 posts
Offline
What motherboard and UEFI version are you running with Ryzen? I'm guessing you need to install the chipset driver for the AM4 platform, which includes drivers for the USB controller. http://www.amd.com/en-us/products/chipsets/am4

Attempt the solutions below first. They are bandaid fixes.

Try any polling rate below 1000Hz.

Also try using the Higher Performance power option in Windows while using 1000hz and below, test for a difference. Never reinstall osu!, that won't fix it since the issue arose with a new input device.

Image

Disabling "Enhance pointer precision" will disable mouse acceleration within the OS.

Image
User avatar
Rhythm Rookie
4 posts
Offline
Thanks for the quick response; my motherboard is a Gigabyte Gaming K5 and I'm using the newest F5a BIOS revision. I have used this mouse pretty much since purchasing this machine and until a few days ago it worked beautifully with osu! at the 1000Hz polling rate (we're talking 10-11 months straight of no issues at all across hardware changes including motherboard, CPU, RAM and Video Card changes). I tried 125, 250, 500 Hz and the only one that doesn't exhibit the issue is 125Hz but it feels very clunky for me. I checked my power options and attempted disabling "Enhance Pointer Precision" and the effect was not improved.

I went ahead and downloaded those Chipset drivers as a last resort as mentioned. I noticed an improvement. I think I've pinpointed the issue though. I took my custom lighting settings from CORSAIR software and wrote them to the device and stopped the CORSAIR Utility Engine and the issue mostly disappears. It seems that maybe CORSAIR updated the program or something and now it doesn't play nice with osu!

Thanks a million, osu! is playable again!
User avatar
Rhythm Rookie
4 posts
Offline
EmulateSF64 wrote:
Thanks for the quick response; my motherboard is a Gigabyte Gaming K5 and I'm using the newest F5a BIOS revision. I have used this mouse pretty much since purchasing this machine and until a few days ago it worked beautifully with osu! at the 1000Hz polling rate (we're talking 10-11 months straight of no issues at all across hardware changes including motherboard, CPU, RAM and Video Card changes). I tried 125, 250, 500 Hz and the only one that doesn't exhibit the issue is 125Hz but it feels very clunky for me. I checked my power options and attempted disabling "Enhance Pointer Precision" and the effect was not improved.

I went ahead and downloaded those Chipset drivers as a last resort as mentioned. I noticed an improvement. I think I've pinpointed the issue though. I took my custom lighting settings from CORSAIR software and wrote them to the device and stopped the CORSAIR Utility Engine and the issue mostly disappears. It seems that maybe CORSAIR updated the program or something and now it doesn't play nice with osu!

Thanks a million, osu! is playable again!


Set my polling rate to 500Hz which is high enough I don't notice any difference and the issue is COMPLETELY gone. Is there a way to close a thread? Thanks!
Reply 5 posts

Users browsing this forum: None


Jump to: