User avatar
Cymbal Sounder
35 posts
Offline
Problem Details:
my songs folder is about 96.2GB and there has 43434 .osu files in my songs folder(pic1 [and sorry my OS is write in chinese.])..so..my osu should tell me that I have 43434 beatmaps available..(pic2 I changed my version after I found this problem.)and I think I've lost about 400 beatmaps..(tell me if I'm wrong about the .osu files = beatmaps available in osu).
well...I didn't notice before I take a look at my collections and..I don't know how to repair it.(I forgot to backup my computer files..so I can't recover everything.)
If my Osu can't detect those beatmaps back. How can I know which map I've lost?

Video or screenshot showing the problem:
Image

Image

osu! version: 20170222.3 (latest) <--- I've tried to use fallback and see this problem fixed or not..but it's not working.
User avatar
Rhythm Incarnate
1,789 posts
Offline
Press f5 to do a force refresh of the database
Take note this will take very long

You can backup your osu!.db first before doing so (if you ever give up waiting)
User avatar
Cymbal Sounder
35 posts
Offline
Kao wrote:
Press f5 to do a force refresh of the database
Take note this will take very long

You can backup your osu!.db first before doing so (if you ever give up waiting)


I did Press F5 and still telling me that I have 43034 beatmaps available.(Yep...it takes over 5 mins to refresh :o .)
User avatar
Rhythm Incarnate
1,789 posts
Offline
Move the file osu!.db out of osu!
Image

If that still didn't solve it, try fixing permissions then do a scan again
You can go to settings and click on the Repair folder permissions option like so,
Image

You can also manually set the permissions yourself but it's gonna take some steps
  1. Navigate through the root folder of osu! and open up the properties
    1. Select then Alt + Enter or
    2. Right click > Properties
  2. Go to Security tab and click on Advanced
  3. Go to Owner tab and click on "Edit..."
  4. Choose your account and click on "Replace owner on..."
  5. Click on OK and wait for it to apply.
collapsed text
Image


After that
  1. Navigate through the root folder of osu! again and open up the properties
    1. Select then Alt + Enter or
    2. Right click > Properties
  2. Go to Security tab and click on Advanced
  3. Go to Permissions tab then "Change Permissions..."
  4. Click on "Add..." and enter your Username there
  5. Click on OK and select on Allow all (at the top)
  6. Click on OK and wait for it to apply.
collapsed text
Image
Reply 4 posts

Users browsing this forum: None


Jump to: