1. osu! forums
  2. Beatmaps
  3. Beatmap Management
  4. Archive
hi cuties.

As many of you know, there is currently an update bug on beatmaps which deletes every elements from beatmaps and most do not know how to handle it. I am making this thread as a reminder, this is simply some kind of visual bug which can be ignored and do not stop the map from hitting the ranked state.

How to replicate the bug:
(The links below every points are short videos showing the steps to replicate the bug)

  1. Download a beatmap. I am choosing this one as an example.
  2. I just downloaded the beatmap and you can see in 'Play' that the map is not asking for an update:
  3. Once you go in 'Edit' with the same map, everything seems to work out fine:
  4. Now get in the editor with one of these difficulties and go back to the selection of beatmaps. The whole mapset will ask for an update. Take into consideration I did not change anything in the beatmap!:
  5. Go back in 'Play' with the same beatmap. The update prompt won't be showing anymore:

If there are more ways to replicate this bug or you have any questions, feel free to join the conversation here.
Happy mapping/modding!
I reported it in 'Help' forum before t/681428

Going back to the main page of osu client and re-entering into 'Play' page is just a temporary remedy. It does not solve the problem's root at all. (well it should not be solved by the general anyway)

The mapper tried completely removing the .osu and re-adding it, apparently it did not work. I guess the system has already recognized the submitted info of the mapset, so anything related to that specific problematic difficulty cannot be solved unless the bug is fixed.

Maybe in other ways could the bug be replicated permanently, I am still figuring them out :D
Please sign in to reply.