forum

[Archived] Game capped at 60fps when Fullscreen

posted
Total Posts
13
Topic Starter
Yadang
Hi, whenever I put the game on fullscreen, the game stays at 60 fps, constant 5ms input lag. When I go borderless, input lag will drop to like 1.5ms, but since im running win10, I feel like the cursor delay is much higher because of playing on borderless, and it is literally unplayable for me. (No it really doesn't feel like 1.5ms). I tried various things:

Updating graphic drivers.
Disabling Game DVR.
Running on latest. (Somehow I don't get this problem on fallback, but fallback gives input lag to me aswell.)
Every setting in the settings menu.
FixMyPen
Nvidia settings, disabling vsync.
And some more..

My specs : i5 7300HQ, 8Gbs DDR4 memory, GTX 1050 4Gb.

Something is capping my game when fullscreen and I have no idea why, it feels like Vsync, I've disabled it everywhere I could but nothing happened.
I'm very used to lower resolution, so i want to play fullscreen letterbox. Fallback doesn't have letterbox.

I'd be happy with any response that can solve this issue.
Kondou-Shinichi
really? you SURE the fps limiter is not set to vsync?
Emerold
yep, my guess would be the same. Check the ingame fps limiter (you can just even press [i think] f7 for that), considering that everything outside of osu is not capping your game.
Topic Starter
Yadang
No i'm 100% sure, constant 5ms, Unlimited(Gameplay), when I go borderless, the input lag disapears, but then there is win10 that makes my cursor delayed, it's not as bad as fullscreen, but unplayable.

I'm clueless, that's why I haven't played osu properly for last month...
Topic Starter
Yadang
Oh now I got it! It's not stuck at 5ms, it's not stuck at 60fps, I actually have much lower FPS in fullscreen, like alot less, the game is literally lagging. I have no idea what to do really.
Topic Starter
Yadang
I just switched to integrated graphics and the game runs good on fullscreen. Guess I'll play on integrated then.

Intergrated > GTX 1050 4GB
Death
Integrated graphics outperforming your graphics card is a very clear indicator that you missed a setting in your NVIDIA Control Panel or Geforce Experience, or you have a driver problem.

In Geforce Experience, click on the gear icon in the top right to open the settings and disable "In-game overlay."

In NVIDIA Control Panel, double check you have the lowest pre-rendered frames, triple buffering is disabled, vsync is disabled, gsync (if applicable) is disabled, and your power settings are on Optimal Power or Prefer maximum performance.

NVIDIA also recently released a driver update for most of their graphics cards. If none of the above works, go to this website, search for your graphics card, and download the second or third driver on the list that populates, depending on which driver version you have currently.
Venzire
Just select the osu!.exe and force it to use the discrete Nvidia GPU. If none of this works then it's another issue, perhaps playing while your laptop is unplugged could be causing it to run in a power-saving state. What does "and some more..." mean?

"2. Select the preferred graphics processor for this program:"

Make sure v-sync and triple buffering is disabled!

Topic Starter
Yadang
In-game overlay disabled, triple buffering and vsync disabled on Nvidia settings, yes I tried to force Nvidia card to run osu. This happens only in osu!, other games are running as they should. Also this only happens when fullscreen is turned on.
Also updated drivers trying to fix this issue before.
Sabvo
i have this same case and same specs. .-.
Death

Sabvo wrote:

i have this same case and same specs. .-.
Try the solutions in this thread.

One that was not listed, but should have been, is disabling Fullscreen Optimizations through windows.

If you are still having issues make a new thread and provide as much detail as possible (computer specs, solutions tired, etc).
Mouse Pad
the same thing is happening to me and i dont know what to do
Catzzye
Literally same specs and have exact same problem. Rarely I get it to work and it goes to 240FPS in an instant. But when I woke up today and opened osu! again, it was on 60FPS again. Like all those hours spent figuring it out went to waste. :/ I did all the same steps as you.
Please sign in to reply.

New reply