1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
Problem Details: Hi, I have played osu! for about 1.5 years and I always play with high sensitivity mouse (800 mouse DPI with x4.5 sensitivity in osu!) and i feel comfortable with it. But recently, my cursor usually freeze while playing osu!, i thought it was power supply problem (since i have 1 external keyboard, 1 external mouse and 1 earphone plug into my laptop) but then i realized that only if i play osu! it will be like that, nothing happen with other software, this problem got worse after i used avira anti virus to delete some malware, now the input detect rate usually drop to 60 - 100 (Normally is >120) and it's literally unplayable
here is a video about it, i tried to record my cursor in my main screen but it didn't show. And believe me that the problem isn't cause by my recording software. hope i can get a solution soon to continue playing osu! :)



Video or screenshot showing the problem:
https://youtu.be/CcwC-cIoEpw


osu! version: 20161101.2 (latest)
posted
Controlpanel>mouse>mouse settings>Then uncheck that button:
posted
This problem couldn't have been caused by Windows Acceleration

Try disabling your antivirus instead.
If you have Skype, Raptr, OBS, Steam, try disabling those too and see if they help
posted
Try lowering your FPS rate by pressing F7.
posted
Sorry for late reply. I'll clear up something here because when i opened this thread, it was 11.00 pm in my place xd
- my full mouse setting : windows, 6/11sensitivity, mouse accel off
osu!, raw input on, sensitivity x4.56
- screen resolution: windows: 1370x768, osu!:800x600(full screen)
- my laptop spec : intel pentinum 2x2.26 GHz processors with integrated graphic, 2GB of RAM running windows 7
- i set pretty much everything in osu! to minimal, including set the fps to Vsycn
- when i recorded this l, only osu! and my recording software (action) is active, other software you guy said is disable or i didn't even have them. Except the anti virus which i will try today.
So i hope these would help you to figure it out, thanks for your help :)
posted
I'm thinking there is a shortage of RAM. Usually when playing games and the game itself doesn't lag (Because of High Priority) but the mouse lags, it is usually caused by a shortage of RAM.

Go to task manager and set osu! To run in normal priority
Then disable your antivirus (make sure it isn't in the process)
posted

Kao wrote:

I'm thinking there is a shortage of RAM. Usually when playing games and the game itself doesn't lag (Because of High Priority) but the mouse lags, it is usually caused by a shortage of RAM.

Go to task manager and set osu! To run in normal priority
Then disable your antivirus (make sure it isn't in the process)
I tried what you said and it significantly reduce my mouse glitch :). Tho setting osu! prioritize to normal sometimes make osu! freeze right in the middle of the play so i set it from high -> above normal :(. and there are some glitch here and there but yeah, i can bear that, thanks for your help :)
posted
We could still go further and stop running processes and services that could be taking RAM.
Open task manager and go to processes tab, check "show all processes" then go to columns>private memory and check that.
Sort processes by private memory and take a screenshot.
posted

Kao wrote:

We could still go further and stop running processes and services that could be taking RAM.
Open task manager and go to processes tab, check "show all processes" then go to columns>private memory and check that.
Sort processes by private memory and take a screenshot.
Well, sadly I shut down my laptop and now i have to wait till weekend to use it again, sorry about that
posted
It's okay, just update us soon.
If you see "svchost.exe" at the top, go to the columns and enable "Handles"
If you see svchost.exe having > 800 in Handle, you might be having a handle leak.

To fix this do the following steps:
  1. Right click svchost.exe (the one at top, since there's multiple svchost.exe)
  2. Then click on "Go to services"
    You'll see number if items listed and highlighted.
  3. Find among these items "wuaserv"
  4. Right click > properties then choose "Disabled" on the drop down menu.


After that, you'll notice private memory will drop.
Note:
  1. wuaserv service is used by Windows Update, and won't run updates automatically if you disable this service.
    If you don't use it, just ignore this.
  2. More information here https://blogs.technet.microsoft.com/yon ... -problems/

Good luck!
posted
Another thing you can do is to upgrade your RAM to 4GB. It will have a very significant performance boost from 2GB. 2X2GB RAM kit is rather cheap these days. It will also allow you to run much more programs at once and will probably accommodate AV + osu! just fine.
Please sign in to reply.