[Archived] Can't run osu! properly no matter what

posted
Total Posts
9
Topic Starter
Amlink
Problem Details:
Ok so I recently bought an MSI GE62 6QD Apache Pro with a Nvidia GTX960M graphics card windows 10 (ew i know I hate it as well) I run osu in full screen (ctb requires extreme amounts of frames since its movement based. I know its dumb but honestly the damn mini game mode is the most pc demanding mode you can play in osu *face palm*) yet skype and other things pop up over it rendering fullscreen useless no matter what build of osu I use. It also shows me running at manageable ms in game ranging from .80ms to around 1.2 to around 2ms yet runs like 20ms I slide everywhere across the screen with no control this also effects the other three game modes delaying my key presses on my built in keyboard 1 mech and 2 rubber dome externals I have even reiinstalled my mech keyboard drivers as well as put my pc in every performance mode at different times.... I checked forum posts dating 3 years back but nothing helps.
I've tried setting osu to specifically run in high performance using my graphics card as well as using the intel i7 just for kicks and giggles as well. I have also ran it in compatibility mode, reduce dropped frames, open gl and direct x, every frame lock avalible on every build, as well as reinstalling osu! itself.... Nothing works can somebody plz tell me what I can do this thing is a beast it runs pc demanding games like a good rig desktop as it should for the price and I'd be really sad to find out this isn't compatible with osu! or something since it costed about 1,400$ -_-


Video or screenshot showing the problem:



osu! version: 20161020cuttingedge
Kao
Are you using full screen mode? If not, switch to full screen mode.
Try changing resolution to native or a lower one
Make sure your directx drivers are updated too

Make sure osu! Has enough RAM to run properly
And make sure Vsync is off both in osu! And your GPU control panel.
Topic Starter
Amlink

Kao wrote:

Are you using full screen mode? If not, switch to full screen mode.
Try changing resolution to native or a lower one
Make sure your directx drivers are updated too

Make sure osu! Has enough RAM to run properly
And make sure Vsync is off both in osu! And your GPU control panel.
can you please just read the whole thing before posting. I don't want to seem like a prick but omg dude really the first line you wrote are you serious
Kdefs
I heard nvidia optimus is really un-optimized for osu, but I cant confirm, peppy would know about this.
Kao

Amlink wrote:

Kao wrote:

Are you using full screen mode? If not, switch to full screen mode.
Try changing resolution to native or a lower one
Make sure your directx drivers are updated too

Make sure osu! Has enough RAM to run properly
And make sure Vsync is off both in osu! And your GPU control panel.
can you please just read the whole thing before posting. I don't want to seem like a prick but omg dude really the first line you wrote are you serious
Yes sorry if I sometimes have mistakes on what I say, I often make a list that the user can do in hope one of them would be able to help
Just by chance, you wouldn't have multiple monitors set up?
Topic Starter
Amlink
no i dont :d
Kao
Open your task manager to see if there's any demanding program that uses your CPU or RAM such as recording software or any video player

Though could you elaborate more on how programs pop-up in front of osu?
Does osu! Minimize whenever these programs pop-up, or do they appear while playing?
What specific programs show in front of osu?
If you are running on a lower resolution than your monitor, toggle letterboxing to eliminate Windows from going in front
Topic Starter
Amlink

Kao wrote:

Open your task manager to see if there's any demanding program that uses your CPU or RAM such as recording software or any video player

Though could you elaborate more on how programs pop-up in front of osu?
Does osu! Minimize whenever these programs pop-up, or do they appear while playing?
What specific programs show in front of osu?
If you are running on a lower resolution than your monitor, toggle letterboxing to eliminate Windows from going in front
single monitor (the laptop one)

things pop up over osu but not alt tabbing me or minimizing it a skype message ribbons or online ribbons would appear over osu and basically f*ck it up even more causing way more input delay until restart as well as it running poorly to begin with

any program anything from pc notifications to apps to steam everything fullscreen is flat out broken for some reason

ive toggled resolution as well as well as used every available res built in to osu and a few custom ones

ive even turned off every program and just ran osu after a fresh restart same problems
Kao
Well then that's weird, if things show in front of osu, it should minimize and switch to that window, if it's in full screen mode.
Could you take a screenshot of your windows task manager? Go to processes and sort by private memory
If it isn't an external program that's causing this, it could be some display enhancement your laptop has

Try running without compatibility mode of its checked.
t/353941
Please sign in to reply.

New reply