1. osu! forums
  2. osu!
  3. Help
  4. Confirmed Issues
posted
Yeah, you are probably right, but since this is like my nineth time trying to contact the devs over the last year, which have all remained unanswered, I'll risk displeasing the staff members, if I can bring some attention to this matter.

Still thank you though, I haven't thought about it that way.
posted

Fizzn wrote:

Btw, I don't think you are supposed to add that confirmed thing yourself.
Let staff members decide. just telling
I've added the confirmed tag. I could reproduce that too.
posted

Shiro wrote:

Fizzn wrote:

Btw, I don't think you are supposed to add that confirmed thing yourself.
Let staff members decide. just telling
I've added the confirmed tag. I could reproduce that too.
Thank you very much !

I'm so glad that I'm finally making progress.
posted
This is normal behaviour since you've set your screen area to only a single monitor in your tablet software. Set your screen area to be all monitors in your tablet software if you want to use 'map absolute raw input' with multiple monitors.
posted
That is not true.

Your method doesn't work because of three reasons.

1. When clicking near the edge of the game, it will automatically tab out.

2. Although I can now access the whole game, my tablet area consists of only the upper half of my total area.

That means that I'm moving approximately thrice as fast up and down than I'm doing horizontally.


3. My cursor is being inconsistently mirrored to my second monitor.


I'm sorry if the following sounds harsh, but please refrain from proposing solutions without trying them yourself at least once.

Even more so as you are a member of the Support Team.
posted
I wasn't exactly suggesting a solution but rather explaining the behvaiour (and also have also dealt with this before). I strongly doubt this can be 'fixed' as a mismatch of settings both inside and outside of osu!, hence what I said in my previous post. It works perfectly fine if you set it up as in the following screenshot.

posted
I'm sorry for not answering for a while.

Using your options I was able to completely solve my problem, thank you so much !

I'm sorry for neglecting your solution earlier, that was imappropriate.

Still, is this the logical behaviour of those features (raw input, the mapping thing), or is it really unintentional ?


Best, staticV3
posted
No worries. I wasn't being very detailed with my initial post either.

To answer your question though, well, yes. It's not intended behavior, but it mechanically (/ logically) makes sense why this happens.

To further elaborate, both osu! and your tablet software function in essentially the same way when it comes to scaling monitor and tablet area. osu!'s sensitivity scaler is essentially the tablet area in your tablet software and the 'map absolute raw input' is the screen area. Either one has to be set to its default settings as they both add on to each other, which is why the behavior is what it currently is. If you didn't have your tablet software installed (so that the settings aren't running) or had a tablet without software in which you can change these settings it would (and does) work as intended, which is essentially the setup showed in my screenshot, except that the tablet area is downscaled.

With that said, I don't exactly think the devs can make osu! can't ignore/undo your custom screen and tablet area from your tablet software, which is why I said it strongly doubt this can be fixed (/ worked around).

Oh, and the second cursor on your other monitor (unfocusing osu! when clicking) is another quirk with this. While osu! can scale the sensitivity of its own cursor, it can't change that of the windows cursor, the best it can do is lock it inside its area.

All in all I don't really see how this could be improved (without magic, lol), feel free to suggest things though (and correct me if I'm wrong on anything I said).
posted
I have this same problem, I've tried what VeilStar suggested, but anytime I move my cursor to the edge of my screen, it would go to my second monitor, even following the settings he listed.

Yes, I'm playing Fullscreen on 1280x720

Also, no matter what tablet area I set, (how small the box ir or how big the box is) It still move at the same pase a full area would.

I'm sore out of luck and I seriously doubt it is my tablet (CTL 480)
posted

Nantakuuu wrote:

Also, no matter what tablet area I set, (how small the box ir or how big the box is) It still move at the same pase a full area would.

I'm sore out of luck and I seriously doubt it is my tablet (CTL 480)
I have the same problem and I'm currently struggling to make a fitting area for myself , the problem is osu! scales your display settings too and therefore confines your tablet area.
posted
I have this with my CTL-490.
It's always been this way, this is probably how it's supposed to be even.
Please sign in to reply.