[resolved] Cursor clicking outside of osu window and pausing game

posted
Total Posts
11
Topic Starter
caned
Problem Details:
This problem has been occuring since I installed windows 10 last week.

If I move my cursor too far down it clicks outside of the osu window, so the game gets paused. Is there any way to lock the cursor to inside the window to prevent this? Or some other workaround.


I use a tablet and drag it, so windows acts as though it is always clicking. I would like to not disable clicking by pushing the pen down altogether as this is how I select songs and use menus etc.

Video or screenshot showing the problem:
n/a


osu! version: 20150812.11 (latest)
Trosk-
Hmm, osu! doesn't let you leave the osu! window while you are playing a map. If it's not the case then it's weird.

And well, a quick fix would be to change to Beta or Cutting Edge release streams, and activate Fullscreen and Letterboxing options. Then, select the resolution that you normally use on Windowed mode. Also, doing this, you will get rid of the input lag.
Arcane
Someprogramms like for example : Task Management. ALWAYS have a priority in windows so it doesnt matter if you have a fullscreen game running over it as long as such programms have that priority or a higher priority than, in this case Osu!, you will get forced out of the game.

Things you can do:


  • -Notice where you click when it occurs
    and tell us about it. so we can take a look at it.

    -Do NOT run like i already said processes like Task Manager behind your Osu! on your desktop



i hope this will give you an image of what is wrong. and i hope it helped you~
Topic Starter
caned

Trosk- wrote:

Hmm, osu! doesn't let you leave the osu! window while you are playing a map. If it's not the case then it's weird.

And well, a quick fix would be to change to Beta or Cutting Edge release streams, and activate Fullscreen and Letterboxing options. Then, select the resolution that you normally use on Windowed mode. Also, doing this, you will get rid of the input lag.
Thanks! I'll use this as a temporary fix.


Arcane wrote:

Someprogramms like for example : Task Management. ALWAYS have a priority in windows so it doesnt matter if you have a fullscreen game running over it as long as such programms have that priority or a higher priority than, in this case Osu!, you will get forced out of the game.

Things you can do:


  • -Notice where you click when it occurs
    and tell us about it. so we can take a look at it.

    -Do NOT run like i already said processes like Task Manager behind your Osu! on your desktop



i hope this will give you an image of what is wrong. and i hope it helped you~
I don't usually have any programs running behind osu. I made a video of the problem but unfortunately you can't see the mouse cursor movement. The mouse is moving around on screen at the same time as the osu cursor.

https://youtu.be/40ALxBguI5g

As you can see, when I move the cursor too far down it pauses the game, and when i try to unpause I can't even hover over the unpause area with the tablet.

Thanks for the help guys <3
VeilStar
Do you have the 'map raw input' setting enabled? If so, disable it.
Other than that another work-around would be setting your in-game sensitivity to 1x.
Arcane
So if i see it well it stucks? is this because you touch/drag on the tablet because it could have something to do with Tablet Gestures (windows) and otherwise maby it is just your tablet settings. are you a Fullscreen Player or windowed ( as show in the video) ? because what i think is that your Always has an absolute input so this means where it is on the tablet area = the place it is on the screen ( duhhh the concept of tablet usage XD) so if you are out of the box( osu ) and you acidentally click with the pen it ofcourse gets you out of the playing window.

I am not very well educated about how to set your tablet since i am a fullscreen player. Maby you can try if it also occurs on fullscreen? please tell me :)
i understand that you dont want to play on fullscreen but its just as a test.

XD i want to install windows 10 to test all these issues that get reported lately
Alek X
This happens to me aswell... :(
Topic Starter
caned

VeilStar wrote:

Do you have the 'map raw input' setting enabled? If so, disable it.
Other than that another work-around would be setting your in-game sensitivity to 1x.
The option was already disabled, and in-game sensitivity was already set to 1.

Arcane wrote:

So if i see it well it stucks? is this because you touch/drag on the tablet because it could have something to do with Tablet Gestures (windows) and otherwise maby it is just your tablet settings. are you a Fullscreen Player or windowed ( as show in the video) ? because what i think is that your Always has an absolute input so this means where it is on the tablet area = the place it is on the screen ( duhhh the concept of tablet usage XD) so if you are out of the box( osu ) and you acidentally click with the pen it ofcourse gets you out of the playing window.

I am not very well educated about how to set your tablet since i am a fullscreen player. Maby you can try if it also occurs on fullscreen? please tell me :)
i understand that you dont want to play on fullscreen but its just as a test.

XD i want to install windows 10 to test all these issues that get reported lately
It doesn't happen on fullscreen. But I don't want to play fullscreen ;-;
VeilStar
In that case it's just you moving your cursor outside of the game window and not an issue where the in-game sensitivity is different than your desktop sensitivity. There's no way around that if you want to play in windowed mode.

Playing in fullscreen or using the letterboxing option are your only options.
bobbybenny12

caned wrote:

Problem Details:
This problem has been occuring since I installed windows 10 last week.

If I move my cursor too far down it clicks outside of the osu window, so the game gets paused. Is there any way to lock the cursor to inside the window to prevent this? Or some other workaround.


I use a tablet and drag it, so windows acts as though it is always clicking. I would like to not disable clicking by pushing the pen down altogether as this is how I select songs and use menus etc.

Video or screenshot showing the problem:
n/a


osu! version: 20150812.11 (latest)
I have this problem, I have my cursor locked when fullscreen and play at fullscreen. I have no idea why this is happening.
Death
Please do not bump old, resolved threads.

Make a new thread and provide as much detail as possible such as: When this occurs/ what you are doing when it occurs, how long this has been happening for, what you have already tried to resolve the issue, etc.
Please sign in to reply.

New reply