1. osu! forums
  2. osu!
  3. Help
  4. Resolved Issues
posted
https://www.youtube.com/watch?v=iJYYWFar9qg
Laptop is SVE14A27CXH running 8.1, Drivers fully updated.
It uses switchable graphics and I have it set to use the dGPU instead of the iGPU.
Cutting edge, fullscreen, tried 120 240 and unlimited same results (the video is showing it on unlimited)
Outside of osu! using a paint application it shows much lower latency. The taps are instantaneous even in game as well.
Also when I try to use raw input to see the measure of latency it shows - my tracpad is showing upwards of 7ms.

Any way to fix this?

osu! version: 20150414.2
posted
Does using the integrated GPU make any difference? Also keep in mind that a small delay is inherent due to the way touch screens work and due to your FPS. If for instance you have 120 FPS, then 8.3ms delay is as good as it will get.
posted
I set the configurable graphics to low power mode, I assume this uses the iGPU.
https://www.youtube.com/watch?v=O2kbB7vRubA
(dunno why the video broke like that, sorry)

This is still worse than what using paint shows.

Edit:
Suspending winlogon.exe, killing dwm.exe and explorer.exe resolves this issue but exposes the fact that fullscreen cutting edge opengl isn't running in an "exclusive" display mode. It's still running through the desktop window manager. Seeing as you guys are planning to drop directx is there any way to fix this on your end? If this can't really be fixed I guess I can just switch to using Linux or windows 7 since Microsoft is pretty incompetent.
posted
Osu should be capable of exclusive fullscreen when using opengl. It is a known issue, that on laptops with hybrid graphics solutions when using the dGPU exclusive fullscreen does not work - this looks to be a problem with windows / graphics drivers and not with osu! unfortunately, since other opengl games also exhibit this behavior.

This is why I asked you to make use of the integrated gpu. I suspect it did not correctly switch to integrated graphics. Can you try using them again and afterwards post the contents of gl_info.txt here? It should be created in your osu! folder after you started osu!.
posted
if you want a lower latecy you should indeed set Osu to fullscreen and if that doesnt lower your latency enough you can go to : system > advanced system settings>Settings ( under the Performance Tab ''the most upper one'') and put it on ''best settings for performance'' this will turn ofd some windows graphical well you can call it intense settings and will speed up the latency process since it doesnt have to go thourgh alle the adjustments windows makes ;) hopefully this works and if not go to your Nvidia / Catalyst window and assign the Osu! game graphics to the Video card and not the internal one, which you have done already i see and ofcourse directX11 if possible :0 and yeah XD win 7 isi the best because of AeroDisable and on Linux XDDD i have no idea i couldnt manage to get osu running on Linux a little while ago maby its fixed by now

GOOD LUCK~!!!
Please sign in to reply.