[Archived] Sampling Editor on Standard's Slider issue

posted
Total Posts
8
Topic Starter
LordRaika
WALL of text ahead... Coding Stuff and lots of explanation...
Hopefully anyone follow what i'm explaining...


As the title said... Sampling Editor doesnt works on Standard's Slider....
Sampling Editor is... tool/menu under the editor >>> Compose > Sample Import or accessed with ALT+Mouse Left Click in Osu!Mania
cant be quick access in Standard compose part because ALT trigger distance snap multiplier... ( can still be access through Compose > Sample Import )

BUT the problem is not that...
Even i use this method on Slider , it doesnt works, either by manual scripting and Sampler Editor...


First , about how this Sampling works... ( either by manual scripting or using this feature )
this is normal notes coding line in both standard and osu mania ( beside coordinat )
224,80,3072,1,0,0:0:0:0:
Using Sampling Editor and hitsound them, will generate this line
224,80,3072,1,0,0:0:0:100:A6S_s.wav
The last two part is Volume and Sample in used... ignoring all other 0:0: since "1,0"
which is Hitsound type ( clap, whistle , finish) : Set : and so on...




So... this is example of Slider Coding line... ( Repeating slider of 7 times, 7 times being the last or end of the slider )
144,80,2379,2,0,L|192:80,6,35,0|0|8|4|0|0|0,0:0|0:0|0:0|0:0|0:0|0:0|0:0,0:0:0:0:
(this slider has clap on 3rd , and finish on 4th )

the highlighted color , is my thought about this coding line layering and structure...



i try to read and add the 99:A6S_s.wav manually on those slider....
144,80,2379,2,0,L|192:80,6,35,0|0|8|4|0|0|0,0:0|0:0|0:0|0:0|0:0|0:0|0:0,0:0:0:99:A6S_s.wav
and yeah it doesnt works... even on any part of them...i thought it will works for each part of the slider...
thus i try to add the code between each part ( i highlighted with colour )

it doesnt works as well... my coding also has the same result when i tried with Sampling Editor ... and yes it doesnt works...
i cant find a proper line where i can add this...
this structure and layering coding line on slider seems a bit different with normal notes...



like this
224,80,3072,1,0,0:0:0:0:
i assume , they are : X,Y,offset,ComboSet,Notetype,Sound,Set,0,Custom,Volume

where
Sound: 2=Whistle, 4=Finish, 8=Clap
Set: 1=Normal, 2=Soft, 3=Drum
Custom: custom sound number

but the layering on slider is a bit different and complex... thus making the sampling method doesnt works...

i humbly suggest...
that this method could works perfectly even on slider as well....either by improve the layering , or adding new line on how the system read them ,
then we can add this sampling code on between those layering ...

hopefully i made myself as clear as possible , since its tough to describe with only words...
yeah... programming stuff...
im not an expert in C but i used to other language in programming...
i also Wish that i can help into solving this one....


In short,
Sampling doenst works on slider, any part.... , Sampling means, using a file directly hitsound to the notes ...
IGNORING timing section and it doesnt have to follow default osu custom hitsound format like Soft-hitnormal, drum-hitclap and so on...

Side note :
This works for Osu!mania perfectly...
Works for standard's single notes as well but not the slider... not at all....

Thanks for reading




Video or screenshot showing the problem:
Currently no, its a wall of text...
sry... orz


osu! version: 20140814.1 (latest)
TheVileOne
I don't think it was made primarily for osu standard and that's why this was overlooked. ._.
Topic Starter
LordRaika

TheVileOne wrote:

I don't think it was made primarily for osu standard and that's why this was overlooked. ._.
yeah XD
hmm i think so too, since the slider's coding structure seems a bit complex especially when the slider have more than 2 part that can be hitsounded... ( start and end ) , well... manual scripting on them are possible thou, but its not Sampling anymore and the file must be in osu format like...
soft-hitnormal
drum-hitclap
normal-hitfinish and so on....

i must say it must be intensely hard to manage that if the mapper have lots of hitsounded use... especially me that depend on naming...

hoping this feature wlll perfectly implemented to Standard Slider as well, and it will be perfect ^^b
( not to mention, this will absolutely works for CTB and Taiko as well ) but its less noticeable on Taiko as Taiko doesnt really use other custom hitsound
TheVileOne
I'll investigate this tomorrow.
Topic Starter
LordRaika
Yes please...
Thanks
TheVileOne
Bringing this back from the dead.
Wingman626

TheVileOne wrote:

Bringing this back from the dead.
is this where i'm supposed to say "so much for getting ""back to him tomorrow"" " ?



all in all, this seems kind of weird to me (that and i dont know enough of that code)

144,80,2379,2,0,L|192:80,6,35,0|0|8|4|0|0|0,0:0|0:0|0:0|0:0|0:0|0:0|0:0,0:0:0:99:A6S_s.wav


is the ""0:0|0:0"" supposed to change when the "99:A6S_s.wav" value is added at the end of the line?

i think i need to read up on this more on this language of code. im hoping that this information is in the wiki?
Bara-
This is still not fixed...

FYI, I'm using it so a note can have multiple hitsounds (aka, more than the Original 4 normal/clap/whistle/finish) at the same time
Please sign in to reply.

New reply