osu! Skin Manager

posted
Total Posts
102
show more
DriftKingTW
Same situation, crashed after relaunch it.
maybe "[INFO] 15.02.2015, 19:08:52: Found old installer files! Files deleted" is the problem?? :o
log:

[INFO] 15.02.2015, 19:07:45: Initializing "log.txt"...
[INFO] 15.02.2015, 19:07:45: "log.txt" created!
[INFO] 15.02.2015, 19:07:45: Initializing Application..language set to "default"
[INFO] 15.02.2015, 19:07:46: Initializing complete! Loading settings...
[INFO] 15.02.2015, 19:07:46: Loading necessary data...
[INFO] 15.02.2015, 19:07:46: Found no directory
[INFO] 15.02.2015, 19:08:21: Loading skins...
[INFO] 15.02.2015, 19:08:21: All skins loaded successfully!
[INFO] 15.02.2015, 19:08:25: Loaded all data! Updater initialized...
[INFO] 15.02.2015, 19:08:25: Begin searching for Updates...Step 1: Getting version.txt
[INFO] 15.02.2015, 19:08:28: Loading skin into the application...
[INFO] 15.02.2015, 19:08:30: Downloaded "version.txt". Checking for version...
[INFO] 15.02.2015, 19:08:30: Everything is up-to-date!
[INFO] 15.02.2015, 19:08:38: --- loaded 519 files
[INFO] 15.02.2015, 19:08:38: --- loaded skin.ini
[INFO] 15.02.2015, 19:08:38: Set index to 0
[INFO] 15.02.2015, 19:08:38: Loaded skin successful!
[INFO] 15.02.2015, 19:08:47: Application closed with code 0
[INFO] 15.02.2015, 19:08:47: Settings exported!
[INFO] 15.02.2015, 19:08:51: Initializing Application..language set to "default"
[INFO] 15.02.2015, 19:08:52: Imported settings!
[INFO] 15.02.2015, 19:08:52: Initializing complete! Loading settings...
[INFO] 15.02.2015, 19:08:52: Found old installer files! Files deleted
[INFO] 15.02.2015, 19:08:52: Loading necessary data...
Topic Starter
BlackTasty
No, this is normal after updates, but you can try to delete the "Installer" folder in the installation path of the application. Can you describe me what you have done before the crashes appeared? Would be nice :)
DriftKingTW
After I've installed the app, I just open it to load a skin then close it.
When I open the app again, and it crashed as soon as the Welcome page came out... :|
Topic Starter
BlackTasty
If you reinstall the application, make sure after the first start that you go to settings and deactivate under "Other" "Automatically load the last edited skin after startup", this should solve the problem (I will work on a solution ;) )
DriftKingTW
Oh the problem has been solved!!Thank You ;)
Topic Starter
BlackTasty

DriftKingTW wrote:

Oh the problem has been solved!!Thank You ;)
I'm glad to help you :D
Topic Starter
BlackTasty
Update 3.7.5 Full is now avaible!
  1. Changed: The log is now more precise
  2. Changed: The name of the selected audio file is now displayed over the element viewer
  3. Fixed: Some weird bugs (after saving your skin, he didn't updated the element view anymore)
clairvoyant
http://i.imgur.com/fSx6KDv.png This happened to me, i never downloaded this before.
Topic Starter
BlackTasty
Are you sure you haven't installed the application before? Check your installed programs and uninstall the osu! Skin Manager ;)

The entry should look like this:
Ruidoso
I've read every single post you wrote in this thread and it's so inspiring to witness how much progress you've made. First, according to what is posted, UI was not looking so good and then there were bugs, you fixed them, you updated the program to have better features and so on. I might be going full emotional on this thread but whatever, keep up the good job! :P
MomokoCho
The instlaller is in Detucsh xD But very nice app.
Flanster
What are you using NAudio for? WAV & MP3 can be played without the need of another external library as such.
naseweis520
Da sich meine osu! Installation im %LocalAppData% Verzeichnis befindet, welches standardmäßig versteckt wird, ist es mir nicht möglich über den FolderBrowser zum Skin-Verzeichnis (C:\Users\[Nutzername]\AppData\Local\osu!\Skins") zu navigieren bzw. dieses auszuwählen.



For those who don't speak German: I'm unable to navigate to my Skin-Folder 'cause it's hidden.
Topic Starter
BlackTasty

Ruidoso wrote:

I've read every single post you wrote in this thread and it's so inspiring to witness how much progress you've made. First, according to what is posted, UI was not looking so good and then there were bugs, you fixed them, you updated the program to have better features and so on. I might be going full emotional on this thread but whatever, keep up the good job! :P
Thank you very much, you honored me with your post :)

MomokoCho wrote:

The instlaller is in Detucsh xD But very nice app.
Visual Studio is too stupid to select english as installer language ;D

LoliFlan wrote:

What are you using NAudio for? WAV & MP3 can be played without the need of another external library as such.
I use NAudio because it's easier to use for me to use and implement :)

naseweis520 wrote:

Da sich meine osu! Installation im %LocalAppData% Verzeichnis befindet, welches standardmäßig versteckt wird, ist es mir nicht möglich über den FolderBrowser zum Skin-Verzeichnis (C:\Users\[Nutzername]\AppData\Local\osu!\Skins") zu navigieren bzw. dieses auszuwählen.



For those who don't speak German: I'm unable to navigate to my Skin-Folder 'cause it's hidden.
Ich versuch eine Lösung für das Problem zu finden, alternativ kannst du auch über "Einstellungen" den Pfad manuell angeben ;)
I will work on a solution, alternately you can select the path manually over "Settings" ;)
naseweis520

bl8ckdr8gon wrote:

Ich versuch eine Lösung für das Problem zu finden, alternativ kannst du auch über "Einstellungen" den Pfad manuell angeben ;)
I will work on a solution, alternately you can select the path manually over "Settings" ;)
Der Ordner lässt sich über die Windows-Einstellungen wieder einblenden und daher auch auswählen, nur ist das etwas aufwendig, daher wäre vllt. eine automatische Erkennung des Ordners praktisch.
Darüberhinaus öffnet sich das Dialogfenster beim ersten Start, eine Auswahl eines "falschen" Ordners ist nicht möglich aufgrund der Überprüfung und ein Klick auf Abbrechen beendet das Programm.
For those who don't speak German: It's possible to redisplay all folders including hidden folders in the Windows-Folder-Settings.
_Erra_
good job~
Topic Starter
BlackTasty

naseweis520 wrote:

bl8ckdr8gon wrote:

Ich versuch eine Lösung für das Problem zu finden, alternativ kannst du auch über "Einstellungen" den Pfad manuell angeben ;)
I will work on a solution, alternately you can select the path manually over "Settings" ;)
Der Ordner lässt sich über die Windows-Einstellungen wieder einblenden und daher auch auswählen, nur ist das etwas aufwendig, daher wäre vllt. eine automatische Erkennung des Ordners praktisch.
Darüberhinaus öffnet sich das Dialogfenster beim ersten Start, eine Auswahl eines "falschen" Ordners ist nicht möglich aufgrund der Überprüfung und ein Klick auf Abbrechen beendet das Programm.
For those who don't speak German: It's possible to redisplay all folders including hidden folders in the Windows-Folder-Settings.
Ich werd versuchen eine automatische Erkennung möglich zu machen ;)
EDIT: Erste Versuche haben geklappt, der AppData Ordner wird angezeigt :) Ein Update folgt noch heute oder morgen.

_Erra_ wrote:

good job~
Thank you :)
Maralina
I've attempted to download it. I've done everything I should have done and it keeps saying I'm missing certain files and to contact you for help. Anything?
Topic Starter
BlackTasty

Maralina wrote:

I've attempted to download it. I've done everything I should have done and it keeps saying I'm missing certain files and to contact you for help. Anything?
Could you upload a screenshot of the error? This would help me :)
aafi
hi there :)
i just want to send a log
Error come up if skin folder was empty

it's just a minor issue, but
in my opinion it will be more nice if the program can mention that:
your folder was empty. you may select wrong folder or you still doesn't have a skin installed on osu!
or some thing like that



########################################################
## !!This application is copyrighted by bl8ckdr8gon!! ##
## Log created: 20.04.2015 at 08:28:19. ##
## ##
## If you run into problems, please send this log ##
## via pm on the osu! homepage or post it in the ##
## thread: http://osu.ppy.sh/forum/t/231747 ##
########################################################

[INFO] 20.04.2015, 08:28:19: Initializing "log.txt"...
[INFO] 20.04.2015, 08:28:19: "log.txt" created!
[INFO] 20.04.2015, 08:28:19: Initializing Application..language set to "default"
[INFO] 20.04.2015, 08:28:20: Initializing complete! Loading settings...
[INFO] 20.04.2015, 08:28:20: Loading necessary data...
[INFO] 20.04.2015, 08:28:20: --- Checking the osu_directory setting...
[INFO] 20.04.2015, 08:28:20: Found no directory
[INFO] 20.04.2015, 08:29:16: --- Setting values...
[INFO] 20.04.2015, 08:29:16: --- Checking if a skin was loaded...
[INFO] 20.04.2015, 08:29:16: Loading skins...
[INFO] 20.04.2015, 08:29:16: Settings exported!
[FATAL] 20.04.2015, 08:29:27: Exception thrown in Form1: While starting the osu! Skin Manager, the application crashed completely (Line osu__Skin_ManagerForm1ctor()) - Crash information: InvalidArgument=Value of '0' is not valid for 'SelectedIndex'.
Parameter name: SelectedIndex
[INFO] 20.04.2015, 08:29:28: Creating Crash Backup from actual skin...
[ERROR] 20.04.2015, 08:29:28: Exception thrown in Form1: Unable to save the skin.ini (Line data))
[INFO] 20.04.2015, 08:29:28: Backup created!
[INFO] 20.04.2015, 08:29:28: Backup finished successful!
and after that i keep getting an error every time i want to re-start aplication
note: (my skin folder is still empty)
here the log
########################################################
## !!This application is copyrighted by bl8ckdr8gon!! ##
## Log created: 20.04.2015 at 08:28:19. ##
## ##
## If you run into problems, please send this log ##
## via pm on the osu! homepage or post it in the ##
## thread: http://osu.ppy.sh/forum/t/231747 ##
########################################################

[INFO] 20.04.2015, 08:28:19: Initializing "log.txt"...
[INFO] 20.04.2015, 08:28:19: "log.txt" created!
[INFO] 20.04.2015, 08:28:19: Initializing Application..language set to "default"
[INFO] 20.04.2015, 08:28:20: Initializing complete! Loading settings...
[INFO] 20.04.2015, 08:28:20: Loading necessary data...
[INFO] 20.04.2015, 08:28:20: --- Checking the osu_directory setting...
[INFO] 20.04.2015, 08:28:20: Found no directory
[INFO] 20.04.2015, 08:29:16: --- Setting values...
[INFO] 20.04.2015, 08:29:16: --- Checking if a skin was loaded...
[INFO] 20.04.2015, 08:29:16: Loading skins...
[INFO] 20.04.2015, 08:29:16: Settings exported!
[FATAL] 20.04.2015, 08:29:27: Exception thrown in Form1: While starting the osu! Skin Manager, the application crashed completely (Line osu__Skin_ManagerForm1ctor()) - Crash information: InvalidArgument=Value of '0' is not valid for 'SelectedIndex'.
Parameter name: SelectedIndex
[INFO] 20.04.2015, 08:29:28: Creating Crash Backup from actual skin...
[ERROR] 20.04.2015, 08:29:28: Exception thrown in Form1: Unable to save the skin.ini (Line data))
[INFO] 20.04.2015, 08:29:28: Backup created!
[INFO] 20.04.2015, 08:29:28: Backup finished successful!
[INFO] 20.04.2015, 08:51:48: Initializing Application..language set to "default"
[INFO] 20.04.2015, 08:51:48: Imported settings!
[INFO] 20.04.2015, 08:51:48: Initializing complete! Loading settings...
[INFO] 20.04.2015, 08:51:48: Loading necessary data...
[INFO] 20.04.2015, 08:51:48: --- Checking the osu_directory setting...
[INFO] 20.04.2015, 08:51:48: --- Setting values...
[INFO] 20.04.2015, 08:51:48: --- Checking if a skin was loaded...
[INFO] 20.04.2015, 08:51:48: Loading skins...
[INFO] 20.04.2015, 08:51:48: Settings exported!
[FATAL] 20.04.2015, 08:51:51: Exception thrown in Form1: While starting the osu! Skin Manager, the application crashed completely (Line osu__Skin_ManagerForm1ctor()) - Crash information: InvalidArgument=Value of '0' is not valid for 'SelectedIndex'.
Parameter name: SelectedIndex
[INFO] 20.04.2015, 08:51:51: Creating Crash Backup from actual skin...
[ERROR] 20.04.2015, 08:51:51: Exception thrown in Form1: Unable to save the skin.ini (Line data))
[INFO] 20.04.2015, 08:51:51: Backup created!
[INFO] 20.04.2015, 08:51:51: Backup finished successful!
[INFO] 20.04.2015, 08:52:10: Initializing Application..language set to "default"
[INFO] 20.04.2015, 08:52:10: Imported settings!
[INFO] 20.04.2015, 08:52:10: Initializing complete! Loading settings...
[INFO] 20.04.2015, 08:52:10: Loading necessary data...
[INFO] 20.04.2015, 08:52:10: --- Checking the osu_directory setting...
[INFO] 20.04.2015, 08:52:10: --- Setting values...
[INFO] 20.04.2015, 08:52:10: --- Checking if a skin was loaded...
[INFO] 20.04.2015, 08:52:10: Loading skins...
[INFO] 20.04.2015, 08:52:10: Settings exported!
[FATAL] 20.04.2015, 08:52:18: Exception thrown in Form1: While starting the osu! Skin Manager, the application crashed completely (Line osu__Skin_ManagerForm1ctor()) - Crash information: InvalidArgument=Value of '0' is not valid for 'SelectedIndex'.
Parameter name: SelectedIndex
[INFO] 20.04.2015, 08:52:18: Creating Crash Backup from actual skin...
[ERROR] 20.04.2015, 08:52:18: Exception thrown in Form1: Unable to save the skin.ini (Line data))
[INFO] 20.04.2015, 08:52:18: Backup created!
[INFO] 20.04.2015, 08:52:18: Backup finished successful!
[INFO] 20.04.2015, 08:54:32: Initializing Application..language set to "default"
[INFO] 20.04.2015, 08:54:32: Imported settings!
[INFO] 20.04.2015, 08:54:32: Initializing complete! Loading settings...
[INFO] 20.04.2015, 08:54:32: Loading necessary data...
[INFO] 20.04.2015, 08:54:32: --- Checking the osu_directory setting...
[INFO] 20.04.2015, 08:54:32: --- Setting values...
[INFO] 20.04.2015, 08:54:32: --- Checking if a skin was loaded...
[INFO] 20.04.2015, 08:54:32: Loading skins...
[INFO] 20.04.2015, 08:54:32: Settings exported!
[FATAL] 20.04.2015, 08:54:40: Exception thrown in Form1: While starting the osu! Skin Manager, the application crashed completely (Line osu__Skin_ManagerForm1ctor()) - Crash information: InvalidArgument=Value of '0' is not valid for 'SelectedIndex'.
Parameter name: SelectedIndex
[INFO] 20.04.2015, 08:54:40: Creating Crash Backup from actual skin...
[ERROR] 20.04.2015, 08:54:40: Exception thrown in Form1: Unable to save the skin.ini (Line data))
[INFO] 20.04.2015, 08:54:40: Backup created!
[INFO] 20.04.2015, 08:54:40: Backup finished successful!
[INFO] 20.04.2015, 08:56:04: Initializing Application..language set to "default"
[INFO] 20.04.2015, 08:56:04: Imported settings!
[INFO] 20.04.2015, 08:56:04: Initializing complete! Loading settings...
[INFO] 20.04.2015, 08:56:04: Loading necessary data...
[INFO] 20.04.2015, 08:56:04: --- Checking the osu_directory setting...
[INFO] 20.04.2015, 08:56:04: --- Setting values...
[INFO] 20.04.2015, 08:56:04: --- Checking if a skin was loaded...
[INFO] 20.04.2015, 08:56:04: Loading skins...
[INFO] 20.04.2015, 08:56:04: Settings exported!
[FATAL] 20.04.2015, 08:56:07: Exception thrown in Form1: While starting the osu! Skin Manager, the application crashed completely (Line osu__Skin_ManagerForm1ctor()) - Crash information: InvalidArgument=Value of '0' is not valid for 'SelectedIndex'.
Parameter name: SelectedIndex
[INFO] 20.04.2015, 08:56:07: Creating Crash Backup from actual skin...
[ERROR] 20.04.2015, 08:56:07: Exception thrown in Form1: Unable to save the skin.ini (Line data))
[INFO] 20.04.2015, 08:56:07: Backup created!
[INFO] 20.04.2015, 08:56:07: Backup finished successful!
hope it can help you
thank you for making this program :)
show more
Please sign in to reply.

New reply