User avatar
Tempo Trainee
13 posts
Offline
Hello,
i have a Problem with my tablet ctl-470 after installing Windows 8.
If i tap on the screen in osu! the curosr stops until i move the pen a bit.
Through the fact that i'm just tap when i spin or accidentally tap while play.
It is straight on every tap i do not just sometimes.

The funny thing is that i'm running a second Computer and on this one it works perfectly.
So far i installed all kind of drivers i found, enabled the stuff in system config and tried varius things in forums etc.

Please if you know a solution help me :)
Wer anderen eine Grube gräbt hat ein Grubengrabgerät!
User avatar
Beat Clicker
50 posts
Offline
Bumping this because I'm having the exact same issues. I'm using a CTL-470 with driver version 5.2.5-5. The newer driver seems to be a bit worse.

I played this map 2 times, once on Windows 7 and on Windows 8 (click to download replays). Windows 7 is perfectly smooth, but on Windows 8, you should be able to see that every time I tap, the cursor freezes for a short amount of time.

This is not necessarily an issue with osu!. It looks like the reason is that you can't properly turn off press-and-hold right-click in the pen input settings anymore. Well, you can, but it doesn't seem to do anything work as intended. In Windows 7, having this turned on results in a similar tap lag, although not as severe. (<-- not 100% sure about this, need to recheck) I guess this is a bug in Windows 8.

The main reason why I'm posting this is that it seems to be possible to fix this from inside osu!. The thing is, the tap lag doesn't happen everywhere. Windows Paint for example works perfectly fine. There's some more info on this blog comment and the referenced MSDN article.
Edit: Also, inside osu!, whenever osu! uses the default arrow cursor, there don't seem to be any of those freezes.

I hope this can be resolved soon. I'll have to boot into Windows 7 in the meantime, because playing like this in Windows 8 is just no fun.

(Related topic on the Wacom forums.)
Last edited by helion on , edited 2 times in total.
User avatar
Beat Clicker
50 posts
Offline
Looks like I found a workaround. This doesn't actually solve the problem and it's rather uncomfortable, but it makes osu! playable for the time being.

After endless hours googling I found out that it's actually possible to turn off tablet taps driver-side, even though there is no such setting in the Wacom settings app. It works like this:
  • Locate "AppData\Roaming\WTablet\Pen_Tablet.dat" and open it. It's a simple XML file.
  • Find line "<ButtonName type="string">tip</ButtonName>" and change the button function node above from 1 to 0.
  • Restart computer (or tablet service).

After doing that, any tapping on the tablet surface will be completely ignored. Of course, navigating osu! doesn't work either, so I set one of the pen buttons to issue a click (which will cause the aforementioned lags/delays again :P ). Also, any playstyle that involves tablet tapping is impossible with this.
User avatar
Tempo Trainee
13 posts
Offline
WoW.... thanks mate i will try it and give feedback as soon as i can.
Well kinda annoying anways.. maybe there will be a bugfix on driverside or either windows.
Wer anderen eine Grube gräbt hat ein Grubengrabgerät!
User avatar
Slider Savant
95 posts
Offline
Edit: I found the "Buttonname..." but here to change it. There is no 1 or 0 ....
User avatar
Beat Clicker
50 posts
Offline
This is what you need to find:

Image

Where I have a 0 now, the file in its default state should have a 1.
User avatar
Rhythm Incarnate
614 posts
Offline
FynnFTW wrote:
Edit: I found the "Buttonname..." but here to change it. There is no 1 or 0 ....

There should be a way to modify the value once you select the line, as highlighted by helion above.
Be sure to select/modify the correct line i.e. the '1' in <blablabla>1</ButtonFunction> to '0'.
Image
User avatar
Tempo Trainee
9 posts
Offline
before edit AppData\Roaming\WTablet\Pen_Tablet.dat
1</ButtonFunction> to '0'.

you should kill table process in the win task manager(total 4 process),because ever 30 sec the file will be recorvery.
User avatar
Tempo Trainee
5 posts
Offline
i have the same problem here and for the time being i'm playing tip-less to avoid freezing and the second button of the pen as the left click button for all the navigation issues :D
User avatar
Combo Commander
484 posts
Offline
Same here, I just bought a tablet and I have same issues with Windows 8 and osu!.

helion wrote:
The thing is, the tap lag doesn't happen everywhere. Windows Paint for example works perfectly fine.]


I can confirm this, but I notice same lags when I move any application window (whether osu! or Explorer's windows) with my tablet (Bamboo CTL-470). Can anyone confirm this?
User avatar
Slider Savant
95 posts
Offline
Puncia wrote:
Same here, I just bought a tablet and I have same issues with Windows 8 and osu!.

helion wrote:
The thing is, the tap lag doesn't happen everywhere. Windows Paint for example works perfectly fine.]


I can confirm this, but I notice same lags when I move any application window (whether osu! or Explorer's windows) with my tablet (Bamboo CTL-470). Can anyone confirm this?


yes. Same!

some1 tryed the installation CD? Maybe it works on Windows 8
User avatar
Tempo Trainee
13 posts
Offline
The installation cd doesn't work aswell i tried it several times.
Wer anderen eine Grube gräbt hat ein Grubengrabgerät!
User avatar
Rhythm Incarnate
651 posts
Offline
you can't disable dynamic feedback in windows 8, solution? change back to windows 7 or wait for microsoft to publicate some kind of fix (good luck).
User avatar
Slider Savant
95 posts
Offline
SteRRuM wrote:
you can't disable dynamic feedback in windows 8, solution? change back to windows 7 or wait for microsoft to publicate some kind of fix (good luck).


Ye, and if Windows 7 dont work..... and if Windows Vista dont work [. . . .]

[. . . .] wellcome back to Windows 3.2 ~~
User avatar
Combo Commander
484 posts
Offline
Reply 17 posts jump | 1, 2  next

Users browsing this forum: None


Jump to: