User avatar
Whistle Blower
17 posts
Offline
 

 
Please see this wiki article for a fix: osu!wiki: Windows 8.1 cursor stuttering solution




I just upgraded to Windows 8.1 and when open osu! I get this problem.

Mouse cursor can't controllable when setting Mouse sensitivity higher than 1.0x

I'm trying to rotate my mouse.

At 1.0x It's normal, but when set to 1.1x. It's look weird.
Then set it higher It'll uncontrollable. :?

Edit: Lower 1.0x have same effect, only 1.0x working fine.

Precision disabled in mouse setting. No external mouse software.

Image

Image

Image
User avatar
17,888 posts
Offline
I can replicate this.
User avatar
17,888 posts
Offline
This looks to be an issue at Microsoft's end. The API to change the mouse cursors location no longer works.

I have reported it here: http://answers.microsoft.com/en-us/wind ... bd2ad4a90a
User avatar
Rhythm Rookie
4 posts
Offline
peppy wrote:
This looks to be an issue at Microsoft's end. The API to change the mouse cursors location no longer works.

I have reported it here: http://answers.microsoft.com/en-us/wind ... bd2ad4a90a


Are you sure it's the API. Just asking because my touchpad still works even though the mouse doesn't when I set the sensitivity to 2.5x.
User avatar
17,888 posts
Offline
Yes. I am sure. Else I wouldn't have said anything.
User avatar
Pro Tester
4,506 posts
Offline
Moving to low priority for now, as peppy has done all he can for the moment.
User avatar
Rhythm Rookie
1 posts
Offline
Me too on my desktop (not VM)
Windows 8.1 (Latest Update complete and Build 9431)

When fix this problem?
I want to play!!!!
User avatar
Rhythm Rookie
1 posts
Offline
i found some answer.
resultly,
they say

"SendInput() works."

is ok?
User avatar
17,888 posts
Offline
Until the final release, I cannot support this. Please use 1.0x or rollback.
User avatar
Rhythm Incarnate
1,487 posts
Offline
Just for the record, I'm using the final retail build (9600), and this is still a problem. Unless Microsoft releases a hotfix post-release, this will still be a problem when Windows 8.1 launches.
Image
YouTube - MyAnimeList - Steam - ask.fm
My skin ver.38 [all modes, HD] work-in-progress, 9月14日

pls support my feature request
User avatar
Whistle Blower
17 posts
Offline
YayMii wrote:
Just for the record, I'm using the final retail build (9600), and this is still a problem. Unless Microsoft releases a hotfix post-release, this will still be a problem when Windows 8.1 launches.


8.1 build 9600 is 'leaked' release and Microsoft doesn't provide any support on this release.

We have to wait for official release to fix this.
User avatar
Rhythm Incarnate
1,487 posts
Offline
9600 is the final RTM build, which was officially released on MSDN to developers and manufacturers, who get it earlier than the public. And peppy just confirmed on his twitter that the RTM build still doesn't have this fixed, so this won't be fixed unless there is a hotfix post-release.
Image
YouTube - MyAnimeList - Steam - ask.fm
My skin ver.38 [all modes, HD] work-in-progress, 9月14日

pls support my feature request
User avatar
17,888 posts
Offline
Depending on my VM settings, I can actually make it work correctly on 9600.winblue_rtm.130821-1623. I found this out after posting on twitter. I am waiting for confirmation of people running in a non-VM environment, as I don't have the resources to test this currently.
User avatar
Rhythm Incarnate
1,487 posts
Offline
I'll give my build number another check when I get home then. I'm running Windows 8.1 Pro (Build 9600) in a non-VM environment on my desktop PC and I'm having this issue. I'm pretty sure that 9600.winblue_rtm.130821-1623 is the only build with the 9600 tag though.

Is the setting you changed only relevant to VMs? If not, what did you change?
Image
YouTube - MyAnimeList - Steam - ask.fm
My skin ver.38 [all modes, HD] work-in-progress, 9月14日

pls support my feature request
User avatar
17,888 posts
Offline
I have mouse-specific driver hacks at an OS X level, and parallels has game optimisations settings at a VM level. One combination of these makes the mouse work as expected again.
Reply 134 posts jump | 1, 2, 3, 4, 5 ... 9  next

Users browsing this forum: None


Jump to: