Let's get you started!

What next?

Installation Issues?

  • osu! requires .NET framework 3.5. The installer should prompt you to download this, but if not, you can find it here
  • osu! will run on just about any hardware, as long as you have a graphics card. If you are having trouble getting it to run, please report your issue in the forums or send an email to support.

Learn more?

Check out the osu!academy youtube channel for up-to-date tutorials and tips on how to get the most out of osu!