User avatar
Tempo Trainee
8 posts
Offline
Hey guys, I've came across an issue I'd like to discuss. When running osu! on my dedicated NVIDIA 820M GPU (not the best, but it's my laptop), it always caps to 60 FPS (though it fluctuates from 60 - 61). This lock is accompanied by a severe 17ms of input lag.

Image

I am quite sure that vSync (vertical sync) is disabled, as I play on the "unlimited" fps setting.

Image

In the NVIDIA Control Panel, it is also disabled.

Image

Interestingly enough, this only occurs on the fullscreen setting. When toggled off - into windowed mode - I receive maximum fps, with around 4ms of input lag. Nonetheless, I continue to play on my integrated graphics, Intel(R) HD Graphics 5500. Here, I also achieve maximum fps, but the latency bounces from time to time, in addition to the occasional second of freezing when playing a map. I want to try using the NVIDIA GPU, to see if it's possible for improvement.

If need be, I can fetch additional information that may be relevant to this problem.

Have a good one, TR4NQU1L1TY.
User avatar
Support Team
1,520 posts
Offline
Inside your osu! folder, right click on the osu!.exe, select Properties, and then Compatibility. Once there, check "Disable fullscreen optimizations."

If that does not work, restart you computer, close any programs you have running in the background and disable any overlays you have enabled.

You can also try updating or reinstalling your graphics drivers.
Last edited by Death on , edited 2 times in total.
User avatar
Tempo Trainee
8 posts
Offline
Death wrote:
Inside your osu! folder, right click on the osu!.exe, select Properties, and then Compatibility. Once there, check "Disable fullscreen optimizations."

If that does not work, restart you computer, close any programs you have running in the background and disable any overlays you have enabled.

You can also try updating or reinstalling your graphics drivers.


Thanks for the speedy response!

I took a shot at disabling fullscreen optimizations. Following all your directions, I navigated the files to adjust the settings as you indicated. However, it seems that the issue continues to persist: I am still locked at 60-61 FPS, with 17ms of input lag.

Restarting my computer did not do the trick, and I analyze this issue with osu! as the only open program, without any overlays.

I just updated the graphics card via NVIDIA GeForce Experience, hoping that it would work...

Unfortunately, it didn't D:

Please continue to attempt to find a solution. All help is appreciated. If you require any other information, simply ask.
User avatar
Support Team
1,520 posts
Offline
Do you have any programs like EVGA Precision X or MSI Afterburner installed on your computer at all? Programs such as these have been found in the past to be the culprit of this capped FPS issue, and sometimes people forget about disabling them.
Last edited by Death on , edited 1 time in total.
User avatar
Tempo Trainee
8 posts
Offline
Death wrote:
Do you have any programs like EVGA Precision X or MSI Afterburner installed on your computer at all? Programs such as these have been found in the past to be the culprit of this capped FPS issue, and sometimes people forget about disabling them.


Sorry for a late response, I got busy over the past couple of days.

I do not believe I have such programs installed. The only item that may fall under the same category is NVIDIA GeForce Experience. Yet, I do not believe that it applies to osu! at all, as it does not recognize it as an official game... I simply use GeForce Experience to update my NVIDIA drivers, which are indeed of the latest build.

Interestingly enough, this seems to be a widespread issue. I have realized that osu! is set to run on integrated graphics by default, as seen on both of my brothers' laptops. In terms of specifications, their computers are of greater quality than mine.

On both computers, I have attempted to run osu! via their NVIDIA GPUs - NVIDIA GTX 1050 and 960mx. Being in fullscreen, the same issue occurs! A fluctuating 60 FPS cap, with 17ms of input lag. This is not the case when you run it in integrated graphics, nor in windowed w/ a NVIDIA GPU.

Could this be some kind of issue regarding NVIDIA GPUs + fullscreen in osu!...?

Any feedback would be appreciated. I apologize for any inconvenience in the delayed reply!
User avatar
Support Team
1,520 posts
Offline
Try disabling the In-game overlay through GeForce Experience.
User avatar
Tempo Trainee
8 posts
Offline
Death wrote:
Try disabling the In-game overlay through GeForce Experience.


NVIDIA GeForce Experience's In-Game Overlay does not seem to be compatible with my older GPU...

Image

Any other thoughts?
User avatar
Support Team
1,520 posts
Offline
Do you have any power saving settings enabled on your laptop? If so disable them, also plug your laptop in if it is not.

Check to make sure your graphics card also has maximum performance selected for anything power related.
User avatar
Tempo Trainee
8 posts
Offline
Death wrote:
Do you have any power saving settings enabled on your laptop? If so disable them, also plug your laptop in if it is not.

Check to make sure your graphics card also has maximum performance selected for anything power related.


Observing the NVIDIA Control Panel, the option of "Power Management Mode" has been set to "Prefer maximum performance," in addition "Texture filtering - Quality" to being set to "High performance." "Threaded optimization" is also enabled, to allow the usage of multiple CPUs...

Within the power settings of my computer, it is set to "High Performance." Items regarding graphics and CPU usage has been set to maximum performance.

And yes, I do play with my laptop plugged in :)

Nonetheless, the issue continues to persist. Please mention if I may have missed something relevant.
User avatar
Rhythm Incarnate
761 posts
Offline
try turning down the resolution (of osu)
User avatar
Tempo Trainee
8 posts
Offline
Kondou-Shinichi wrote:
try turning down the resolution (of osu)


Ah, still no luck. I attempted all available resolutions with fullscreen. The issue persists, with the NVIDIA GPU - a 60 FPS lock and 17ms of input lag.

Thanks for the suggestion, though :D
User avatar
Rhythm Incarnate
761 posts
Offline
idk if this is related, but try turning game DVR and game bar off

goto settings (control panel), then gaming, then turn both game dvr and game bar off.

researched a bit online and i saw some people having same problem with fullscreen capping at 60fps when this helped them, so give it a try
User avatar
Cymbal Sounder
37 posts
Offline
Well I've been having the exact same problem for almost a year now and funny enough I was looking for solutions again today because I got so annoyed by the variations in fps i get from playing with the integrated graphics, and found your post. Not sure if this is a problem with laptops, because I play on one too, though my gpu is a 740m.
I have tried all the possible fixes already, so i'm just leaving a comment to see if someone comes up with a solution and to show that you're not alone with this mind breaking problem, my friend. :cry:
User avatar
Tempo Trainee
8 posts
Offline
Kondou-Shinichi wrote:
idk if this is related, but try turning game DVR and game bar off

goto settings (control panel), then gaming, then turn both game dvr and game bar off.

researched a bit online and i saw some people having same problem with fullscreen capping at 60fps when this helped them, so give it a try


Thanks for another suggestion! I've actually tried this before, but to no avail. Interestingly enough, I discovered this fix when my Counter-Strike: Global Offensive was locked at 60 FPS with irregular input lag! It worked for that game... if only it did for osu! :)

Ari0n wrote:
Well I've been having the exact same problem for almost a year now and funny enough I was looking for solutions again today because I got so annoyed by the variations in fps i get from playing with the integrated graphics, and found your post. Not sure if this is a problem with laptops, because I play on one too, though my gpu is a 740m.
I have tried all the possible fixes already, so i'm just leaving a comment to see if someone comes up with a solution and to show that you're not alone with this mind breaking problem, my friend. :cry:


Yikes, nearly a year? Yes, I've also researched this online, and it seems to be a reoccurring issue among a number of NVIDIA GPUs - from what I've seen, of course. Developers, hear us out! (at your convenience, of course :D)

Thanks for the words of empathy! I truly hope that we are able to find a fix sometime in the future... Until then, my friend ;)
Reply 14 posts

Users browsing this forum: None


Jump to: