Rhythm Rookie
2 posts
Offline
Problem Details:
I found that all the thumbnails, ranked status and the grades of my maps are all messed up today.
And what I can do is to click in "Edit" of every song and exit edit window without doing anything, then the information would be correct.
But I have thousands of maps! I have to spend such a long time recovering the map information!?
So, are there any other ways that I can try to fix this problem?

Other ways I have tried but found not useful:
1. Delete data/bt/ , it's not useful because my bug is not only about thumbnails;
2. Delete osu.db, it's not useful either...
3. Press F5 to refresh all the beat maps, not useful...

Video or screenshot showing the problem:
1. Wrong thumbnails, ranked status and the grades
Image

2. After clicked on "Edit" and exit edit window, the thumbnails, ranked status and the grades were corrected.
Image


osu! version: 20171106.5 (latest)
User avatar
Support Team
960 posts
Offline
Did you delete your osu!.db file with osu! closed?
Rhythm Rookie
2 posts
Offline
Death wrote:
Did you delete your osu!.db file with osu! closed?


Thanks for your reply!
I have tried this way. But after refreshing the beatmap list, I found that I can only see about 20% of my maps. Being afraid of the data loss, I finally gave up this idea and recovered my osu!.db file to the former version.
Whistle Blower
23 posts
Offline
Same issue here, it's really frustrating
User avatar
Tempo Trainee
6 posts
Offline
press f5 to refresh all your maps and if that doesn't work try repairing your osu
Whistle Blower
23 posts
Offline
I did both it's still a problem and actuially getting worse. Is it possible to download corrupted beatmaps?
User avatar
Support Team
3,403 posts
Offline
Sort by Title and scroll all the way up, and all the way down and make sure their are no maps that are just " // " If there are, please delete it.

Also to be sure we aren't just being silly about most of your maps not showing up, make sure you haven't messed with this option.
Image

A recompiled database should of fixed your issue with the thumbnails, not exactly sure why it didn't. Sometimes it rarely doesn't seem to work, and I don't think anyone ever really found a fix. All I can suggest is trying again at your own risk.
Last edited by Dntm8kmeeatu on , edited 1 time in total.
Reply 7 posts

Users browsing this forum: None


Jump to: