User avatar
Rhythm Incarnate
824 posts
Offline
Problem Details:

While editing the map Thaehan – Saiyajin, some strange behavior occurs for the updater, and this has existed for the past month and a half. To demonstrate the problem, I recently updated the map with a different name. Formerly, the names of the difficulties with problematic updaters were “Intense” and “Saiyan”. I will now show with these pictures what creating a difficulty with the name Saiyan does, though if you download the map yourself I'm sure you can replicate it since modders from my thread have done this as well.

Creating the difficulty “Saiyan”: http://puu.sh/y4InF/6709ab89cf.jpg

Open the editor, don't do anything, just exit out: http://puu.sh/y4Iqc/5b06b7c022.jpg

This results in the updater prompting you to make an update. Note that currently, no “Saiyan” difficulty exists in the mapset: http://puu.sh/y4Iqx/4faa9c37ef.jpg

Updating it results in a blank map like this: http://puu.sh/y4IrW/1540c3d4ab.jpg ---- http://puu.sh/y4IXe/187fb9f9e8.jpg

Clicking the map description button brings you to this mapset: https://osu.ppy.sh/b/252483

It looks like changing the name of this difficulty fixed the problem since I was not able to replicate this issue for the difficulty now called “Insane” or “Testing, 1 2 3”. However, I would very much like to keep the name Saiyan for the top difficulty, and I hope to try resolve potential future issues for other users.

Some context about the map: I first uploaded the map with a few different backgrounds and with the difficulties Intense and Saiyan (well my memory is a bit fuzzy, I'm positive I had Saiyan, and I'm pretty sure I had Intense). I then chose the current background and deleted the others, which is why the thumbnail in my pictures is a bit different. I'm guessing that the difficulties “Novice”, “Advanced”, and “Hyper” didn't have this problem because they were created after the background change. This could be completely irrelevant, but I hope that might be helpful.

osu! version: 20170731.2 (latest)
User avatar
Rhythm Incarnate
1,457 posts
Offline
It seems like a problem with your data base file.

Turn off your osu! > go to osu! folder and then move file called osu!.db out of folder > run osu!

Now beatmaps should automatically reload and problem propably won't exist anymore.
User avatar
Combo Commander
344 posts
Offline
Up comment, because same problem on my map, i do this above^ but, only resolved for a few minutes (5 in my case) after that the problem returns geez..
User avatar
Rhythm Incarnate
602 posts
Offline
pinataman wrote:
Problem Details:

While editing the map Thaehan – Saiyajin, some strange behavior occurs for the updater, and this has existed for the past month and a half. To demonstrate the problem, I recently updated the map with a different name. Formerly, the names of the difficulties with problematic updaters were “Intense” and “Saiyan”. I will now show with these pictures what creating a difficulty with the name Saiyan does, though if you download the map yourself I'm sure you can replicate it since modders from my thread have done this as well.

Creating the difficulty “Saiyan”: http://puu.sh/y4InF/6709ab89cf.jpg

Open the editor, don't do anything, just exit out: http://puu.sh/y4Iqc/5b06b7c022.jpg

This results in the updater prompting you to make an update. Note that currently, no “Saiyan” difficulty exists in the mapset: http://puu.sh/y4Iqx/4faa9c37ef.jpg

Updating it results in a blank map like this: http://puu.sh/y4IrW/1540c3d4ab.jpg ---- http://puu.sh/y4IXe/187fb9f9e8.jpg

Clicking the map description button brings you to this mapset: https://osu.ppy.sh/b/252483

It looks like changing the name of this difficulty fixed the problem since I was not able to replicate this issue for the difficulty now called “Insane” or “Testing, 1 2 3”. However, I would very much like to keep the name Saiyan for the top difficulty, and I hope to try resolve potential future issues for other users.

Some context about the map: I first uploaded the map with a few different backgrounds and with the difficulties Intense and Saiyan (well my memory is a bit fuzzy, I'm positive I had Saiyan, and I'm pretty sure I had Intense). I then chose the current background and deleted the others, which is why the thumbnail in my pictures is a bit different. I'm guessing that the difficulties “Novice”, “Advanced”, and “Hyper” didn't have this problem because they were created after the background change. This could be completely irrelevant, but I hope that might be helpful.

osu! version: 20170731.2 (latest)


Probably because the beatmap ID isn't correct, change it to -1 in the .osu file.

Make sure the creator is your username also, you're essentially trying to submit someone elses beatmap.
User avatar
Rhythm Incarnate
1,457 posts
Offline
Kalindraz wrote:
Up comment, because same problem on my map, i do this above^ but, only resolved for a few minutes (5 in my case) after that the problem returns geez..

so try to shift+delete on osu!.db instead
User avatar
Rhythm Incarnate
682 posts
Offline
uh hi
as far as i know as a mapper, it’s a problem that happens quite commonly, i suppose
this map, https://osu.ppy.sh/b/252483 , is known to appear at every kind of these blank maps
its still unknown why thou

well in this case, i think youre fucked
User avatar
Rhythm Incarnate
824 posts
Offline
Been a bit busy, sorry for the delayed response.

Venix wrote:
It seems like a problem with your data base file.

Turn off your osu! > go to osu! folder and then move file called osu!.db out of folder > run osu!

Now beatmaps should automatically reload and problem propably won't exist anymore.


This did not solve the problem, I was still able to update to the completely different mapset.

Venzire wrote:
Probably because the beatmap ID isn't correct, change it to -1 in the .osu file.

Make sure the creator is your username also, you're essentially trying to submit someone elses beatmap.


This did not solve the problem, I was still able to update to the completely different mapset. I confirmed I was the creator.
User avatar
Rhythm Incarnate
976 posts
Offline
I doubt the problem was on pinataman's end, I experienced osu immediately asking me to update those same difficulties after downloading them to mod. It is probably something on the osu website/server's end that's causing this.
User avatar
Rhythm Incarnate
682 posts
Offline
Noffy wrote:
I doubt the problem was on pinataman's end, I experienced osu immediately asking me to update those same difficulties after downloading them to mod. It is probably something on the osu website/server's end that's causing this.

As a mapper myself ,this problem happened numerous times, and I don’t think theres any clues for me to understand why does this happen
User avatar
Rhythm Incarnate
976 posts
Offline
This is a present issue sstill and I have heard of it effecting others as well.
Very recently, this has begun happening on one of my sets :
https://osu.ppy.sh/beatmapsets/688590#osu/1457177
it has started happening to the taiko difficulties after I added them.

My fix for it was to add vaguely song related adjectives to the difficulty names, but this bug is preeettty dang bad and should be addressed ASAP
User avatar
Combo Commander
460 posts
Offline
I can vouch for Noffy, the only way to fix this issue to to change the diffnames, if that doesn't work, change the artist, if that doesn't work, change the title.

The only steps past changing all the metadata would be to have the set manually deleted by a qat and reuploading, but even then it didn't work (for me at least).
Reply 11 posts

Users browsing this forum: None


Jump to: