User avatar
Tempo Trainee
10 posts
Offline
Problem Details:
So I was exploring the options and came across the resolution options and I was curious, so I turned it all the way down, and got a screen in the corner with a white rectangle in the middle, so basically the rectangle was supposed to be where the screen actually is. So I tried turning the resolution back up and got a white screen. The game still runs in the background but the rectangle overlaps the original screen and results in not being able to see anything but white. I tried the repair osu! shortcut in the game's files, and it works but it would be tiring having to do that over and over again, so I want to find a way to restore the screen.
:(

Video or screenshot showing the problem:

file:///C:/Franklin's%20Fabulous%20Works!/Images/Screenshots/problem%20-%20osu!.PNG

osu! version: 20170731.2 (latest)
User avatar
Support Team
551 posts
Offline
I'm confused as to when this issue occurs? Is it only when you change your resolution? You said you fixed it by repairing osu! but you are still having the issue?
Also, we can't see files that are stored on your computer unless you upload them to a site like imgur first.

Open up your the file osu!.pcname.config in your osu! folder and double check that the lines "Shaders" and "BloomSoftening" are set to 0.
User avatar
Rhythm Incarnate
1,838 posts
Offline
Are you able to run the game with no issues in Compatibility Mode?

Hold shift while launching osu!. A recovery dialog should pop up, and from there, you should be able to enable Compatibility Mode.
User avatar
Cymbal Sounder
45 posts
Offline
I run into a similar problem playing osu! from an HDMI output. although my screen turns black and not white.

When the game launches hold the keys ALT+ENTER, this is the hotkey to switch osu! into windowed more, here you should be able to see, then go into settings and enable compatibility mode and when the game starts, click ALT+ENTER again if you wish to continue playing in fullscreen, or you may choose the letterboxing option in the settings.
User avatar
Tempo Trainee
10 posts
Offline
Nikosbks wrote:
Are you able to run the game with no issues in Compatibility Mode?

Hold shift while launching osu!. A recovery dialog should pop up, and from there, you should be able to enable Compatibility Mode.

It works! Thanks! But it doesn't work w/o it and it's laggier w/ it.
Death wrote:
I'm confused as to when this issue occurs? Is it only when you change your resolution? You said you fixed it by repairing osu! but you are still having the issue?
Also, we can't see files that are stored on your computer unless you upload them to a site like imgur first.

Open up your the file osu!.pcname.config in your osu! folder and double check that the lines "Shaders" and "BloomSoftening" are set to 0.

About the image thing yeah I realized but had to sleep :/ Also I can't open .cfg, Windows Explorer tells me it can't open the file and it can search the internet. I don't feel like downloading anything so yeah... And for your confusion, I changed the res once, and from there on out it was a white rectangle blocking it.
OfficialPyroh wrote:
I run into a similar problem playing osu! from an HDMI output. although my screen turns black and not white.



When the game launches hold the keys ALT+ENTER, this is the hotkey to switch osu! into windowed more, here you should be able to see, then go into settings and enable compatibility mode and when the game starts, click ALT+ENTER again if you wish to continue playing in fullscreen, or you may choose the letterboxing option in the settings.

BTW alt + enter didn't work, or maybe it was alredy windowed. IDK. :/

Also, and I know this'll be annoying but I've done it before - Should I re-download osu!?
User avatar
Support Team
551 posts
Offline
franklincool wrote:
Nikosbks wrote:
Are you able to run the game with no issues in Compatibility Mode?

Hold shift while launching osu!. A recovery dialog should pop up, and from there, you should be able to enable Compatibility Mode.

It works! Thanks!

If this is working you might want to consider updating/reinstalling your graphics drivers so you don't have to use it.
franklincool wrote:
Death wrote:
I'm confused as to when this issue occurs? Is it only when you change your resolution? You said you fixed it by repairing osu! but you are still having the issue?
Also, we can't see files that are stored on your computer unless you upload them to a site like imgur first.

Open up your the file osu!.pcname.config in your osu! folder and double check that the lines "Shaders" and "BloomSoftening" are set to 0.

About the image thing yeah I realized but had to sleep :/ Also I can't open .cfg, Windows Explorer tells me it can't open the file and it can search the internet. I don't feel like downloading anything so yeah... And for your confusion, I changed the res once, and from there on out it was a white rectangle blocking it.

You can open .cfg with notepad.

franklincool wrote:
Also, and I know this'll be annoying but I've done it before - Should I re-download osu!?

No, that is not necessary.
User avatar
Tempo Trainee
10 posts
Offline
death wrote:
Open up your the file osu!.pcname.config in your osu! folder and double check that the lines "Shaders" and "BloomSoftening" are set to 0.

It was set to 1, so I set it to 0 and it works! But in options, if I turn on softening filter everything goes white, and when I exit the screen turns white, the game says "See you next time" and it fades away. And whenever I click on something the screen flashes white, and I played a beatmap and everything was fine a few seconds in and then the screen turned white for a few seconds, causing me to lose. (w/o compatibility mode) :/
User avatar
Support Team
551 posts
Offline
franklincool wrote:
death wrote:
Open up your the file osu!.pcname.config in your osu! folder and double check that the lines "Shaders" and "BloomSoftening" are set to 0.

It was set to 1, so I set it to 0 and it works! But in options, if I turn on softening filter everything goes white, and when I exit the screen turns white, the game says "See you next time" and it fades away. And whenever I click on something the screen flashes white, and I played a beatmap and everything was fine a few seconds in and then the screen turned white for a few seconds, causing me to lose. (w/o compatibility mode) :/


BloomSoftening is Softening filter, so if it was set to 1 and it didn't work, that is because it was enabled in options. Your computer just might not be able to handle having it enabled, but you can still try updating your graphics drivers if you really want it on for whatever reason. You aren't really missing out on much when it is disabled, so I suggest you just keep it that way.
User avatar
Tempo Trainee
10 posts
Offline
Death wrote:
BloomSoftening is Softening filter, so if it was set to 1 and it didn't work, that is because it was enabled in options. Your computer just might not be able to handle having it enabled, but you can still try updating your graphics drivers if you really want it on for whatever reason. You aren't really missing out on much when it is disabled, so I suggest you just keep it that way.

I had it on, and it was working, then I changed the res and everything else occurred.
User avatar
Support Team
551 posts
Offline
Death wrote:
...but you can still try updating your graphics drivers if you really want it on for whatever reason. You aren't really missing out on much when it is disabled...
User avatar
Tempo Trainee
10 posts
Offline
franklincool wrote:
death wrote:
Open up your the file osu!.pcname.config in your osu! folder and double check that the lines "Shaders" and "BloomSoftening" are set to 0.

It was set to 1, so I set it to 0 and it works! But in options, if I turn on softening filter everything goes white, and when I exit the screen turns white, the game says "See you next time" and it fades away. And whenever I click on something the screen flashes white, and I played a beatmap and everything was fine a few seconds in and then the screen turned white for a few seconds, causing me to lose. (w/o compatibility mode) :/

Oh, and also, I found out that all of the above were caused by shaders. Apparently it doesn't work w/ shaders and/or bloom softening :(
User avatar
Tempo Trainee
10 posts
Offline
Death wrote:

What's NVIDIA and AMD? Just saying I have a Windows 7 Ultimate.
User avatar
Support Team
551 posts
Offline
Graphics card manufacturers.

Go to Control Panel > Device Manager > Display Adapters, to find what graphics card you have, then download the correct version from one of those three websites (depending on which manufacturer you have).
User avatar
Tempo Trainee
10 posts
Offline
Death wrote:
Graphics card manufacturers.

Go to Control Panel > Device Manager > Display Adapters, to find what graphics card you have, then download the correct version from one of those three websites (depending on which manufacturer you have).

Is it in processors? What adapter/device?
User avatar
Support Team
551 posts
Offline
Death wrote:
Go to Control Panel > Device Manager > Display Adapters


Image

You can also do this:
Windows 10:
  • Right click on your desktop and select "Display Settings"
  • In the window that pops up select "Advanced Display Settings"
  • Then select "Display Adapter Properties"
  • Your card will be listed in the "Adapter Type" box
Windows 7
  • Right Click on your desktop and select "Screen Resolution"
  • One the new window that pops up, select "Advanced settings"
  • Another window will pop up, select the "Adapter" tab
  • Your card will be listed in the "Adapter Type" box
Reply 18 posts jump | 1, 2  next

Users browsing this forum: None


Jump to: