User avatar
Rhythm Rookie
3 posts
Offline
Problem Details:

This started just randomly one time when i was playing around 2 months ago,
really depending on the day, my osu game will have little little stutters during gameplay and it's just enough to mess up
a stream or throw you off a jump. It doesn't always do this either, sometimes the game runs completely fine and other times it can't
stop stuttering. I notice the game really stutters when the meter on the bottom right next to the input delay goes up into the red (for no reason).
I thought at first maybe my computer was getting crowded with too much junk so i cleared a lot of junk and made sure really nothing else was
running in the background of my game, i even kept task manager open on my other monitor and kept an eye on usage of any other programs.
Still, random stutters during gameplay. Funny because right after i recorded the video of the example below, my game started working fine and no stutters at all.

Things I tried:
- Running osu! off my SSD instead of HDD
- Using fallback version
- Re-Installing
- Changing multiple settings (too many to list, none of them worked)
- Upgrading from Windows 8.1 to Windows 10 (yes, i actually did this from the time the problem started, and it continued)
- Making sure my tablet drivers are up to date
- Making sure my video card drivers are up to date
- Making sure my keyboard drivers are up to date
- Shutting down almost every other program in the background of the game

If i forgot to add anything in this post please just ask and i can hopefully provide any missing information;
I just want to be able to play normally!

Video or screenshot showing the problem:

This is the meter on the bottom right i was talking about next to the input delay:

Image

I recorded a liveplay to try and demonstrate the best possible to you guys what exactly my problem is.
The little stutters are kind of hard to notice while watching the video, but while you're playing they are
much more noticeable and very disrupting:



Something to note: during the recording i got more stutters than i usually would when the problem occurs
probably about double the amount

osu! version: 20160403.6

Specs:
Operating System
Windows 10 Pro 64-bit
CPU
Intel Core i5 4690K @ 3.50GHz 84 °C
Haswell 22nm Technology
RAM
8.00GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)
Motherboard
MSI Z97I AC (MS-7851) (SOCKET 0) 41 °C
Graphics
GN246HL (1920x1080@144Hz)
XP19WD (1440x900@60Hz)
Intel HD Graphics 4600 (MSI)
2047MB NVIDIA GeForce GTX 960 (Gigabyte) 47 °C
ForceWare version: 384.94
SLI Disabled
Storage
111GB Samsung SSD 840 EVO 120GB (SSD) 36 °C
931GB Western Digital WDC WD10EZEX-08M2NA0 (SATA) 40 °C
Audio
Realtek High Definition Audio

Peripherals:

Monitor: Acer GN246HL
Tablet: Wacom Intuos CTL-490
Keyboard: Corsair K65 RAPIDFIRE
Audio: Apple Earpods connected through a set of Logitech 5.1 surround speakers
User avatar
Support Team
3,136 posts
Offline
richardf wrote:
- Shutting down almost every other program in the background of the game


Did you try disabling things like Anti-virus? They are notorious for deciding to do things and causing skips / lags.

I would also open up Perfmon and look for what is writing to your disk when the issue happens. as these things are normally caused by disk usage spikes. (Some people have fixed after putting on SSD, but seems not to be your case)
User avatar
Rhythm Incarnate
2,433 posts
Offline
If you sit on the title screen and set your frame limiter to 120fps, can you see lag increase every 5 seconds?

https://vid.me/nfSWr
Tempo Trainee
9 posts
Offline
ziin wrote:
If you sit on the title screen and set your frame limiter to 120fps, can you see lag increase every 5 seconds?

https://vid.me/nfSWr
No but I have that exact problem. Same as OP, but my stuttering is in the menus and not while I'm playing. About every 2-5 seconds the game will freeze and input delay and latency will dramatically increase. As soon as I start a beatmap, perfectly fine.
Tempo Trainee
9 posts
Offline
My specs are as follows. Win 10 64-bit, Gtx 1070, AMD FX-8320 8-core processor at 4 physical cores and 8 virtual cores, 24GB of DDR3 Ram running at 1333Mz. 50 GB SSD, 2TB Hard disk drive (where Osu! is at) which is defragmented every other day when needed.
User avatar
Rhythm Rookie
3 posts
Offline
ziin wrote:
If you sit on the title screen and set your frame limiter to 120fps, can you see lag increase every 5 seconds?

https://vid.me/nfSWr


No, just tested it and it just sat at 8.3 - 8.4ms input lag and the frames stayed at 120.
If i click on another beatmap my input lag and frames will get worse for a sec and stable themselves out.
User avatar
Rhythm Incarnate
2,433 posts
Offline
No clue. I was having latency every 5 seconds, likely caused by AMD ReLive.

Try a clean install of graphics drivers, with the basic package if that's an option.
User avatar
19,052 posts
Offline
I guarantee there is something on your PC that is causing this. Keep task manager open and watch for other processes spiking in CPU when it happens.

Make sure you don't have any colour correct apps like flux open.
Make sure you don't have any background recording apps open, like nvidia experience or whatever
Make sure you haven't forced "thread optimisations" in nvidia gpu settings (try toggling it or setting to default).
User avatar
Combo Commander
413 posts
Offline
I actually wonder, is your CPU throttling?

You can check by enabling the high performance power option in Windows and then playing a game. If it hits close to 90 or tjmax then it'll throttle.

I'll keep an eye out for a response.
Reply 9 posts

Users browsing this forum: None


Jump to: