User avatar
Tempo Trainee
5 posts
Offline
Problem Details: everytime I try to play online or try doing anything that need internet connection it just doesn't work, it does not connect to bancho bot,
and I amoust sure I'm connected to internet ( or wouldn't even be able to post this ) I have searched but didn't find anything.
also ... already tried to disable antivirus and firewall or reinstalling osu... help pls

Video or screenshot showing the problem:

http://imgur.com/nJ15Tf0
http://imgur.com/2ovcpPL

osu! version: 20160403.6
User avatar
Tempo Trainee
8 posts
Offline
I have the exact same problem as you! I really don't know what to do, and it's really frustrating. I have had this problem for a month now, maybe even more. The bigger problem is that now I can't even play solo. When I click on osu! icon it automatically opens updater. But, it won't update because of internet connection problem. I am also 100% sure that I am connected to the internet, because I am watching YouTube as I write this.

I really really hope someone will help us with this :(

P.S. I don't know how to check my current osu! version, since I can't even open osu!.
User avatar
Rhythm Rookie
1 posts
Offline
I have this problem too as from Maskarada.. reinstall doesn't help. :(
User avatar
Tempo Trainee
8 posts
Offline
Yeap, I tried reinstalling, I tried completely disabling my Firewall. Nothing works...
User avatar
Tempo Trainee
5 posts
Offline
ok so I found a temporally ''solution'' for my problem
I installed a older version of osu using a <olld installer> that can be found on the official site in
https://osu.ppy.sh/p/download
https://imgur.com/a/xMoO9
and after downloading osu with this installer I CAN now play in multiplayer and have acess to banchobot
buuuut...
I still want a real solution because I want to use the newest and updated version of osu :cry:
for now this is the version that I will use hope that this help you guys too
User avatar
Tempo Trainee
8 posts
Offline
Oh it works! Thank you babfishs! Did you maybe try updating it from that old installer or you didn't wanna risk it?
User avatar
Rhythm Incarnate
1,918 posts
Offline
Are you sure that your anti-virus isn't blocking the connection to osu! without your agreement Maskarada? I know that some anti-virus also give a firewall option.
From what you said, it sounds like something is blocking Bancho.
User avatar
Tempo Trainee
8 posts
Offline
Pachiru wrote:
Are you sure that your anti-virus isn't blocking the connection to osu! without your agreement Maskarada? I know that some anti-virus also give a firewall option.
From what you said, it sounds like something is blocking Bancho.


So, fallback version works. It connects to Bancho even with antivirus on and firewall on. I tried updating osu! to the newest version from inside the game from fallback version. It updated, but again it fails to connect to Bancho after I restarted the game. I have tried disabling both antivirus and firewall at the same time and still doesn't work. I use Avast antivirus, and that antivirus always notifies me when it blocks some program or web page. I didn't get any notification for osu!. So I'm sure it doesn't block it whatsoever.

I only have this problem with the newest version of osu! for some reason. And as you can see I'm not the only one. I think the problem is much bigger than just antivirus or firewall...

For now, I'm gonna keep using fallback version, cause that's the only way. But I hope this gets resolved in the future so I can play new version :)
User avatar
Rhythm Incarnate
1,900 posts
Offline
Switch to Cutting Edge build and provide your network.log file, please.
User avatar
Tempo Trainee
8 posts
Offline
Nikosbks wrote:
Switch to Cutting Edge build and provide your network.log file, please.


https://mega.nz/#!5k11UY4Q!9u9myPqSZeSPO4VfFSeD3YKyxkew9L2dqIGlA98NAZQ

Here it is!
User avatar
Rhythm Incarnate
1,900 posts
Offline
Maskarada and babfishs, please switch to Cutting Edge build, go to the options menu and use the Debug_ForceIPv4FallbackPath option.
User avatar
Tempo Trainee
8 posts
Offline
Nikosbks wrote:
Maskarada and babfishs, please switch to Cutting Edge build, go to the options menu and use the Debug_ForceIPv4FallbackPath option.


Did it. It still doesn't work. I tried to restart osu!, but now when I open it, it doesn't open the game, but the updater box, and it's just stuck there, cause it says there is no internet connection.
User avatar
Rhythm Incarnate
1,918 posts
Offline
If it doesn't work, you can also try releasing and renewing your IPconfig, and flushing your DNS.
I'm not sure if it'll work, but it's still worth a try.
User avatar
Rhythm Incarnate
1,900 posts
Offline
Maskarada wrote:
Did it. It still doesn't work. I tried to restart osu!, but now when I open it, it doesn't open the game, but the updater box, and it's just stuck there, cause it says there is no internet connection.

Can you update back to fallback, though? Please provide your update.log.

Meanwhile, make sure your .NET Framework is properly installed and up-to-date. You might wanna uninstall it completely and install the latest version to make sure nothing is messing up with it.
User avatar
Rhythm Incarnate
1,457 posts
Offline
Try to go to proxy settings by going to control panel > network and sharing center > internet options, if you're here then go to connections tab and click LAN settings button, now uncheck Automaticly detect options. Press ok and close internet settings and try to run osu!

My osu! was connecting ultra slow and after this it's connecting very fast so it's a worth try I think.
Reply 25 posts jump | 1, 2  next

Users browsing this forum: None


Jump to: