User avatar
Rhythm Rookie
4 posts
Offline
when i launch the game, it says ''Can't find the name of Intel icd OpenGL driver''

here is the error thing: OpenTK.Graphics.GraphicsContextException: [EGL] Failed to create window surface, error BAD_NATIVE_WINDOW.
en OpenTK.Platform.Egl.EglWindowInfo.CreateWindowSurface(IntPtr config)
en OpenTK.Platform.Egl.EglContext..ctor(GraphicsMode mode, EglWindowInfo window, IGraphicsContext sharedContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
en OpenTK.Platform.Egl.EglAnglePlatformFactory.CreateGLContext(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Boolean directRendering, Int32 major, Int32 minor, GraphicsContextFlags flags)
en OpenTK.Graphics.GraphicsContext..ctor(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
en #=qH8MHUwc4s4AIOP8embIm_LZVJ1hcXHmXvQ4kbKKaWdXEAILiwIKAGYcIN5xQJXaQ.#=qqvWHIjTJ11kNQjXagY2F3Q==(Int32 #=qziYoDwk$PYjdOkqhyQIonw==, Int32 #=qAxkx7SJqQSowL0CnPp7gGg==, GraphicsContextFlags #=q0r5I1MdApGtJ54aGgOdCjQ==)
en #=qJlnuD_UcXRoElpm2icUN$xv4mHIVbAIXw0qJaXX4M17Nt6UwoiS1Agm0IcyQ69sI.OnHandleCreated(EventArgs #=q3m$_0fTukzAo40eVgKKt8A==)
en #=qmcB6XnfGcdT$_fSIuP8CBToueKpBlR5PlfKTI7deIJL42oV_a3A$j0BVEdXueDJp.OnHandleCreated(EventArgs #=q3m$_0fTukzAo40eVgKKt8A==)
en System.Windows.Forms.Control.WmCreate(Message& m)
en System.Windows.Forms.Control.WndProc(Message& m)
en System.Windows.Forms.ScrollableControl.WndProc(Message& m)
en System.Windows.Forms.Form.WmCreate(Message& m)
en System.Windows.Forms.Form.WndProc(Message& m)
en #=qi17YWq5DpjzsdfsVCMbOCKlTKzi5JL1aNh1uHTzjAi0=.WndProc(Message& #=qKFgFOP_7pGMr0NtKdRHygA==)
en System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
en System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
en System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

THANKS FOR CLICKING


osu! version: 20170222.3 (latest)
User avatar
Support Team
2,053 posts
Offline
Dntm8kmeeatu wrote:
This is only a Temporary workaround.

Go into your osu!.PCNAME.cfg file and change Fullscreen from 1 to 0. Save, and then relaunch osu!

Playing without fullscreen is normally not recommended due to how Windows forces DWM buffering and creates a feeling of input delay.

If you are 7 or Vista, you can disable this by disabling the Windows Aero theme. It's completely forced on 8 and 10 and cannot be disabled.


See if that don't do the trick for ya;
User avatar
Rhythm Rookie
3 posts
Offline
I don't know if this will work for you or not, but for me it work perfectly fine.

Go to where you locate your osu! game file, then you will see two .cfg file one is 'osu!.cfg' another one is 'osu!.(your PC name).cfg'. Click on the 'osu!.(your PC name).cfg open it with notepad. Next click 'Edit' on the top then click 'Find...' type in 'CompatibilityContext' then click find next after that you will see 'CompatibilityContext 1' change it to 0 then click 'save'.

then I start the game and it run perfectly fine :)

Hope this help you
(sorry for my bad English xD)
User avatar
Rhythm Rookie
4 posts
Offline
well, it worked, but i rebooted the pc and the cfg file was blank, then i decided to reinstall osu, but the error continues
User avatar
Rhythm Rookie
4 posts
Offline
Looks like there isn't an actual solution to this by now
User avatar
Support Team
2,053 posts
Offline
Try installing with the old installer
User avatar
Rhythm Rookie
1 posts
Offline
8-) I have the same problem and same error code here.
i got that after my lastest Intel Graphic driver auto update.
I try both solutions but it still not work. :o :o :o
Looking for help!!!
User avatar
Support Team
2,053 posts
Offline
ha_jinjin wrote:
8-) I have the same problem and same error code here.
i got that after my lastest Intel Graphic driver auto update.
I try both solutions but it still not work. :o :o :o
Looking for help!!!


Try downgrading your driver version or rolling them back if possible.
User avatar
Rhythm Rookie
4 posts
Offline
WELL, it actually worked, and for the newcomers, it's a problem with the updated Intel graphics 520 driver you just need to roll them back

THANKS Dntm8kmeeatu
Reply 9 posts

Users browsing this forum: None


Jump to: