User avatar
Beatmap Nominator
757 posts
Offline
Problem Details:
Sometimes when booting up the game, all of my maps are missing their star rating. Playing/editting maps, particularly those with lots of stacking, appears to raise the CPU usage of osu! to the point where the game and eventually my PC runs extremely slowly. The only way to fix at that point is to close the game before the CPU gets overloaded, at which point hard rebooting is the only option.

Restarting the game does not fix this issue. The way I've found to fix is to revert back to Stable and then back to CE. After fixing, the issue reappears after an unknown amount of times opening the game. Missing star ratings seems to be the main indicator that the issue is present in the session.


Video or screenshot showing the problem:



Sorry that the video gets choppy at places, that's my CPU overloading from the issue.


osu! version: b20180208cuttingedge
User avatar
Pro Tester
4,986 posts
Offline
This is normal. The latest cuttingedge build changed the difficulty calculation algorithm, so all your maps are being reprocessed in the background, which may take a while if you have a lot of them. It only calculates stars for the current mode on the current mod combo, so if you're not switching those around, it'll finish faster and hopefully complete before your CPU overheats.

Switching back to stable is the worst thing you can do in this case, since that triggers another full difficulty reprocess due to the algorithm being different again, and then switching back to cuttingedge triggers it yet again. Probably the best thing you can do in your case is open song select, lower your fps to 120, then click a score and sit at the results screen to minimize excess power usage and reduce overheating until the calculations finish.
Last edited by MillhioreF on , edited 1 time in total.
User avatar
Beatmap Nominator
757 posts
Offline
Right, so there was a problem specific to my game that occured with this reprocessing.

So I tried leaving my game on 120 fps on a score screen to let it process. After about 30 minutes, I got somewhat impatient and saw my CPU usage was still at 70-80%. Backing out of the score screen put the computer into slow motion again. I thought it was weird that a recalculation like this was using up so much processing power, and it's not as if my specs were seriously lacking (i3 6100, RX 470).

Trying it in a new session it seemed like the CPU usage kept going up whenever I enter and exit a score screen, so maybe it was trying to retrigger a calculation when I did that?

I then noticed one of the mapsets had all of the difficulties recalculated apart from one. When I removed that difficulty from the game, everything started to run smoothly again. That difficulty was some old experiment I had a while ago, where I put 20000 circles stacking on opposite ends of the playfield 1ms apart to see how high I could raise star difficulty (511 stars iirc, if you were interested). I think that difficulty being so extreme with the stacking and number of objects was breaking the game.

Mapset link in case you wanted to see it yourself. [t] difficulty was the one breaking stuff (I set the file type to .osuignore in case it broke something immediately).
Reply 3 posts

Users browsing this forum: None


Jump to: