User avatar
Whistle Blower
19 posts
Offline
Firstly, My laptop specs:
CPU: i7-7700HQ
GPU: Intel HD 630 & GTX 1050Ti 4GB
SSD: 256GB
HDD: 1TB
RAM: 16GB

I personally don't think this laptop would have any problem running osu, but after changing, it suprisingly had many problems including:

Screen freezing after alt+tabbing back in the game when i use gtx 1050ti
Lag right before spinner which makes me miss the note right before
Random freezes that ruin my fc

The Spinner lag occurs randomly with about 40-70% chance.

The Video Below shows the Random Freeze and Spinner Lag:
https://youtu.be/iBoZlbwomSQ
Timestamp:
0:14 (Spinner Lag)
2:08 (Random Freeze)
2:47 (Spinner Lag 2)
Timestamps are also in the description of the video
Last edited by patmethny1 on , edited 1 time in total.
User avatar
Rhythm Rookie
4 posts
Offline
having the exact same problem with very similar specs. guess i'm not the only one, but this is extremely frustrating.
User avatar
Support Team
1,543 posts
Offline
Tried updating or reinstalling your graphics drivers?
User avatar
Rhythm Rookie
1 posts
Offline
I have the same problem. I get 2ms input lag and 240fps at 1920x1080, but got spinner lag before it popped up 50% of the time.

I fixed by changing my resolution to 1280x720 and after about 15 spinner, no lag yet.



I know it's not the optimal solution, but that's one solution
User avatar
Rhythm Incarnate
888 posts
Offline
Have you disable this "Shader" under Graphics Options?
User avatar
Beat Clicker
70 posts
Offline
TheBoiCold and patmethny1!
You have pretty similar laptop to mine! I've been having loads of issues with osu! myself, including this one you are currently experiencing! I am looking for a solution too, I really hope we can get this resolved. I am SOO glad that I am not alone with this issue, I was starting to lose hope... Death and I tried to resolve this, but didn't quite work out...
If anyone was wondering, my laptop specs are:
NVIDIA GeForce 1050 Graphics Card
Intel HD 630 Graphics (osu! choosed this one as default)
Intel i5-7300 HQ Processor
1TB HD
User avatar
Rhythm Rookie
4 posts
Offline
Catzzye wrote:
TheBoiCold and patmethny1!
You have pretty similar laptop to mine! I've been having loads of issues with osu! myself, including this one you are currently experiencing! I am looking for a solution too, I really hope we can get this resolved. I am SOO glad that I am not alone with this issue, I was starting to lose hope... Death and I tried to resolve this, but didn't quite work out...
If anyone was wondering, my laptop specs are:
NVIDIA GeForce 1050 Graphics Card
Intel HD 630 Graphics (osu! choosed this one as default)
Intel i5-7300 HQ Processor
1TB HD

i think you have the exact same laptop that i do, makes sense that we would have the same problem.
User avatar
Whistle Blower
19 posts
Offline
Quote:
i think you have the exact same laptop that i do, makes sense that we would have the same problem.


I have dell inspiron 15 7567, the ones having the problem might be the dell inspiron 15 7000 series.


Btw, does any one of you guys also have problem like this?

t/685812

Just checking if it's the laptop's problem
User avatar
Rhythm Rookie
4 posts
Offline
patmethny1 wrote:
Quote:
i think you have the exact same laptop that i do, makes sense that we would have the same problem.


I have dell inspiron 15 7567, the ones having the problem might be the dell inspiron 15 7000 series.


Btw, does any one of you guys also have problem like this?

t/685812

Just checking if it's the laptop's problem

i don't seem to have that problem but yeah i do have the dell inspiron 15 7000 series.
User avatar
Beat Clicker
70 posts
Offline
TheBoiCold, patmethny1 and all others with the same issue, I finally found a solution.
By default osu! is running on our integrated graphics card, which was the issue.
You have to manually set it to your GTX 1050 or whichever one you have!
To do that you have to do the following:
1. Right click on your desktop and click NVIDIA Control Panel
2. Click Manage 3D Settings on the left and than go to Program Settings so you can modify settings for osu! specifically.
3. For the preferred graphics processor choose your main card, for me it's named "High-performance NVIDIA processor".
4. Follow EliteDonuts video on which settings to tweak there and which to leave alone: https://www.youtube.com/watch?v=7M5ASNTQTLU
5. Press Apply. Control Panel may freeze for few seconds in that time.
6. Everything should be fine now.

When using your main GPU, if you are locked at 60FPS and there isn't anything you can do to unlock that there are few possible solutions.
1. Use Display Driver Unistaller to uninstall your display drivers and then download and reinstall them again.
2. Disable Xbox DVR in Windows Setting or Xbox App settings (depends on the Windows 10 version)
3. Locate osu! executable or shortcut then right click it. Choose properties and in newly opened window choose Compacitbility. Now check "Disable fullscreen optimization".
4. If nothing worked go to Device Manager>Display Adapters. Now here disable Intel HD Graphics and than re enable them. This should fix your issue.
This one worked for me.


I hope this has helped you overcome this super frustrating issue. If you need any further help, you can ask me in game. Good luck! :)
User avatar
Whistle Blower
19 posts
Offline
Catzzye wrote:
TheBoiCold, patmethny1 and all others with the same issue, I finally found a solution.
By default osu! is running on our integrated graphics card, which was the issue.
You have to manually set it to your GTX 1050 or whichever one you have!
To do that you have to do the following:
1. Right click on your desktop and click NVIDIA Control Panel
2. Click Manage 3D Settings on the left and than go to Program Settings so you can modify settings for osu! specifically.
3. For the preferred graphics processor choose your main card, for me it's named "High-performance NVIDIA processor".
4. Follow EliteDonuts video on which settings to tweak there and which to leave alone: https://www.youtube.com/watch?v=7M5ASNTQTLU
5. Press Apply. Control Panel may freeze for few seconds in that time.
6. Everything should be fine now.

When using your main GPU, if you are locked at 60FPS and there isn't anything you can do to unlock that there are few possible solutions.
1. Use Display Driver Unistaller to uninstall your display drivers and then download and reinstall them again.
2. Disable Xbox DVR in Windows Setting or Xbox App settings (depends on the Windows 10 version)
3. Locate osu! executable or shortcut then right click it. Choose properties and in newly opened window choose Compacitbility. Now check "Disable fullscreen optimization".
4. If nothing worked go to Device Manager>Display Adapters. Now here disable Intel HD Graphics and than re enable them. This should fix your issue.
This one worked for me.


I hope this has helped you overcome this super frustrating issue. If you need any further help, you can ask me in game. Good luck! :)


The main problem is that another guy who has inspiron 15 7000 series like me also has a problem with osu screen freezing after alt+tabbing out of the game and back in when using gtx 1050ti...

But still, thanks for a step forward to resolving this issue!
User avatar
Slider Savant
107 posts
Offline
patmethny1 wrote:

The main problem is that another guy who has inspiron 15 7000 series like me also has a problem with osu screen freezing after alt+tabbing out of the game and back in when using gtx 1050ti...

But still, thanks for a step forward to resolving this issue!


That's me. I just ended up enabling compatibility mode and not using fullscreen and everything works ok now. Even after reinstalling Windows I still had the alt tab feeeze issue, but after turning on compatibility mode and not using fullscreen my latency is around 1.4 ms which is perfectly fine for me and I have little to no stutters. Good luck with fixing it.
User avatar
Whistle Blower
19 posts
Offline
Krypto wrote:
patmethny1 wrote:

The main problem is that another guy who has inspiron 15 7000 series like me also has a problem with osu screen freezing after alt+tabbing out of the game and back in when using gtx 1050ti...

But still, thanks for a step forward to resolving this issue!


That's me. I just ended up enabling compatibility mode and not using fullscreen and everything works ok now. Even after reinstalling Windows I still had the alt tab feeeze issue, but after turning on compatibility mode and not using fullscreen my latency is around 1.4 ms which is perfectly fine for me and I have little to no stutters. Good luck with fixing it.


I wonder why i get around 5ms latency.... thanks for the tip anyways
User avatar
Slider Savant
107 posts
Offline
patmethny1 wrote:

I wonder why i get around 5ms latency.... thanks for the tip anyways


Well, before I ever updated my Nvidia drivers to the latest version, I always got around 1-2 ms of latency with the drivers that were pre-installed with the laptop. As soon as I did update them, that's when I got around 4 ms of latency. After reinstalling Windows, my latency went back down. So honestly, I would try reinstalling Windows. Move everything you don't want to be wiped to the 1 TB HDD (D Drive) since the OS for me is on the C drive (the SSD) as the restoring process only affects the C drive. Here's a guide I used if you run out of any other options.

Just a warning though, if you're like me, then you'll still have the alt-tab freeze issue even after restoring, but my latency ended up going down. You could also do what I mentioned in the alt-tab thread (compatibility mode and/or no fullscreen) or re-installing osu! (back up your songs/.db/skin files first)

My Nvidia driver version is 23.21.13.8816 and was released on 30/10/17
Reply 14 posts

Users browsing this forum: None


Jump to: