Rhythm Rookie
2 posts
Offline
There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.
User avatar
Rhythm Rookie
2 posts
Offline
a0206021 wrote:
There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.




Works perfectly!!! Thanks so much!!!
User avatar
Rhythm Rookie
1 posts
Offline
a0206021 wrote:
There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.



No, don't works :c
User avatar
Whistle Blower
25 posts
Offline
a0206021 wrote:
There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.


It worked! Thank you so much!
User avatar
Rhythm Rookie
1 posts
Offline
a0206021 wrote:
There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.


Thank you!!! It works!
User avatar
Rhythm Rookie
1 posts
Offline
a0206021 wrote:
There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.


Does it matter what version of osu i'm using? I'm currently using the alpha release from 2016...
User avatar
Rhythm Rookie
3 posts
Offline
frankengwenny wrote:
a0206021 wrote:
There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.


Does it matter what version of osu i'm using? I'm currently using the alpha release from 2016...


No it doesn't.
User avatar
Tempo Trainee
5 posts
Offline
god bless PixelArray
User avatar
Rhythm Rookie
4 posts
Offline
a0206021 wrote:
There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.

mine doesn't work either.... :(
User avatar
Rhythm Rookie
1 posts
Offline
Gerardoesp wrote:
a0206021 wrote:
There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.


The above method works. Porting Kit is also useful to update the WineSkin version. WS9WineStaging2.16 works for me. Once Porting Kit is downloaded, use PixelArray's methods through 1,2,3,3 to download the newest wineskin. Then, go to the original osu!.app, right click-> Show Package Contents -> Double click on "Wineskin" -> Advanced -> Tools -> Change Engine Used -> Select "WS9WineStaging2.16" -> OK. Wait to complete. Finally, follow a0206021's method. This should work.
User avatar
Rhythm Rookie
1 posts
Offline
I found this AMAZING video: https://youtu.be/RDjWNWM3Y7w (1st solution 2:48-6:40)
You keep your Mac version, all your beatmaps and it is very short. He explains very well what happened.
This VERY SIMPLE solution worked for me after trying all these others long, boring and complicated solutions...
User avatar
Rhythm Rookie
1 posts
Offline
a0206021 wrote:
There is a problem in Wineskin in High Sierra, so osu! may fail to launch.

Here is the solution:
1.Right click on osu.app, and select "Show Package Contents"
2.double click Wineskin.app.
3.click "Set Screen Options"
4.uncheck "Auto Detect GPU for Direct 3D"
5.click "done" and quit the program

Then, it should work normally.


When I do it, it keeps running the osu!updater over and over. I'm using the alpha release from http://osuosx.tumblr.com/. Is there a reason to why this happens?
Last edited by Een Persoon on , edited 1 time in total.
Reply 42 posts jump | prev  1, 2, 3

Users browsing this forum: None


Jump to: