Tempo Trainee
7 posts
Offline
Hitsounds play starting on 10ms ticks, even when the timing of the object or the click were not.

I discovered this while trying to match hitsounds with audio by recording auto play the map.

I found that my hitsounds were 2ms late, pushed the objects up, and tested again. still 2ms late. This prompted some more tests, and my conclusion is that hitsounds will only play starting on 10ms intervals, regardless of object placement or click timing. Variance in the audio feedback by half the hit error margin makes me think it should be fixed, in addition to adding 5ms average hitsound latency.

Of course the first thing to be done is other people confirm that it isnt just my setup. I will provide relevant details if other people don't have this issue.

osu! version: 20170731.2 (latest)
User avatar
Support Team
1,005 posts
Offline
Did you test this with the default skin?
Tempo Trainee
7 posts
Offline
no, but I don't see why it should matter. brb testing. ok yes it happens with the default skin, same everything. want my test map?
User avatar
Support Team
1,005 posts
Offline
Karoo13 wrote:
no, but I don't see why it should matter.

There is a very high chance it does not matter, and in your case that is true, however, if you are using a poorly made skin, the actual hitsound files could have a delay.

Try disabling surround sound through Windows and any other separate driver program you may have for you headphones/speakers.
Tempo Trainee
7 posts
Offline
hitsound delay should also be irrelevant. I am using the default windows audio drivers with all effects disabled. here is my test map, which includes custom hitsounds:

https://puu.sh/y1uQz/e9aab2f6d3.osz

the song is a loud pulse every 400ms followed by 2 quieter ones 10 and 20ms later, panned right. the included hitsounds are just the loud pulse, panned left. The map's objects are spaced every 399ms rather than 400, so we should see hitsounds moving left by 1ms each click. I have tried unlimited frame limit and it does not change the result. I recorded auto playing the map and get this:

https://puu.sh/y1veD/63bdf654dd.mp3

if you look at the waveform, you will see the hitsounds moving left on average, but they jump in gaps of 10ms.
User avatar
19,090 posts
Offline
This could be something on your system causing issues (audio drivers etc.). Please check your runtime log file for any reports of audio interpolation failures
Tempo Trainee
7 posts
Offline
emails from support suggest it is a directsound thing -
Quote:
Windows' directsound precision is only 10ms post-XP

which may be intrinsic to directsound, or be due to the audio buffer size, which may be changeable though I don't know how.

A good followup would be to test whether this is due to audio buffer size by someone who can change it, and to test whether the problem applies to asio or waspi. until then, consider this post closed.
User avatar
19,090 posts
Offline
It's post windows 7, actually. osu! does its own interpolation on top of reported data to ensure higher precision. The only time it will "skip" 10ms or more is if the sync is drifting between what osu! expects from its interpolation.

This is a common issue in some audio hardware, where playback of the music track is not precise enough (ie. it plays 0.01% lower frequency than expected).

osu!'s tolerance for interpolation is around 11ms, so if it drifts 1ms or more you may notice snapping back to reported values.
Last edited by peppy on , edited 1 time in total.
Reply 8 posts

Users browsing this forum: None


Jump to: