117 posts jump | prev  1 ... 4, 5, 6, 7, 8
User avatar
Rhythm Rookie
1 posts
Offline
Osu just updated for me (automatically- the thing on the bottom had a "click here to restart") and now it won't load- every time I try to boot it up on my mac an error window pops up.
Here's an image of the error
It says:
"osu!.exe - .NET Framework Initialization Error"
"Unable to find a version of the runtime to run this application."

Do I need to re-download Osu, or is there a way to fix this bug?

(Edit: I'm playing on a Macbook pro with OS X El Capitan (10.11.6) and using xQuartz to play Osu.)
User avatar
Rhythm Rookie
1 posts
Offline
Please help with this glitch
User avatar
Whistle Blower
18 posts
Offline
Ateliesta wrote:
Osu just updated for me (automatically- the thing on the bottom had a "click here to restart") and now it won't load- every time I try to boot it up on my mac an error window pops up.
Here's an image of the error
It says:
"osu!.exe - .NET Framework Initialization Error"
"Unable to find a version of the runtime to run this application."

Do I need to re-download Osu, or is there a way to fix this bug?

(Edit: I'm playing on a Macbook pro with OS X El Capitan (10.11.6) and using xQuartz to play Osu.)

I experienced that problem too, you should re-download your osu! client. Then put osu!installer.exe file that can be found out in the Download page in osu.ppy.sh if you need to do so.
[ADDITIONAL]If there are any of the songs that you want to keep it, you should take it out from the package file you can see when you right-click apps, then back-up to another folder or drive in order to save it.
If it is reinstalled, maybe there can be one more crash(It happened to me, which my computer is OS Sierra), then you will need to login then manually put the song back. Then you can enjoy the game. Sorry that my English is not that fluent.
User avatar
Rhythm Rookie
1 posts
Offline
Hey I'm new to osu so excuse me if this isn't the right place to post.

I just downloaded osu for the mac osx and I've been downloading beatmaps, but for some reason, the beatmaps do not show up in my lists in game and I have no way to play them. I've put them in the osu!/drive_c/osu!/Songs folder (nowhere else) just for reference.

Thanks for the help!
User avatar
Whistle Blower
18 posts
Offline
Quatzil wrote:
Hey I'm new to osu so excuse me if this isn't the right place to post.

I just downloaded osu for the mac osx and I've been downloading beatmaps, but for some reason, the beatmaps do not show up in my lists in game and I have no way to play them. I've put them in the osu!/drive_c/osu!/Songs folder (nowhere else) just for reference.

Thanks for the help!

Did you try to press fn key and f5 key together? That is the way to restore your lost beatmap.
User avatar
Whistle Blower
18 posts
Offline
I got the problem which is making me get .NET Framework error(map is not restored even when I put backup file manually), or just opens Wineskin app.
User avatar
Rhythm Incarnate
546 posts
Offline
Reading this thread just makes me sad. I personally have three issues that doesn't really need to get fixed but if anyone's experiencing the same problem, hopefully this post would create some kind of empathy or something.
1. Taking screenshots in-game. It's either a good or bad; the screenshot is either fine or a black screen.
2. After 3-5 hours of play, sometimes the skin gets glitched out. Something like this. Some sliders turn transparent lmao.
screenshot
Image

3. Sometimes the game lags and the approach circle kinda glitches out. This one's pretty annoying.

Still using 2015 ver. Unstable release ver just doesn't work for me.
User avatar
Rhythm Rookie
2 posts
Offline
There is an issue on mac where it will start receiving keypresses outside of osu! instead of inside. This happens mid-map too, so it is very annoying. The only thing I have been able to do to keep them in-game is try to tap with my pen on the tablet or click with my mouse at every possible chance. This needs fixing, strongly
User avatar
Tempo Trainee
8 posts
Offline
I have had many of these same issues:
1. Keypresses randomly registering outside of osu mid song (particularly bad in mania)
2. When attempting to load a new map, it just infinitely loads and I have to manually delete the map from within osu to be able to play again
3. Random crashes on song select
4. Pretty severe input lag
5. Certain maps having wrong thumbnail or wrong C/B/A/S/SS ranks associated with them at select
6. The worst of them all, after updating from within client, the entire game gets broken with the .NET framework error and must be redownloaded :(

I've found a fix for #2 however, the issue is caused by a certain number of maps being skeletons (that is to say that they have a folder within the game, and they have a .mp3 and a background, but no .osu beatmap file). One of the ways that skeletons get created is by choosing the "Delete all visible beatmaps" at song select, but I'm sure there are others. Choosing this option will create skeletons of all the maps that you want to delete (I'm pretty sure other deletion options are fine). If you have a certain number of skeletons, new maps will not load. Here's how get rid of skeletons:
1. hit f5 at song select
2. If the song that starts playing mysteriously does not have a beatmap associated with it, then you have a skeleton
3. look at the name of the song playing in the top right corner of the main title screen, the song name should be the name of the .mp3 in the skeleton, this will help you find it
4. Go to your appilcations, right click on osu, click "Show Package Contents" then navigate to your songs folder and search for that .mp3 file's name
5. Once you find the beatmap, double check to make sure it's a skeleton (no .osu file inside) then manually delete
6. Hit f5 again to repeat

I once had to delete 50+ skeletons, not fun. Hopefully this will help some people and hold them over until lazer. (But seriously fuck the .NET framework init error, 4th time having to redownload this game)
User avatar
Tempo Trainee
10 posts
Offline
I have a problem with #2 as well! But pressing f5 (checking for new files) doesn't really take me to any 'skeleton', per se. But adding a new map still keeps me on "checking for new files" indefinitely. #sendhelp
User avatar
Star Shooter
189 posts
Offline
None of the OS X builds seem to work on mac OS Sierra.

For 2016-4-21, XQuartz opens, but that's it.

For 2015-10-17 it opens, but you can't drag in beatmaps.

For 2015-10-15, the file link seems to be removed.

Woo hoo.
User avatar
Tempo Trainee
10 posts
Offline
You're mostly right but there are a few corrections.
-Osu will open with xquartz, it just takes a while.
-At around 6700 beat maps, the game bugs out and gets stuck in processing. (Seems to be due to Sierra, it wasn't there before)
-Xquartz osu seems to be locked at 60fps due to vsync (beamsync aka 'metal' on Sierra) which can no longer be disabled (on Sierra). (Although for some reason latency on 2015 osu seems to be lower-maybe vsync doesn't affect it? Idk, will do some more testing)
Basically, please fix osu on mac.
Reply 117 posts jump | prev  1 ... 4, 5, 6, 7, 8

Users browsing this forum: None


Jump to: