User avatar
Whistle Blower
15 posts
Offline
It was working fine yesterday but it won't open today. How do I fix this?

My osu! is on Stable(Latest)
User avatar
Tempo Trainee
14 posts
Offline
Please provide more information. What exactly happened the day before? What did you do?
User avatar
Whistle Blower
15 posts
Offline
I didn't do anything. That's why I'm confused.
User avatar
Rhythm Incarnate
1,618 posts
Offline
Try running osu! as an administrator
User avatar
Whistle Blower
15 posts
Offline
It's really weird, it shows osu! at processes on Windows Task Manger then it suddenly disappears.
User avatar
Tempo Trainee
14 posts
Offline
Try clicking on osu! in the task manager, and end process, then try launching osu! again.

Also, try deleting osu!. If it interrupts you saying that osu! is still running, then you may have left it on in some way. If you delete osu, then restore it from the recycle bin, and try running osu!.
User avatar
Whistle Blower
15 posts
Offline
Sorry for late reply, I slept but the what Glowix said didn't work. Also, I tried to reinstall but even the installer won't open.
User avatar
Support Team
3,189 posts
Offline
Did you ever try restarting your computer once the issue started to happen?

Try looking on Event Viewer for any errors.
User avatar
Whistle Blower
15 posts
Offline
Yes, and I tried to reinstall. It open on Stable(Fallback) but after I updated it, it didn't open again.

Edit: I reinstalled and it opened on Stable(Fallback) but I updated it to Stable(Latest) and won't open again.
Please help.
User avatar
Rhythm Incarnate
1,799 posts
Offline
Try running the game in compatibility mode
Method 1: Launch Repair Dialog
  1. Hold down the Shift key on your keyboard.
  2. While holding Shift, double click the osu! icon on your desktop.
  3. Continue holding Shift until you see the recovery dialog prompt.
  4. From there, under Renderer, check "Compatibility mode"
    Image

Method 2: Shortcut
If you have the "repair osu!" Shortcut, opening that also works.
Image


Method 3: Config Shortcut
If you don't have the "repair osu!" Shortcut, you can create one instead.
  1. Right click osu!.exe > Create a shortcut
  2. Open properties of the shortcut
    1. Select then Alt + Enter or
    2. Right click > Properties
  3. Set Target to ...\osu!.exe -config
  4. Press OK then open the shortcut


Method 4: Text document
You can also force the updater to run by creating a new text document in your osu! folder called "help". Right-click in an empty space in your osu! folder, and choose New > Text Document.
Image
Name it help and then run osu! to start the updater in forced maintenance mode.
Image
User avatar
Rhythm Incarnate
1,826 posts
Offline
If there is no Compatibility Mode option in the recovery dialog, go to your osu! folder and open the "osu!.username.cfg" file with notepad.

From there, change the CompatibilityContext line to 1. ( CompatibilityContext = 1)
User avatar
Whistle Blower
15 posts
Offline
Kao wrote:
Try running the game in compatibility mode
Method 1: Launch Repair Dialog
  1. Hold down the Shift key on your keyboard.
  2. While holding Shift, double click the osu! icon on your desktop.
  3. Continue holding Shift until you see the recovery dialog prompt.
  4. From there, under Renderer, check "Compatibility mode"
    Image

Method 2: Shortcut
If you have the "repair osu!" Shortcut, opening that also works.
Image


Method 3: Config Shortcut
If you don't have the "repair osu!" Shortcut, you can create one instead.
  1. Right click osu!.exe > Create a shortcut
  2. Open properties of the shortcut
    1. Select then Alt + Enter or
    2. Right click > Properties
  3. Set Target to ...\osu!.exe -config
  4. Press OK then open the shortcut


Method 4: Text document
You can also force the updater to run by creating a new text document in your osu! folder called "help". Right-click in an empty space in your osu! folder, and choose New > Text Document.
Image
Name it help and then run osu! to start the updater in forced maintenance mode.
Image


Method 1:
Didn't open

Method 2:
Also didn't open

Method 3:
Also didn't open

Method 4:
osu didn't even open

What I've noticed is that the process of osu! in the background runs then suddenly it disappears.
Also, thank you for giving the effort to help me. :D
Reply 12 posts

Users browsing this forum: None


Jump to: