User avatar
Tempo Trainee
8 posts
Offline
Problem Details: osu! keeps crashing when I open it, i haven't played it in a couple of weeks.



Video or screenshot showing the problem: crashlog:

OpenTK.Graphics.GraphicsContextException: [EGL] Failed to create window surface, error BAD_NATIVE_WINDOW.
at OpenTK.Platform.Egl.EglWindowInfo.CreateWindowSurface(IntPtr config)
at OpenTK.Platform.Egl.EglContext..ctor(GraphicsMode mode, EglWindowInfo window, IGraphicsContext sharedContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
at OpenTK.Platform.Egl.EglAnglePlatformFactory.CreateGLContext(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Boolean directRendering, Int32 major, Int32 minor, GraphicsContextFlags flags)
at OpenTK.Graphics.GraphicsContext..ctor(GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Int32 major, Int32 minor, GraphicsContextFlags flags)
at #=qH8MHUwc4s4AIOP8embIm_LZVJ1hcXHmXvQ4kbKKaWdXEAILiwIKAGYcIN5xQJXaQ.#=qqvWHIjTJ11kNQjXagY2F3Q==(Int32 #=qziYoDwk$PYjdOkqhyQIonw==, Int32 #=qAxkx7SJqQSowL0CnPp7gGg==, GraphicsContextFlags #=q0r5I1MdApGtJ54aGgOdCjQ==)
at #=qJlnuD_UcXRoElpm2icUN$xv4mHIVbAIXw0qJaXX4M17Nt6UwoiS1Agm0IcyQ69sI.OnHandleCreated(EventArgs #=q3m$_0fTukzAo40eVgKKt8A==)
at #=qmcB6XnfGcdT$_fSIuP8CBToueKpBlR5PlfKTI7deIJL42oV_a3A$j0BVEdXueDJp.OnHandleCreated(EventArgs #=q3m$_0fTukzAo40eVgKKt8A==)
at System.Windows.Forms.Control.WmCreate(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmCreate(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at #=qi17YWq5DpjzsdfsVCMbOCKlTKzi5JL1aNh1uHTzjAi0=.WndProc(Message& #=qKFgFOP_7pGMr0NtKdRHygA==)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
User avatar
Support Team
3,200 posts
Offline
Go into your osu!.pcname.cfg file and change Fullscreen mode to 0. Save, and restart.

This should fix your issue, but is only a temporary workaround as playing non-fullscreen is not recommended. If you are on Windows 7 or Vista, You can disable the aero theme and that will improve windowed performance. You cannot do this in 8+ though.

Do you also get the error "Can't find name of Intel GL Driver" (or something similar) ?
User avatar
Tempo Trainee
8 posts
Offline
Yes, I do get the error
User avatar
Support Team
3,200 posts
Offline
VortexCircle wrote:
Yes, I do get the error


Ok, Follow my workaround until further notice.
User avatar
Tempo Trainee
8 posts
Offline
I've already done that. It only gives me the error (and the same crashlog).
User avatar
Support Team
3,200 posts
Offline
VortexCircle wrote:
I've already done that. It only gives me the error (and the same crashlog).


Try enabling Letterboxing or change your resolution lower than native?
User avatar
Tempo Trainee
8 posts
Offline
Nothing really works :/
Cymbal Sounder
42 posts
Offline
I'm in the same boat :/ But a temporary workaround for me was reinstallng intel's drivers; it made it work for a little bit but not for too long.
Cymbal Sounder
42 posts
Offline
Sorry to revive but it's not too old and I found the solution.

Right click osu and click properties. Then click open file location. Then edit the osu!.(System Name).cfg file. Change compatibility context from 1 to 0.
User avatar
Support Team
3,200 posts
Offline
Phx_Blaster007 wrote:
Sorry to revive but it's not too old and I found the solution.

Right click osu and click properties. Then click open file location. Then edit the osu!.(System Name).cfg file. Change compatibility context from 1 to 0.


That's one of the known current fixes.

I forgot to mention it though because this issue is everywhere and it's hard to keep track lol
User avatar
Rhythm Incarnate
1,388 posts
Offline
Mby try to reinstall osu but deleting all files in osu! folder excluding songs, skins, screenshots and chat. Delete hidden Data folder too, now you can run installer and install osu! after install you'll have your maps, skins etc. and mby game will runs,
User avatar
Support Team
3,200 posts
Offline
Venix wrote:
Mby try to reinstall osu but deleting all files in osu! folder excluding songs, skins, screenshots and chat. Delete hidden Data folder too, now you can run installer and install osu! after install you'll have your maps, skins etc. and mby game will runs,


Don't suggest reinstalling as it almost never works.

Especially with this known issue.

I keep seeing you post with "Maybe this, Maybe that." Unless a post hasn't had any responses for a bit, try having self control and avoiding posting suggestions unless you KNOW what's wrong and how to fix it. Thanks
User avatar
Rhythm Incarnate
1,388 posts
Offline
Dntm8kmeeatu wrote:
Venix wrote:
Mby try to reinstall osu but deleting all files in osu! folder excluding songs, skins, screenshots and chat. Delete hidden Data folder too, now you can run installer and install osu! after install you'll have your maps, skins etc. and mby game will runs,


Don't suggest reinstalling as it almost never works.

Especially with this known issue.

I keep seeing you post with "Maybe this, Maybe that." Unless a post hasn't had any responses for a bit, try having self control and avoiding posting suggestions unless you KNOW what's wrong and how to fix it. Thanks


What's wrong with it? Suggestion can help too...

And yea I'm mainly replying to problems which I had.
Reply 13 posts

Users browsing this forum: None


Jump to: