User avatar
Rhythm Incarnate
566 posts
Offline
Problem Details: Hi there! So I was editing a new map when I realized I was having a bug when adding a New Combo. It's not a real issue but since I "know" how to program, I think you guys might want to fix it aswell. It's pretty simple to understand. Let me explain better. (This is the map -> https://osu.ppy.sh/s/585408 )

First of all I copied 8 circles, starting with a NC. Then pasted it.

Image

After that if I copy the same bunch of circles but previous to the current ones, I get a new combo on the (8) circle, which shouldn't be happening. Note that there're breaks from both left and right sides.

Image

However if I paste the circle inbetween 2 NC the bug doesn't seem to appear.

Image
Image

So yeah.. that's all I guess.

PD: I was trying to get more into detail and realized that this only happened when there was a break previous to some notes.

Image
Image
Image

However after a 1/1 distance snap, the bug seems to be fixed.

Image

PD2: Tried to replicate on another map and it seems to happen but inverted. (This map -> https://osu.ppy.sh/b/1106276 )

Image
Image

Hope I explained myself right so you guys can fix it! :)

osu! version: 20170222.3 (latest)
User avatar
Rhythm Incarnate
1,554 posts
Offline
This isn't a bug, this is intended behaviour. When you copy the first 8 objects you have to realize the first object has the option New Combo toggled, so when you copy that circle the new combo feature is copied along with it. This happens with hitsounds as well. It's not very hard to fix anyways all you have to do is click the circle and remove the NC.
Reply 2 posts

Users browsing this forum: None


Jump to: