forum

[Archived] Custom fps limit

posted
Total Posts
15
Topic Starter
evie-chan
Problem details:
The custom fps limit was removed and i get lag and lag spikes when using optimal 480fps, but 120fps is too much delay, please bring it back D:

Video or screenshot showing the problem:
https://osu.ppy.sh/ss/14209166/a552

osu! version: Stable 20191206 (latest)
Death
You can set a custom frame limit by editing the "osu!.<username>.cfg" file in your installation folder and setting these lines accordingly:
CustomFrameLimit = 240

FrameSync = Custom

Just change the value of CustomFrameLimit to whatever number you want.

Make sure you close the game before opening and modifying this file or it might not work. Also make sure to save the file after you are done.
Topic Starter
evie-chan
it doesnt work anymore... https://cdn.discordapp.com/attachments/650363149987479591/653198214077480981/owo.JPG
and even when i start osu it doesnt show up
Magnus Cosmos

It's still there for me, I'm on cutting edge though, but I'm pretty sure stable should still have it as well
Death
I just tested it and it still works. If it didn't work for you it's most likely because you didn't open and modify the file after you closed the game or you didn't save it after you were done making changes.

Pretty sure the game will still cap to a different value in the menu (optimal or power saving), but while actually playing it should cap to whatever value you set as your custom frame limit.
Topic Starter
evie-chan
that doesnt happen for me tho, i have 0 idea why
i change the limit while im not in game, open it again, and its still 480fps in game
Death
Don't open the file until after you have the game closed, save it before you reopen the game, and test by starting a map rather than just looking in the menu. Make sure you are also changing the correct line to "Custom". It's possible you have a FrameSync and FrameSyncGL in that file, but the latter won't do anything.
Topic Starter
evie-chan
i tested by starting a map im not stupid
Death
Didn't say you were stupid. If it's not working then something was missed and it's a good idea to cover all bases.
Astellis
Since this is working for more than just one person we are just trying to figure out what is different, giving clear instructions is better for eliminating silly things that can be overlooked... no offence was ment
Niggle
They updated the game again, now its showing 240fps in main menu and over 240 when in game
(for me).

Steps I did.

Close osu.

Open "osu!.PCNAME.cfg" with an editor.

Try to look at your config again and ctrl+f, type in "FrameSync" and enter.

Change it the value after FrameSync: to "Custom".


Also look for "CustomFrameLimit".

Change the value of that to "999".

Ctrl+S to save the cfg.

Open up osu again, don't do anything else and play a beatmap.

If your not getting a max fps of 999 then try repairing osu!.
UnpopularBloom0

Death wrote:

You can set a custom frame limit by editing the "osu!.<username>.cfg" file in your installation folder and setting these lines accordingly:
CustomFrameLimit = 240

FrameSync = Custom

Just change the value of CustomFrameLimit to whatever number you want.

Make sure you close the game before opening and modifying this file or it might not work. Also make sure to save the file after you are done.
Basically after you do this, it will still cap to either 280 or whatever fps in the menu, but when you start a map, it will actually be the framelimit you set, and i think if the framelimit you set is higher than 1000 then it will only show whatever your monitors refresh rate is but it will still be using the frame limit you set.
Death

UnpopularBloom0 wrote:

Basically after you do this, it will still cap to either 280 or whatever fps in the menu, but when you start a map, it will actually be the framelimit you set, and i think if the framelimit you set is higher than 1000 then it will only show whatever your monitors refresh rate is but it will still be using the frame limit you set.
Yes, it will still cap in the menu, that is correct. That is precisely why I mentioned in this thread that you should start a map to test if the limit is working and not just use the menu. The monitor refresh rate thing is what happens when you use unlimited as well.
QueneX
Its not working me at all, could someone please help me, when i put in the CustomFrameLimit 1000 it doesn't show or anything please help.
Death
Did you change the other line that is mentioned in this post? Pretty sure the custom frame limit caps at 999 as well.
Please sign in to reply.

New reply