[Archived] W7 Gameplay -> CHOPPY x(

posted
Total Posts
20
Topic Starter
Pharaphobia
Hello!:))

This is my current PC spec
Core 2 Duo 2.15Ghz CPU
4GB DDR2 800Mhz (Dual Channel)
GeForce 210 1GB GDDR3 GFx
WD 220GB HDD

I freshly installed Windows 7 Ultimate 64 bit and I found that my osu! gameplay is very choppy even i have 500+ fps

What I tryed:
Disable enable aero
Vsync in nVidia drivers (running on it cause the choppy is on minimum now)
fullscreen works pretty good but i prefer playing in windowed mode

SO please is there any help?:))
Gabe
What do you mean by "choppy"?
Can you give more details please?
Topic Starter
Pharaphobia

Gabe wrote:

What do you mean by "choppy"?
Can you give more details please?
Well even i have 400-500 fps it looks like 30-40 it feels rly unsmooth
Topic Starter
Pharaphobia
noone helps?:(
WASSHOI
Change computer power settings to high performance in the control panel. What programs do you tend to run in the background? What anti-virus?

When you open taskmanager, please tell me what your CPU% is as well as physical memory%

First thing I'd do to take care of computer speed issue would be to do a quick cleanup and small error fixing.
Click Start -> Run and paste "SFC /SCANNOW" into the run box without quotes. This will run a check on your system files that may take some time, but it'll fix any issues spotted.

Next, it'd help if you grabbed a nice program known as CCleaner. This cleans up junk that Windows tends to leave laying around on your system, which can help. Also do a registry clean for fixing clutter in your registry (you'll need to scan for issues first before the option to fix issues becomes available).

Next, use the Tools tab of Ccleaner to uninstall programs you no longer use. While you're there, go to the Startup tab and disable programs you know you don't need starting as soon as you turn your computer on (don't disable something if you're unsure what it is).

If you wanna tweak around with windows a little for a little more speed, you could try following this guide:


Be careful about the things you're disabling, ask questions if you're unsure about something there. There can be many reasons as to why your computer isn't running up to speed, we'll need to troubleshoot a little.
Topic Starter
Pharaphobia
Power settings didnt affect anything since its desktop PC...:)

Backround programs are usually facebook on firefox+skype

Average load of CPU when im playing osu with mentioned programs CPU 30-35% and memory between 45-50%

Anti-Virus is free Avast anti-virus http://avast.cz

CCleaner is good but ive got AVG PC Tuneup Pro version for this :>

Btw.I forget to mention that instalation of W7 was 2 days ago ^^ there shoudn't be any junks
Topic Starter
Pharaphobia
bump
Sakura
Please dont bump threads after only a few hours.
Topic Starter
Pharaphobia
-.- well I wanna play some songs but its impossible :))
Sakura
Patience is a virtue.

The only real thing i can suggest is to update your computer, but it's already pretty good, i also have windows 7 and have lower specs, yet i dont experience these issues so im not sure what's different on your computer, are you running any background programs? (specially things like XFire)
Ephemeral
make sure pre-rendered frames in nvidia settings is at 0/1 (whichever is available and is lower)

it sounds like something is taxing your cpu excessively while playing.. try disabling your antivirus. alternatively, try playing with a frame limiter (vsync) active instead. there's a lot of things this could be, though i doubt it is any issue with the client itself.
merchat7
How did you disable aero? Since you said it works nicely full screen, this should have solve your problem when playing in window mode. Did you go to personalization panel and set theme to windows 7 basic?

You can also manually set this per program by right clicking an icon > properties > compatibility > disable desktop composition.

Make sure v-sync is off and frame limiter is set to unlimited when trying above solutions.
WASSHOI

Pharaphobia wrote:

Power settings didnt affect anything since its desktop PC...:)
Even desktops should have a power setting in Windows 7. Try disabling Avast temporarily while playing osu! and post your results. Avast is known to not be the most quiet of antivisus programs to run in the background, and may be causing lag spikes.
peppy
If it's choppy, you need vsync.
Topic Starter
Pharaphobia

WASSHOI wrote:

Pharaphobia wrote:

Power settings didnt affect anything since its desktop PC...:)
Even desktops should have a power setting in Windows 7. Try disabling Avast temporarily while playing osu! and post your results. Avast is known to not be the most quiet of antivisus programs to run in the background, and may be causing lag spikes.
Recommend me some other anti-virus than :))) I wanna replace it for long time =)
Topic Starter
Pharaphobia

peppy wrote:

If it's choppy, you need vsync.
Peppy with Vsync its good smooth with vsync enabled in osu too but my mouse is delayed than
WASSHOI

Pharaphobia wrote:

Recommend me some other anti-virus than :))) I wanna replace it for long time =)
Microsoft Security Essentials

Be sure to uninstall your previous anti-virus before installing your new one. Having two anti-virus programs running at the same time creates problems.
peppy
If you are getting choppiness without vsync enabled, your only option is to enable it, or turn down pre-render frames in your graphics driver settings.
Topic Starter
Pharaphobia

peppy wrote:

If you are getting choppiness without vsync enabled, your only option is to enable it, or turn down pre-render frames in your graphics driver settings.
Solved by: Full screen


BUT still its stupid how can one operating system ruin my game when i had Windows XP Pro SP2 it was okay and smooth in windowed mode :(
peppy
Try switching off aero (force windows to use Windows Classic). It should then performa in the exact same way you'd expect from XP etc.
Please sign in to reply.

New reply